summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2024-02-20 03:22:20 +0100
committertytan6522024-02-20 15:36:37 +0100
commit58dd392d7f340e6ca1db22215952b6b75a5993e9 (patch)
tree8bf1342be5190c99bcd63f92487d8a9a7a30801f
parent8766081a889b6f5857b997ebc1c1acfd2999dc16 (diff)
downloadaur-cef-minimal-obs-bin.tar.gz
Force _FORTIFY_SOURCE level 2
libcef.so uses malloc_usable_size so it won’t build with fortification level set to 3. See also: https://rfc.archlinux.page/0017-increase-fortification-level/ https://archlinux.org/todo/prepare-packages-for-d_fortify_source3/ https://gitlab.archlinux.org/archlinux/devtools/-/merge_requests/191
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df436fb55071..817a2b557b42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,6 +64,10 @@ prepare() {
build() {
cd "${srcdir}/cef_binary_${_cefbranch}_linux_${CARCH}"
+ # this uses malloc_usable_size, which is incompatible with fortification level 3
+ export CFLAGS="${CFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
+ export CXXFLAGS="${CXXFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
+
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DPROJECT_ARCH=$CARCH .