summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-09-07 11:33:32 +0200
committertytan6522022-09-07 11:49:51 +0200
commit363ca9c4fb1aa21cd6f1cc51b901b6dda1c4ac9e (patch)
tree7824b19af59bfd7b3a06f4cbc2e45f76bb60ad87
parent8730bd2f621944e1bc096a72c9e5a6e2d5e338b9 (diff)
downloadaur-363ca9c4fb1aa21cd6f1cc51b901b6dda1c4ac9e.tar.gz
build: Fix file permission
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD48
2 files changed, 41 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d84ac3b484ea..668aa04206b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = cef-minimal-obs-bin
pkgdesc = Chromium Embedded Framework minimal release needed by OBS Studio release in /opt/cef-obs
pkgver = 103.0.0_5060_shared_textures_143.2591+g4204d54+chromium_103.0.5060.134_1
- pkgrel = 1
- url = https://bitbucket.org/chromiumembedded/cef
+ pkgrel = 2
+ url = https://github.com/obsproject/cef/tree/5060-shared-textures
arch = x86_64
license = BSD
makedepends = cmake
diff --git a/PKGBUILD b/PKGBUILD
index 2ed2aa1a2aa5..aeb6cb1b8281 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,10 @@ _cefbranch="5060"
_chromiumver="103.0.${_cefbranch}.134"
_rebuild="1" # The tarball sometime can get rebuild by OBS Project
pkgver="${_version}+g${_commit}+chromium_${_chromiumver}_${_rebuild}"
-pkgrel=1
+pkgrel=2
pkgdesc="Chromium Embedded Framework minimal release needed by OBS Studio release in /opt/cef-obs"
arch=("x86_64")
-url="https://bitbucket.org/chromiumembedded/cef"
+url="https://github.com/obsproject/cef/tree/5060-shared-textures"
license=("BSD")
depends=("nss" "alsa-lib" "pango" "libxrandr" "libxcomposite"
"at-spi2-atk" "libxkbcommon" "libcups" "mesa")
@@ -35,21 +35,51 @@ elif [[ $CARCH == 'aarch64' ]]; then
_parch=arm64
fi
+prepare() {
+ cd "$srcdir"/cef_binary_${_cefbranch}_linux${_arch}
+
+ # Fix permissions
+ chmod 755 Release
+ chmod 755 Resources
+ chmod 755 Resources/locales
+ chmod 755 include
+ chmod 755 include/base
+ chmod 755 include/base/internal
+ chmod 755 include/capi
+ chmod 755 include/capi/test
+ chmod 755 include/capi/views
+ chmod 755 include/internal
+ chmod 755 include/test
+ chmod 755 include/views
+ chmod 755 include/wrapper
+
+ # Remove pre-built wrapper
+ rm -rf build
+}
+
build() {
- cd "$srcdir"/cef_binary_${_cefbranch}_linux${_arch}
+ cd "$srcdir"/cef_binary_${_cefbranch}_linux${_arch}
- #The arm64 CEF set the wrong arch for the project
- cmake \
+ #The arm64 CEF set the wrong arch for the project
+ cmake \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DPROJECT_ARCH=$_parch .
- make libcef_dll_wrapper
+ make libcef_dll_wrapper
+
+ # Remove unneeded generated files
+ rm -f CMakeCache.txt Makefile cmake_install.cmake
+ rm -rf CMakeFiles
+
+ cd libcef_dll_wrapper
+ rm -f Makefile cmake_install.cmake
+ rm -rf CMakeFiles
}
package() {
mkdir -p "$pkgdir"/opt/cef-obs/
- cp -R "$srcdir"/cef_binary_${_cefbranch}_linux${_arch}/* "$pkgdir"/opt/cef-obs
- rm -rf "$pkgdir"/opt/cef-obs/CMakeFiles
- rm -rf "$pkgdir"/opt/cef-obs/libcef_dll_wrapper/CMakeFiles
+ cp -a "$srcdir"/cef_binary_${_cefbranch}_linux${_arch}/* "$pkgdir"/opt/cef-obs
+ rm -f "$pkgdir"/opt/cef-obs/CMakeLists.txt "$pkgdir"/opt/cef-obs/LICENSE.txt "$pkgdir"/opt/cef-obs/README.txt
+ rm -rf "$pkgdir"/opt/cef-obs/cmake
install -Dm644 "$srcdir"/cef_binary_${_cefbranch}_linux${_arch}/LICENSE.txt "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
}