summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522023-10-07 19:59:53 +0200
committertytan6522023-10-07 19:59:53 +0200
commit3cbec5b23e26fefea68f1d19c9876a1e853fcc8d (patch)
treeb78466f823c0b5ac701fc300504e01189569b106
parent2335dc2fe2563dddf8c1ebdbb57cac035fb03a37 (diff)
downloadaur-3cbec5b23e26fefea68f1d19c9876a1e853fcc8d.tar.gz
build: Fix CVEs
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 898c92b3e8f2..9b2d22dbf89e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cef-minimal-obs-bin
pkgdesc = Chromium Embedded Framework minimal release needed by OBS Studio release in /opt/cef-obs
- pkgver = 103.0.0_5060_shared_textures_143.2591+g4204d54+chromium_103.0.5060.134_1
- pkgrel = 6
+ pkgver = 103.0.0_5060_shared_textures_2594+gc69ad37+chromium_103.0.5060.134_1
+ pkgrel = 1
url = https://github.com/obsproject/cef/tree/5060-shared-textures
arch = x86_64
arch = aarch64
@@ -28,14 +28,14 @@ pkgbase = cef-minimal-obs-bin
depends = nspr
depends = nss
depends = wayland
- provides = cef-minimal-obs=103.0.0_5060_shared_textures_143.2591+g4204d54+chromium_103.0.5060.134_1
+ provides = cef-minimal-obs=103.0.0_5060_shared_textures_2594+gc69ad37+chromium_103.0.5060.134_1
conflicts = cef-minimal-obs
options = !lto
options = !strip
options = debug
- source_x86_64 = https://cdn-fastly.obsproject.com/downloads/cef_binary_5060_linux_x86_64.tar.xz
- sha256sums_x86_64 = bf4aa9388bab7e94fa945cc3bba16b6da63b6a30f9c0342d42235468b39d84bf
- source_aarch64 = https://cdn-fastly.obsproject.com/downloads/cef_binary_5060_linux_aarch64.tar.xz
- sha256sums_aarch64 = 68d915c9ba2639cba762a54cd3430fce2527aa6355d831d3cfcb6157664206b0
+ source_x86_64 = https://cdn-fastly.obsproject.com/downloads/cef_binary_5060_linux_x86_64_v2.tar.xz
+ sha256sums_x86_64 = 4bee4c90edbdb67b889be28ba1c1558fa6b207ca01d921db9beab342873aa57d
+ source_aarch64 = https://cdn-fastly.obsproject.com/downloads/cef_binary_5060_linux_aarch64_v2.tar.xz
+ sha256sums_aarch64 = c07ada8e18633308771d592d0313c6fb17d5805448e8921ebc51afb19e0e429e
pkgname = cef-minimal-obs-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8a727ea2e906..2a5b2bbd622f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: tytan652 <tytan652 at tytanium dot xyz>
pkgname=cef-minimal-obs-bin
-_cefver="103.0.0-5060-shared-textures_143.2591"
+_cefver="103.0.0-5060-shared-textures_2594"
_version=${_cefver//-/_}
-_commit="4204d54"
+_commit="c69ad37"
_cefbranch="5060"
_chromiumver="103.0.${_cefbranch}.134"
_rebuild="1" # The tarball sometime can get rebuild by OBS Project
pkgver="${_version}+g${_commit}+chromium_${_chromiumver}_${_rebuild}"
-pkgrel=6
+pkgrel=1
pkgdesc="Chromium Embedded Framework minimal release needed by OBS Studio release in /opt/cef-obs"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/cef/tree/5060-shared-textures"
@@ -24,10 +24,10 @@ provides=("cef-minimal-obs=$pkgver")
conflicts=("cef-minimal-obs")
# Prevent people from using link time optimisation for this package because it make OBS unable to be built against it
options=('!lto' '!strip' 'debug')
-source_x86_64=("https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux_x86_64.tar.xz")
-source_aarch64=("https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux_aarch64.tar.xz")
-sha256sums_x86_64=("bf4aa9388bab7e94fa945cc3bba16b6da63b6a30f9c0342d42235468b39d84bf")
-sha256sums_aarch64=("68d915c9ba2639cba762a54cd3430fce2527aa6355d831d3cfcb6157664206b0")
+source_x86_64=("https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux_x86_64_v2.tar.xz")
+source_aarch64=("https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux_aarch64_v2.tar.xz")
+sha256sums_x86_64=("4bee4c90edbdb67b889be28ba1c1558fa6b207ca01d921db9beab342873aa57d")
+sha256sums_aarch64=("c07ada8e18633308771d592d0313c6fb17d5805448e8921ebc51afb19e0e429e")
prepare() {
cd "${srcdir}/cef_binary_${_cefbranch}_linux_${CARCH}"