summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-06-04 21:38:08 +0200
committertytan6522021-06-04 21:38:08 +0200
commit9c40626808eeb8612dd70157fe092a933418f4d7 (patch)
tree443649c553aeda91ec56754e1b6d4b2bade1fc61
parent7d129b7d100beaee15603b3b02ed7e6034d5d9e9 (diff)
downloadaur-9c40626808eeb8612dd70157fe092a933418f4d7.tar.gz
fix: Set project architecture for cmake
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b613ef6fe1c3..c8158d190dca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,10 +26,13 @@ sha256sums_aarch64=("eb7ed49a020f06b54d4561a7d6811fa78b518035449c16a1cfd687cd3b2
if [[ $CARCH == 'x86_64' ]]; then
_arch=64
+ _parch=x86_64
elif [[ $CARCH == 'i686' ]]; then
_arch=32
+ _parch=x86
elif [[ $CARCH == 'aarch64' ]]; then
_arch=arm64
+ _parch=arm64
fi
prepare() {
@@ -39,7 +42,10 @@ prepare() {
build() {
cd "$srcdir"/cef_binary_${_cefver}_linux${_arch}_minimal
- cmake .
+
+ #The arm64 CEF set the wrong arch for the project
+ cmake -DPROJECT_ARCH=$_parch .
+
make libcef_dll_wrapper
}