summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-02-04 11:41:40 +0100
committertytan6522022-02-04 11:41:40 +0100
commitb1e3e57a5fafdcbde221295e6976e64c835e10b7 (patch)
tree89b57ac2df37d6dcac1f2345e54cd202341117a4
parentcf7bf2b96a518c9f34441c4e5461be59dcb3318e (diff)
downloadaur-b1e3e57a5fafdcbde221295e6976e64c835e10b7.tar.gz
build: Enable debug symbol
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a66c40ee617..e37f8b248604 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cef-minimal-obs-bin
pkgdesc = Chromium Embedded Framework minimal release needed by OBS Studio release in /opt/cef-obs
- pkgver = 87.1.14+ga29e9a3+chromium_87.0.4280.141
- pkgrel = 3
+ pkgver = 87.1.14+ga29e9a3+chromium_87.0.4280.141_1
+ pkgrel = 1
url = https://bitbucket.org/chromiumembedded/cef
arch = i686
arch = x86_64
@@ -17,9 +17,11 @@ pkgbase = cef-minimal-obs-bin
depends = libxkbcommon
depends = libcups
depends = mesa
- provides = cef-minimal-obs=87.1.14
+ provides = cef-minimal-obs=87.1.14+ga29e9a3+chromium_87.0.4280.141_1
conflicts = cef-minimal-obs
options = !lto
+ options = !strip
+ options = debug
source_i686 = https://cef-builds.spotifycdn.com/cef_binary_87.1.14+ga29e9a3+chromium-87.0.4280.141_linux32_minimal.tar.bz2
sha256sums_i686 = a214a7a180b2c1cd9b9009e23aac6462e813d9334995b7d8bbf4ecf335aa8b12
source_x86_64 = https://cef-builds.spotifycdn.com/cef_binary_87.1.14+ga29e9a3+chromium-87.0.4280.141_linux64_minimal.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
index 1398b607992d..dd7ca1e5954d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,9 @@ _version="87.1.14"
_commit="a29e9a3"
_chromiumver="87.0.4280.141"
_cefver="${_version}+g${_commit}+chromium-${_chromiumver}"
-pkgver=`echo "$_cefver" | tr - _`
-pkgrel=3
+_rebuild="1" # The tarball sometime can get rebuild by OBS Project
+pkgver="${_cefver//-/_}_${_rebuild}"
+pkgrel=1
pkgdesc="Chromium Embedded Framework minimal release needed by OBS Studio release in /opt/cef-obs"
arch=("i686" "x86_64" "aarch64")
url="https://bitbucket.org/chromiumembedded/cef"
@@ -14,10 +15,10 @@ license=("BSD")
depends=("nss" "alsa-lib" "pango" "libxrandr" "libxcomposite"
"at-spi2-atk" "libxkbcommon" "libcups" "mesa")
makedepends=("cmake")
-provides=("cef-minimal-obs=$_version")
+provides=("cef-minimal-obs=$pkgver")
conflicts=("cef-minimal-obs")
# Prevent people from using link time optimisation for this package because it make OBS unable to be built against it
-options=('!lto')
+options=('!lto' '!strip' 'debug')
source_x86_64=("https://cef-builds.spotifycdn.com/cef_binary_${_cefver}_linux64_minimal.tar.bz2")
source_i686=("https://cef-builds.spotifycdn.com/cef_binary_${_cefver}_linux32_minimal.tar.bz2")
source_aarch64=("https://cef-builds.spotifycdn.com/cef_binary_${_cefver}_linuxarm64_minimal.tar.bz2")
@@ -45,7 +46,9 @@ build() {
cd "$srcdir"/cef_binary_${_cefver}_linux${_arch}_minimal
#The arm64 CEF set the wrong arch for the project
- cmake -DPROJECT_ARCH=$_parch .
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DPROJECT_ARCH=$_parch .
make libcef_dll_wrapper
}