summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-11-07 17:30:40 +0100
committertytan6522021-11-07 17:30:40 +0100
commitcf7bf2b96a518c9f34441c4e5461be59dcb3318e (patch)
tree175133186de83ee83ef8f08214dbbf82e5f571d8
parentceefc615c269a90ef44ee9d9f69e1b58474c3d29 (diff)
downloadaur-cf7bf2b96a518c9f34441c4e5461be59dcb3318e.tar.gz
build: Cleanup
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fda069520b7f..1a66c40ee617 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = cef-minimal-obs-bin
pkgdesc = Chromium Embedded Framework minimal release needed by OBS Studio release in /opt/cef-obs
pkgver = 87.1.14+ga29e9a3+chromium_87.0.4280.141
- pkgrel = 2
+ pkgrel = 3
url = https://bitbucket.org/chromiumembedded/cef
arch = i686
arch = x86_64
arch = aarch64
license = BSD
makedepends = cmake
- makedepends = make
depends = nss
depends = alsa-lib
depends = pango
diff --git a/PKGBUILD b/PKGBUILD
index 85caeb28ed1b..1398b607992d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,17 @@ _commit="a29e9a3"
_chromiumver="87.0.4280.141"
_cefver="${_version}+g${_commit}+chromium-${_chromiumver}"
pkgver=`echo "$_cefver" | tr - _`
-pkgrel=2
+pkgrel=3
pkgdesc="Chromium Embedded Framework minimal release needed by OBS Studio release in /opt/cef-obs"
arch=("i686" "x86_64" "aarch64")
url="https://bitbucket.org/chromiumembedded/cef"
license=("BSD")
depends=("nss" "alsa-lib" "pango" "libxrandr" "libxcomposite"
"at-spi2-atk" "libxkbcommon" "libcups" "mesa")
-makedepends=("cmake" "make")
+makedepends=("cmake")
provides=("cef-minimal-obs=$_version")
conflicts=("cef-minimal-obs")
-# Prevent people using link time optimisation for this package because it make OBS unable to be built against it
+# Prevent people from using link time optimisation for this package because it make OBS unable to be built against it
options=('!lto')
source_x86_64=("https://cef-builds.spotifycdn.com/cef_binary_${_cefver}_linux64_minimal.tar.bz2")
source_i686=("https://cef-builds.spotifycdn.com/cef_binary_${_cefver}_linux32_minimal.tar.bz2")
@@ -53,9 +53,7 @@ build() {
package() {
mkdir -p "$pkgdir"/opt/cef-obs/
cp -R "$srcdir"/cef_binary_${_cefver}_linux${_arch}_minimal/* "$pkgdir"/opt/cef-obs
- rm -rf "$pkgdir"/opt/cef-obs/CMakeFiles/3.20.3/CompilerIdC/tmp
- rm -rf "$pkgdir"/opt/cef-obs/CMakeFiles/3.20.3/CompilerIdCXX/tmp
- rm -rf "$pkgdir"/opt/cef-obs/CMakeFiles/CMakeTmp
+ rm -rf "$pkgdir"/opt/cef-obs/CMakeFiles
+ rm -rf "$pkgdir"/opt/cef-obs/libcef_dll_wrapper/CMakeFiles
install -Dm644 "$srcdir"/cef_binary_${_cefver}_linux${_arch}_minimal/LICENSE.txt "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
}
-