summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnderson Rocha (MAX)2020-11-21 11:38:45 -0300
committerAnderson Rocha (MAX)2020-11-21 11:38:45 -0300
commit21b5b0d91c0deb90d960933b47bf0f4215d6b54c (patch)
tree048c4a0ba87b997fe4825704e47c296922bf346a
parent78f818e0fd9694a60b441c6fd5b088a1b00d1fda (diff)
downloadaur-21b5b0d91c0deb90d960933b47bf0f4215d6b54c.tar.gz
Version 87.1.6
-rwxr-xr-x.SRCINFO11
-rw-r--r--.gitignore4
-rwxr-xr-xPKGBUILD23
3 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be35280c2c9a..c4cd4b232b94 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cef-minimal
pkgdesc = Chromium Embedded Framework minimal release
- pkgver = 80.0.8
+ pkgver = 87.1.6
pkgrel = 1
url = https://bitbucket.org/chromiumembedded/cef
arch = i686
@@ -22,10 +22,9 @@ pkgbase = cef-minimal
provides = cef
conflicts = cef-standard
conflicts = cef-git
- source_i686 = http://opensource.spotify.com/cefbuilds/cef_binary_80.0.8%2Bgf96cd1d%2Bchromium-80.0.3987.132_linux32_minimal.tar.bz2
- sha1sums_i686 = 1036b653697c9089e41dee3e04aa83884b8c365c
- source_x86_64 = http://opensource.spotify.com/cefbuilds/cef_binary_80.0.8%2Bgf96cd1d%2Bchromium-80.0.3987.132_linux64_minimal.tar.bz2
- sha1sums_x86_64 = e6c323ff461d0f9beb093f94a77a1f817c8732e5
+ source_i686 = http://opensource.spotify.com/cefbuilds/cef_binary_87.1.6%2Bg315d248%2Bchromium-87.0.4280.66_linux32_minimal.tar.bz2
+ sha1sums_i686 = d7848dbbc8f0a3d40017ec62e6a046741f9ce467
+ source_x86_64 = http://opensource.spotify.com/cefbuilds/cef_binary_87.1.6%2Bg315d248%2Bchromium-87.0.4280.66_linux64_minimal.tar.bz2
+ sha1sums_x86_64 = 90b16aab9647df340f8cfaa46c039dbd55d9e1e5
pkgname = cef-minimal
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..aaf5e724300e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src/
+/cef_*
+/cef-*
diff --git a/PKGBUILD b/PKGBUILD
index 5b41a1b18e3d..ea66eb7c861e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: NexAdn <nexadn@yandex.com>
+# Maintainer: Anderson Rocha <anderson2320@gmail.com>
+
pkgname=cef-minimal
-pkgver=80.0.8
-_pkgcommit="gf96cd1d"
-_chromiumver="80.0.3987.132"
+pkgver=87.1.6
+_pkgcommit="g315d248"
+_chromiumver="87.0.4280.66"
_pkgver="${pkgver}+${_pkgcommit}+chromium-${_chromiumver}"
_url_pkgver="${pkgver}%2B${_pkgcommit}%2Bchromium-${_chromiumver}"
pkgrel=1
@@ -14,22 +15,28 @@ depends=("nss" "alsa-lib" "libxss" "libxtst" "libglvnd" "pango" "libxcursor" "db
makedepends=("cmake" "make")
provides=("cef")
conflicts=("cef-standard" "cef-git")
+cdn_build_package_url="https://cef-builds.spotifycdn.com"
+
source_i686=(
- "http://opensource.spotify.com/cefbuilds/cef_binary_${_url_pkgver}_linux32_minimal.tar.bz2"
+ "${cdn_build_package_url}/cef_binary_${_url_pkgver}_linux32_minimal.tar.bz2"
)
source_x86_64=(
- "http://opensource.spotify.com/cefbuilds/cef_binary_${_url_pkgver}_linux64_minimal.tar.bz2"
+ "${cdn_build_package_url}/cef_binary_${_url_pkgver}_linux64_minimal.tar.bz2"
)
-sha1sums_i686=('1036b653697c9089e41dee3e04aa83884b8c365c')
-sha1sums_x86_64=('e6c323ff461d0f9beb093f94a77a1f817c8732e5')
+
+sha1sums_i686=('d7848dbbc8f0a3d40017ec62e6a046741f9ce467')
+sha1sums_x86_64=('90b16aab9647df340f8cfaa46c039dbd55d9e1e5')
+
[[ "$CARCH" = "i686" ]] && _arch="32"
[[ "$CARCH" = "x86_64" ]] && _arch="64"
+
build() {
cd "$srcdir"/cef_binary_${_pkgver}_linux${_arch}_minimal
sed -i 's/-Werror/#-Werror/g' cmake/cef_variables.cmake
cmake .
make libcef_dll_wrapper
}
+
package() {
mkdir -p "$pkgdir"/opt/cef/
cp -R "$srcdir"/cef_binary_${_pkgver}_linux${_arch}_minimal/* "$pkgdir"/opt/cef