summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNexAdn2017-05-01 13:41:20 +0200
committerNexAdn2017-05-01 13:41:20 +0200
commit47ca86a2a4eec4c2e38f8b16b7d22973a77c98ec (patch)
tree229362928205c566c4c37f4cbb175bfea5ff6700
downloadaur-47ca86a2a4eec4c2e38f8b16b7d22973a77c98ec.tar.gz
Initial commit.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD36
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eea9698cce6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = cef-minimal
+ pkgdesc = Chromium Embedded Framework minimal release
+ pkgver = 3.3029.1611
+ pkgrel = 1
+ url = https://bitbucket.org/chromiumembedded/cef
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ makedepends = make
+ depends = nss
+ depends = alsa-lib
+ depends = atk
+ depends = gconf
+ depends = pango
+ depends = libxrandr
+ depends = libxcursor
+ depends = libxss
+ depends = libxtst
+ depends = libxcomposite
+ source_i686 = http://opensource.spotify.com/cefbuilds/cef_binary_3.3029.1611.g44e39a8_linux32_minimal.tar.bz2
+ sha256sums_i686 = 978bbab25a8f8f49bb9dc268a15ba7a2f1bdc2fb048d1d3dfb4a3f33840da3a9
+ source_x86_64 = http://opensource.spotify.com/cefbuilds/cef_binary_3.3029.1611.g44e39a8_linux64_minimal.tar.bz2
+ sha256sums_x86_64 = 251c513d48e32163ab1cf804660d360ca4a5152ad2980e1b6bbad26e8e8ddcf0
+
+pkgname = cef-minimal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..831d005ea08f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: NexAdn
+pkgname=cef-minimal
+pkgver=3.3029.1611
+_commit=g44e39a8
+pkgrel=1
+pkgdesc="Chromium Embedded Framework minimal release"
+arch=("i686" "x86_64")
+url="https://bitbucket.org/chromiumembedded/cef"
+license=("BSD")
+depends=("nss" "alsa-lib" "atk" "gconf" "pango" "libxrandr" "libxcursor" "libxss" "libxtst" "libxcomposite")
+makedepends=("cmake" "make")
+source_i686=(
+ "http://opensource.spotify.com/cefbuilds/cef_binary_${pkgver}.${_commit}_linux32_minimal.tar.bz2"
+)
+source_x86_64=(
+ "http://opensource.spotify.com/cefbuilds/cef_binary_${pkgver}.${_commit}_linux64_minimal.tar.bz2"
+)
+sha256sums_i686=(
+ "978bbab25a8f8f49bb9dc268a15ba7a2f1bdc2fb048d1d3dfb4a3f33840da3a9"
+)
+sha256sums_x86_64=(
+ "251c513d48e32163ab1cf804660d360ca4a5152ad2980e1b6bbad26e8e8ddcf0"
+)
+[[ "$CARCH" = "i686" ]] && _arch="32"
+[[ "$CARCH" = "x86_64" ]] && _arch="64"
+build() {
+ cd "$srcdir"/cef_binary_${pkgver}.${_commit}_linux${_arch}_minimal
+ sed '/^add_subdirectory[\(]tests[\/].*/d' -i CMakeLists.txt
+ cmake .
+ make clean
+ make -j4 libcef_dll_wrapper
+}
+package() {
+ mkdir -p "$pkgdir"/opt/cef-minimal/
+ cp -R "$srcdir"/cef_binary_${pkgver}.${_commit}_linux${_arch}_minimal/* "$pkgdir"/opt/cef-minimal
+}