summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoa2024-04-04 20:28:28 -0500
committerNoa2024-04-04 20:28:28 -0500
commitd2cc67788c7a29ce54aaf683fde79dda7d91bb34 (patch)
treea88a03b7034aed61a17f02d09ed3461519c18d6f
parentef22db9c3b65fcc56f4c6f41dfd4f3c10c036ba4 (diff)
downloadaur-d2cc67788c7a29ce54aaf683fde79dda7d91bb34.tar.gz
0.6.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
-rw-r--r--mods-in-user-dir.patch59
3 files changed, 11 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c726f77899c2..7f4b943c6435 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = celeste64-fuji
pkgdesc = A free and open source mod loader for Celeste 64: Fragments of the Mountain
- pkgver = 0.5.0
+ pkgver = 0.6.0
pkgrel = 1
url = https://fujiapi.github.io
arch = x86_64
@@ -9,11 +9,9 @@ pkgbase = celeste64-fuji
makedepends = dotnet-sdk
options = !strip
options = !debug
- source = Fuji-0.5.0.tar.gz::https://github.com/FujiAPI/Fuji/archive/refs/tags/stable-19068e0.tar.gz
+ source = Fuji-0.6.0.tar.gz::https://github.com/FujiAPI/Fuji/archive/refs/tags/0.6.0.tar.gz
source = fuji.desktop
- source = mods-in-user-dir.patch
- sha256sums = 7d6f1148f951897f07084547eb25413cb8f79cac8daf9d6b332e362a9155e72d
+ sha256sums = 7a015175dab16fcb0b33b6e07c52d9a59715404a69b191d93d9ef01e5e87bbac
sha256sums = 35ffe246db00f9a6e54d50eb7e37d637ac2107413e88f2fe12d27c64ef1830dd
- sha256sums = e85dfceb917f508fa3480984e53d8eb3d3050c7ba73987a5e7af32fc40db4c74
pkgname = celeste64-fuji
diff --git a/PKGBUILD b/PKGBUILD
index 08fbb7cedce0..5683c1759de6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
# Maintainer: Noa <coolreader18@gmail.com>
pkgname=celeste64-fuji
-pkgver=0.5.0
-_tag=stable-19068e0
+pkgver=0.6.0
pkgrel=1
pkgdesc="A free and open source mod loader for Celeste 64: Fragments of the Mountain"
arch=(x86_64 aarch64)
@@ -9,28 +8,25 @@ url="https://fujiapi.github.io"
license=('custom:celeste64-fuji')
makedepends=(dotnet-sdk)
options=('!strip' '!debug')
-source=(Fuji-$pkgver.tar.gz::"https://github.com/FujiAPI/Fuji/archive/refs/tags/$_tag.tar.gz"
- 'fuji.desktop'
- 'mods-in-user-dir.patch')
+source=(Fuji-$pkgver.tar.gz::"https://github.com/FujiAPI/Fuji/archive/refs/tags/$pkgver.tar.gz"
+ 'fuji.desktop')
noextract=()
-sha256sums=('7d6f1148f951897f07084547eb25413cb8f79cac8daf9d6b332e362a9155e72d'
- '35ffe246db00f9a6e54d50eb7e37d637ac2107413e88f2fe12d27c64ef1830dd'
- 'e85dfceb917f508fa3480984e53d8eb3d3050c7ba73987a5e7af32fc40db4c74')
+sha256sums=('7a015175dab16fcb0b33b6e07c52d9a59715404a69b191d93d9ef01e5e87bbac'
+ '35ffe246db00f9a6e54d50eb7e37d637ac2107413e88f2fe12d27c64ef1830dd')
prepare() {
- cd "Fuji-$_tag"
- patch -p1 -i ../mods-in-user-dir.patch
+ cd "Fuji-$pkgver"
dotnet restore
}
build() {
- cd "Fuji-$_tag"
+ cd "Fuji-$pkgver"
dotnet build Celeste64.Launcher/Celeste64.Launcher.csproj -c Release --ucr
awk '/License/{license=1} !$0{license=0} license' README.md >License.txt
}
package() {
- cd "Fuji-$_tag"
+ cd "Fuji-$pkgver"
dotnet publish Celeste64.Launcher/Celeste64.Launcher.csproj -c Release --ucr --no-build -o "$pkgdir"/opt/fuji
cp -r Content Mods fuji.png "$pkgdir"/opt/fuji
install -Dm 644 "$srcdir"/fuji.desktop -t "$pkgdir"/usr/share/applications
diff --git a/mods-in-user-dir.patch b/mods-in-user-dir.patch
deleted file mode 100644
index 04883912c136..000000000000
--- a/mods-in-user-dir.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-diff --git a/Source/Mod/Core/ModLoader.cs b/Source/Mod/Core/ModLoader.cs
-index 105ed63..bb0a2d4 100644
---- a/Source/Mod/Core/ModLoader.cs
-+++ b/Source/Mod/Core/ModLoader.cs
-@@ -9,15 +9,15 @@ public static class ModLoader
- {
- public const string ModsFolder = "Mods";
-
-- private static string? modsFolderPath = null;
-+ private static string[]? modsFolderPaths = null;
-
- internal static List<string> FailedToLoadMods = [];
-
-- public static string ModFolderPath
-+ public static string[] ModFolderPaths
- {
- get
- {
-- if (modsFolderPath == null)
-+ if (modsFolderPaths == null)
- {
- var baseFolder = AppContext.BaseDirectory;
- var searchUpPath = "";
-@@ -26,10 +26,15 @@ public static class ModLoader
- searchUpPath = Path.Join(searchUpPath, "..");
- if (!Directory.Exists(Path.Join(baseFolder, searchUpPath, ModsFolder)))
- throw new Exception($"Unable to find {ModsFolder} Directory from '{baseFolder}'");
-- modsFolderPath = Path.Join(baseFolder, searchUpPath, ModsFolder);
-+ var modsFolderPath = Path.Join(baseFolder, searchUpPath, ModsFolder);
-+ var userModsFolderPath = Path.Join(App.UserPath, ModsFolder);
-+ if (Directory.Exists(userModsFolderPath))
-+ modsFolderPaths = [modsFolderPath, userModsFolderPath];
-+ else
-+ modsFolderPaths = [modsFolderPath];
- }
-
-- return modsFolderPath;
-+ return modsFolderPaths;
- }
- }
-
-@@ -51,7 +56,7 @@ public static class ModLoader
- List<(ModInfo, IModFilesystem)> modInfos = [];
-
- // Find all mods in directories:
-- foreach (var modDir in Directory.EnumerateDirectories(ModFolderPath))
-+ foreach (var modDir in ModFolderPaths.SelectMany(path => Directory.EnumerateDirectories(path, "*.zip")))
- {
- var modName = Path.GetFileNameWithoutExtension(modDir)!; // Todo: read from some metadata file
- var fs = new FolderModFilesystem(modDir);
-@@ -73,7 +78,7 @@ public static class ModLoader
- }
-
- // Find all mods in zips:
-- foreach (var modZip in Directory.EnumerateFiles(ModFolderPath, "*.zip"))
-+ foreach (var modZip in ModFolderPaths.SelectMany(path => Directory.EnumerateFiles(path, "*.zip")))
- {
- var modName = Path.GetFileNameWithoutExtension(modZip)!; // Todo: read from some metadata file
- var fs = new ZipModFilesystem(modZip);