summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:41:23 +0200
committerSanskritFritz2015-06-14 00:41:23 +0200
commit8644d650ebc0d4fc8176e3e8b4bcd3307bcbfa32 (patch)
tree8a2f060af8122992023696eb7c21ef1577d727df
downloadaur-8644d650ebc0d4fc8176e3e8b4bcd3307bcbfa32.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--celestia-addon-apollo_soyuz.install8
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9aeecfd4ef6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = celestia-addon-apollo_soyuz
+ pkgdesc = Celestia addon: Spacecraft: Earth Orbit: Apollo-Soyuz Test Project
+ pkgver = 1
+ pkgrel = 1
+ url = http://www.celestiamotherlode.net/catalog/show_addon_details.php?addon_id=269
+ install = celestia-addon-apollo_soyuz.install
+ arch = any
+ license = unknown, free
+ makedepends = unzip
+ depends = celestia
+ conflicts = celestia-addon-apollo-soyuz
+ source = http://celestiamotherlode.net/creators/jackhiggins/astpmodel.zip
+ source = http://celestiamotherlode.net/creators/jackhiggins/astp.zip
+ md5sums = 05997e0ff88353d2078bba0f593ce0d1
+ md5sums = 917491d80393e6a4f339bbb3f17bb41f
+
+pkgname = celestia-addon-apollo_soyuz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ec8935ced68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=celestia-addon-apollo_soyuz
+pkgver=1
+pkgrel=1
+pkgdesc="Celestia addon: Spacecraft: Earth Orbit: Apollo-Soyuz Test Project"
+arch=('any')
+url='http://www.celestiamotherlode.net/catalog/show_addon_details.php?addon_id=269'
+license=('unknown, free')
+depends=('celestia')
+makedepends=('unzip')
+conflicts=('celestia-addon-apollo-soyuz')
+source=('http://celestiamotherlode.net/creators/jackhiggins/astpmodel.zip'
+ 'http://celestiamotherlode.net/creators/jackhiggins/astp.zip')
+install=$pkgname.install
+
+package() {
+ mkdir --parents "$pkgdir/usr/share/celestia/models"
+ mkdir --parents "$pkgdir/usr/share/celestia/textures/medres"
+ mkdir --parents "$pkgdir/usr/share/celestia/extras"
+ cp "$srcdir/ASTP.3ds" "$pkgdir/usr/share/celestia/models"
+ cp "$srcdir/cccp_flag.bmp" "$pkgdir/usr/share/celestia/textures/medres"
+ cp "$srcdir/soyuz_astp_solar.bmp" "$pkgdir/usr/share/celestia/textures/medres"
+ cp "$srcdir/JACK_ASTP.ssc" "$pkgdir/usr/share/celestia/extras/"
+}
+
+md5sums=('05997e0ff88353d2078bba0f593ce0d1'
+ '917491d80393e6a4f339bbb3f17bb41f')
diff --git a/celestia-addon-apollo_soyuz.install b/celestia-addon-apollo_soyuz.install
new file mode 100644
index 000000000000..684aa2fbe355
--- /dev/null
+++ b/celestia-addon-apollo_soyuz.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "Remember that the ASTP ssc only runs between the 15th & 24th July 1975,"
+ echo "so you'll have to run time backwards to see it."
+}
+
+post_upgrade() {
+ post_install $1
+}