summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Lezaeta2016-05-05 23:31:42 -0300
committerPablo Lezaeta2016-05-05 23:31:42 -0300
commitf734985835aa01b936114b25fe838c71145aef47 (patch)
treee381b183869db948071227ba74af2da3bf80a816
downloadaur-f734985835aa01b936114b25fe838c71145aef47.tar.gz
Rerelease version now with t1 and splitpkg
Signed-off-by: Pablo Lezaeta <prflr88@gmail.com>
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD38
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6d4580ffd45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Fri May 6 02:30:23 UTC 2016
+pkgbase = celestia-medium-redux
+ pkgdesc = A font collection based off on Generation B (used in My Little Pony: Friendship is MAgic), originally created by Purple Tinker, redux by Mattyhex
+ pkgver = 1.55
+ pkgrel = 1
+ url = http://www.mattyhex.net/CMR/
+ arch = any
+ license = custom:Public Domain
+ source = http://www.mattyhex.net/CMR/media/fonts/CelestiaMediumRedux1.55.ttf
+ source = http://www.mattyhex.net/CMR/media/fonts/CelestiaMediumRedux_alt1.55.ttf
+ source = http://www.mattyhex.net/CMR/media/fonts/CelestiaMediumReduxPostScript1.55.zip
+ md5sums = 363a277c00badde21964523184d3c1c4
+ md5sums = 42b203c5113594b9e5f0589269f3f8d3
+ md5sums = 8b7b2d909f30569a8fb51d1883c223e8
+
+pkgname = ttf-celestia-medium-redux
+ pkgdesc = A TTF font based off on Generation B (used in My Little Pony: Friendship is MAgic), originally created by Purple Tinker, redux by Mattyhex
+ depends = fontconfig
+ depends = xorg-font-utils
+ provides = ttf-celestia
+
+pkgname = t1-celestia-medium-redux
+ pkgdesc = A PostScript font based off on Generation B (used in My Little Pony: Friendship is MAgic), originally created by Purple Tinker, redux by Mattyhex
+ depends = xorg-fonts-encodings
+ depends = xorg-fonts-alias
+ depends = xorg-font-utils
+ depends = fontconfig
+ provides = t1-celestia
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8613723a7e3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.pac.*
+*.otf
+*.ttf
+*.pfa
+*.pfb
+*.afm
+*.pfm
+*.zip
+src
+srcdir
+pkg
+pkgdir
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84e77f7d06f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: StarGater93 <stargater93@gmail.com>
+
+pkgbase=celestia-medium-redux
+pkgname=(ttf-celestia-medium-redux t1-celestia-medium-redux)
+_realname=CelestiaMediumRedux
+pkgver=1.55
+pkgrel=1
+pkgdesc="A font collection based off on Generation B (used in My Little Pony: Friendship is MAgic), originally created by Purple Tinker, redux by Mattyhex"
+arch=("any")
+url="http://www.mattyhex.net/CMR/"
+license=('custom:Public Domain')
+source=("${url}media/fonts/${_realname}${pkgver}.ttf"
+ "${url}media/fonts/${_realname}_alt${pkgver}.ttf"
+ "${url}media/fonts/${_realname}PostScript${pkgver}.zip")
+md5sums=('363a277c00badde21964523184d3c1c4'
+ '42b203c5113594b9e5f0589269f3f8d3'
+ '8b7b2d909f30569a8fb51d1883c223e8')
+
+package_ttf-celestia-medium-redux() {
+ pkgname=ttf-celestia-medium-redux
+ pkgdesc="A TTF font based off on Generation B (used in My Little Pony: Friendship is MAgic), originally created by Purple Tinker, redux by Mattyhex"
+ provides=(ttf-celestia)
+ depends=('fontconfig' 'xorg-font-utils')
+
+ mkdir -p "$pkgdir/usr/share/fonts/TTF"
+ cp "$srcdir/"*.ttf "$pkgdir/usr/share/fonts/TTF"
+}
+
+package_t1-celestia-medium-redux() {
+ pkgname=t1-celestia-medium-redux
+ pkgdesc="A PostScript font based off on Generation B (used in My Little Pony: Friendship is MAgic), originally created by Purple Tinker, redux by Mattyhex"
+ provides=(t1-celestia)
+ depends=('xorg-fonts-encodings' 'xorg-fonts-alias' 'xorg-font-utils' 'fontconfig')
+
+ mkdir -p "$pkgdir/usr/share/fonts/Type1"
+ cp "$srcdir/"*.ps "$pkgdir/usr/share/fonts/Type1"
+ cp "$srcdir/"*.afm "$pkgdir/usr/share/fonts/Type1"
+}