summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMika Hyttinen2024-01-05 20:40:57 +0200
committerMika Hyttinen2024-01-05 20:40:57 +0200
commitf8dc2547c21af7277dcbedb490bd41319ac8ecc0 (patch)
tree14a91338a0e56edbc5bed8d71b2d9b5aeb132f24
parent02c8a38087caeb18969a1e54204500ec52c4c565 (diff)
downloadaur-f8dc2547c21af7277dcbedb490bd41319ac8ecc0.tar.gz
Add logrotate file with more sane values and remove hourly, logrotate timer handles the file
-rw-r--r--PKGBUILD10
-rw-r--r--cellframe-node.logrotate8
2 files changed, 14 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 771057e0bf2d..c955e1531482 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname="cellframe-dashboard"
_nodename="cellframe-node"
pkgver=2.13.5
-pkgrel=2
+pkgrel=3
pkgdesc="Super application for managing Cellframe node"
arch=(x86_64 aarch64)
url="https://cellframe.net"
@@ -10,8 +10,10 @@ license=(GPL3)
depends=(qt5-graphicaleffects qt5-base qt5-quickcontrols2 qt5-quickcontrols logrotate libxcrypt-compat)
makedepends=(git qt5-base qt5-declarative cmake python3)
options=(!makeflags !buildflags)
-source=(git+https://gitlab.demlabs.net/cellframe/$pkgname.git#commit=d0b026a4655c603330390265de10ec157b76f615)
-md5sums=(SKIP)
+source=(git+https://gitlab.demlabs.net/cellframe/$pkgname.git#commit=d0b026a4655c603330390265de10ec157b76f615
+ cellframe-node.logrotate)
+md5sums=('SKIP'
+ '95ea2a9af2bdd2e08d44494673d2a9f3')
conflicts=(cellframe-node cellframe-wallet)
install=$pkgname.install
@@ -58,6 +60,6 @@ package() {
install -Dm 644 "$pkgdir/opt/$pkgname/share/init.d/$pkgname.service" -t "$pkgdir/usr/lib/systemd/system/"
install -Dm 644 "$srcdir/$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
install -Dm 644 "$srcdir/$pkgname/$_nodename/LICENSE" -t "$pkgdir/usr/share/licenses/$_nodename"
- install -Dm 644 "$srcdir/$pkgname/$_nodename/dist.linux/share/logrotate/$_nodename" "$pkgdir/etc/logrotate.d/$_nodename"
+ install -Dm 644 "$srcdir/$_nodename.logrotate" "$pkgdir/etc/logrotate.d/$_nodename"
install -Dm 644 "$srcdir/$pkgname/$_nodename/dist.linux/share/$_nodename.service" -t "$pkgdir/usr/lib/systemd/system"
}
diff --git a/cellframe-node.logrotate b/cellframe-node.logrotate
new file mode 100644
index 000000000000..4dd2c8abc400
--- /dev/null
+++ b/cellframe-node.logrotate
@@ -0,0 +1,8 @@
+"/opt/cellframe-node/var/log/*.log" {
+ copytruncate
+ maxsize 200M
+ rotate 6
+ compress
+ missingok
+ notifempty
+}