summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMika Hyttinen2024-03-22 17:27:09 +0200
committerMika Hyttinen2024-03-22 17:27:09 +0200
commit6d1cba9051536e227292dcb3096baf4a9aa1c8bb (patch)
treef3d662557d94fdf2cbfe4d67800f4d5db91edbc6
parent4ce2852395c7f1df582d2863160afc382f0849a4 (diff)
downloadaur-6d1cba9051536e227292dcb3096baf4a9aa1c8bb.tar.gz
Try diff build settings
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be5b6386e8e3..f5c4ff5a0c22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cellframe-node-debug
pkgdesc = Cellframe blockchain node with a powerful SDK
pkgver = 5.2.483
- pkgrel = 1
+ pkgrel = 2
url = https://cellframe.net
install = cellframe-node.install
arch = x86_64
@@ -20,6 +20,8 @@ pkgbase = cellframe-node-debug
conflicts = cellframe-node
options = !strip
options = !debug
+ options = !buildflags
+ options = !makeflags
source = git+https://gitlab.demlabs.net/cellframe/cellframe-node.git#commit=952b0eb04830e3a27f3f051f429479703ece87f6
source = git+https://gitlab.demlabs.net/cellframe/cellframe-sdk.git#commit=13a58fc4c50b0756c9f3485067f9e693c2150ca6
source = git+https://gitlab.demlabs.net/dap/dap-sdk.git#commit=482a2f13f982ee33fcff4863041b3db2eda1a00d
diff --git a/PKGBUILD b/PKGBUILD
index 44e04dd21fb3..f9e3fc4307ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cellframe-node-debug
_pkgname=cellframe-node
pkgver=5.2.483
-pkgrel=1
+pkgrel=2
pkgdesc="Cellframe blockchain node with a powerful SDK"
arch=('x86_64' 'aarch64')
url="https://cellframe.net"
@@ -30,7 +30,7 @@ md5sums=('SKIP'
'42a6fdb6b79a93d0a31dd33a40456c9c')
install=$_pkgname.install
conflicts=(cellframe-dashboard cellframe-wallet cellframe-node)
-options=(!strip !debug)
+options=(!strip !debug !buildflags !makeflags)
prepare() {
rm -rf "$srcdir/$_pkgname/cellframe-sdk"
@@ -44,7 +44,7 @@ prepare() {
build() {
cd "$_pkgname"
cmake -B build \
- -DCMAKE_BUILD_TYPE='Debug' \
+ -DCMAKE_BUILD_TYPE='RelWithDebInfo' \
-Wno-dev
cmake --build build -j$(nproc)
}