summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Dvoretsky2015-07-29 21:12:12 +0300
committerEugene Dvoretsky2015-07-29 22:10:52 +0300
commit1652837fd9f93b541b74bfcb08a7b21438124b4e (patch)
tree42bafb1c2077305f9ec182b9c41bb90552ca1d6d
parentb1829b4603b9f0ddc20b44d952ac5b2ead9c31a3 (diff)
downloadaur-1652837fd9f93b541b74bfcb08a7b21438124b4e.tar.gz
Working package with desktop file
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD75
-rw-r--r--cellprofiler-analyst.desktop10
3 files changed, 69 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 959f71ca3b4d..618d917c80bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,26 @@
pkgbase = cellprofiler-analyst-git
pkgdesc = Analysis software for cellular images
- pkgver = 20121017
+ pkgver = 2.0.4.r459.g7a96978
pkgrel = 1
url = http://www.cellprofiler.org/
arch = i686
arch = x86_64
license = GPLv2
- makedepends = git
- makedepends = python2-distribute
- depends = cellprofiler-git
+ depends = wxpython2.8
+ depends = python2-numpy
+ depends = python2-scipy
+ depends = python2-matplotlib
+ depends = python2-imaging
+ depends = python2-pytz
+ depends = python2-verlib
+ depends = python2-javabridge
+ depends = python2-bioformats
+ optdepends = cellprofiler: prepare data for CPA
provides = cellprofiler-analyst
- conflicts = cellprofiler-analyst
+ source = cellprofiler-analyst-git::git+https://github.com/CellProfiler/CellProfiler-Analyst#commit=7a96978
+ source = cellprofiler-analyst.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = cellprofiler-analyst-git
diff --git a/PKGBUILD b/PKGBUILD
index 61bd72a91264..96a3ca56d31c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,64 @@
# Maintainer: Michael Schubert <mschu.dev at gmail>
+# Maintainer: Eugene Dvoretsky <radioxoma at gmail>
pkgname=cellprofiler-analyst-git
-pkgver=20121017
+pkgver=2.0.4.r459.g7a96978
pkgrel=1
pkgdesc="Analysis software for cellular images"
arch=('i686' 'x86_64')
url="http://www.cellprofiler.org/"
license=('GPLv2')
-depends=('cellprofiler-git')
-makedepends=('git' 'python2-distribute')
+depends=(
+ 'wxpython2.8'
+ 'python2-numpy'
+ 'python2-scipy'
+ 'python2-matplotlib'
+ 'python2-imaging'
+ 'python2-pytz'
+ 'python2-verlib'
+ 'python2-javabridge'
+ 'python2-bioformats')
+optdepends=('cellprofiler: prepare data for CPA')
provides=('cellprofiler-analyst')
-conflicts=('cellprofiler-analyst')
+source=("$pkgname::git+https://github.com/CellProfiler/CellProfiler-Analyst#commit=7a96978"
+ "cellprofiler-analyst.desktop")
+sha256sums=('SKIP'
+ 'SKIP')
-_gitroot="git://github.com/CellProfiler/CellProfiler-Analyst.git"
-_gitname="CellProfiler-Analyst"
-
-build() {
- cd "$srcdir"
-
- msg "Connecting to GIT server...."
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot $_gitname
- fi
+prepare() {
+ cd "$srcdir/$pkgname"
+ # Should be fixed in the source three
+ sed -i '1i#!/usr/bin/env python2' ./CellProfiler-Analyst.py
+ rm -rf `find "$pkgdir" -name "tests" -type d`
+}
- cd "$srcdir/$_gitname/cpa"
+build() {
+ cd "$srcdir/$pkgname"
+ # force selection of wxpython2.8 (xargs helps handle spaces)
+ find . -name '*.py' -print0 | xargs -0 sed -i -e "s/^\(.*\)import wx$/\1import wxversion\n\1wxversion.select(\"2.8\")\n\1import wx/g"
- CP_HOME=/usr/lib/python2.7/site-packages/cellprofiler python2 setup.py build
+ # python2 setup.py build # Unusable build system (only for Mac now)
+ python2 -m compileall cpa
}
+# check() {
+# cd "$srcdir/CellProfiler-Analyst"
+# python2 setup.py test # Only for Mac now
+# }
+
package() {
- cd "$srcdir/$_gitname"
+ # python2 setup.py install --root="$pkgdir"/ --optimize=1 # Only for Mac now
pydir=`python2 -c "from distutils.sysconfig import get_python_lib; print get_python_lib()"`
-
-mkdir -p "$pkgdir/usr/bin"
-cat > "$pkgdir/usr/bin/cpa" << EOF
-#!/bin/sh
-python2 "$pydir/cpa/cpa.py"
-EOF
-chmod 755 "$pkgdir/usr/bin/cpa"
-
mkdir -p "$pkgdir/$pydir"
- cp -r cpa "$pkgdir/$pydir"
- python2 -m compileall "$pkgdir/$pydir/cpa/" || return 0
+ cd "$srcdir/$pkgname"
+ cp -r cpa "$pkgdir/$pydir"
+ install -Dm755 CellProfiler-Analyst.py "$pkgdir/usr/bin/cellprofiler-analyst"
+ install -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/cellprofiler-analyst.desktop" "$pkgdir/usr/share/applications/cellprofiler-analyst.desktop"
}
-
diff --git a/cellprofiler-analyst.desktop b/cellprofiler-analyst.desktop
new file mode 100644
index 000000000000..f356ba332f36
--- /dev/null
+++ b/cellprofiler-analyst.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=CellProfiler Analyst
+Comment=Explore and analyze large, high-dimensional image-derived data
+Type=Application
+Version=1.0
+Categories=Science;Biology;DataVisualization;
+Exec=cellprofiler-analyst
+Terminal=false
+StartupNotify=true
+Icon=/usr/lib/python2.7/site-packages/cpa/icons/cpa_16.png