summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuskuss2022-09-05 20:04:03 +0200
committerAnuskuss2022-09-05 20:04:03 +0200
commit3fcb0d694b1ebb3cd33923fb957d671c6e6595b1 (patch)
tree8ede61ecd47c2027ea1b879a366e0096317997ca
parent881ca6dc5fcbc748d0af0be0f8ebf980febdf9a7 (diff)
downloadaur-3fcb0d694b1ebb3cd33923fb957d671c6e6595b1.tar.gz
Removed bundled fmt & clang workaround and updated to latest version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
-rw-r--r--clang.patch14
-rw-r--r--xdg.diff (renamed from xdg.patch)72
4 files changed, 57 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e50c980a5417..88c2d29441e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cemu
pkgdesc = Software to emulate Wii U games and applications on PC
- pkgver = 2.0.89
+ pkgver = 2.0.96
pkgrel = 1
url = https://github.com/cemu-project/Cemu
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = cemu
makedepends = boost
makedepends = glslang
makedepends = glm
+ makedepends = fmt>=9.1
makedepends = nasm
makedepends = vulkan-headers
makedepends = glu
@@ -22,8 +23,7 @@ pkgbase = cemu
depends = wxwidgets-gtk3>=3.2
optdepends = vulkan-driver: Vulkan graphics
provides = cemu
- source = git+https://github.com/cemu-project/Cemu#commit=a54a3ec74ea95326096feb46317fb9c6cd277742
- source = fmt-7.1.3.tar.gz::https://github.com/fmtlib/fmt/archive/refs/tags/7.1.3.tar.gz
+ source = git+https://github.com/cemu-project/Cemu#commit=0030fa44a5bea51d422bd7d5f413bf0bdc8c7b64
source = imgui-1.88.tar.gz::https://github.com/ocornut/imgui/archive/refs/tags/v1.88.tar.gz
source = imgui.cmake::https://raw.githubusercontent.com/microsoft/vcpkg/master/ports/imgui/CMakeLists.txt
source = imgui.conf::https://raw.githubusercontent.com/microsoft/vcpkg/master/ports/imgui/imgui-config.cmake.in
@@ -31,10 +31,8 @@ pkgbase = cemu
source = git+https://github.com/Exzap/ZArchive#commit=48914a07df3c213333c580bb5e5bb3393442ca5b
source = git+https://github.com/arsenm/sanitizers-cmake#commit=aab6948fa863bc1cbe5d0850bc46b9ef02ed4c1a
source = git+https://github.com/google/googletest#commit=800f5422ac9d9e0ad59cd860a2ef3a679588acb4
- source = clang.patch
- source = xdg.patch
+ source = xdg.diff
sha256sums = SKIP
- sha256sums = 5cae7072042b3043e12d53d50ef404bbb76949dad1de368d7f993a15c8c05ecc
sha256sums = 9f14c788aee15b777051e48f868c5d4d959bd679fc5050e3d2a29de80d8fd32e
sha256sums = 262faed507149c89aab7572fd2c2a968f843ca2900043e30a9c339735ed08a8f
sha256sums = 91528f60cca93d3bce042d2ac16a63169025ec25a34453b49803126ed19153ae
@@ -42,7 +40,6 @@ pkgbase = cemu
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 893832f2e7dd7784e9df423020ff2acc63ffe8d9b75b7d92f371f7dd57313131
- sha256sums = c8b6cefa33256c84435313c02f03dfe55b651db573642c12b3db01e1a51a64da
+ sha256sums = 78aa9187fa6a1819da039c10f1d2681b962329c9fc6d4724eeff5936b3ec02ee
pkgname = cemu
diff --git a/PKGBUILD b/PKGBUILD
index 36c8ccb3d2fd..891e719c6b39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Anuskuss <anuskuss@googlemail.com>
pkgname=cemu
-pkgver=2.0.89
+pkgver=2.0.96
pkgrel=1
pkgdesc='Software to emulate Wii U games and applications on PC'
arch=(x86_64)
@@ -14,7 +14,7 @@ makedepends=(
# pkgbuild
git 'cmake>=3.21.1' make
# unbundled vcpkg
- rapidjson boost glslang glm
+ rapidjson boost glslang glm 'fmt>=9.1'
# cemu
nasm vulkan-headers
# wxwidgets
@@ -25,9 +25,8 @@ optdepends=(
)
provides=(cemu)
source=(
- git+https://github.com/cemu-project/Cemu#commit=a54a3ec74ea95326096feb46317fb9c6cd277742
+ git+https://github.com/cemu-project/Cemu#commit=0030fa44a5bea51d422bd7d5f413bf0bdc8c7b64
# dependencies
- fmt-7.1.3.tar.gz::https://github.com/fmtlib/fmt/archive/refs/tags/7.1.3.tar.gz
imgui-1.88.tar.gz::https://github.com/ocornut/imgui/archive/refs/tags/v1.88.tar.gz
imgui.cmake::https://raw.githubusercontent.com/microsoft/vcpkg/master/ports/imgui/CMakeLists.txt
imgui.conf::https://raw.githubusercontent.com/microsoft/vcpkg/master/ports/imgui/imgui-config.cmake.in
@@ -40,12 +39,10 @@ source=(
git+https://github.com/arsenm/sanitizers-cmake#commit=aab6948fa863bc1cbe5d0850bc46b9ef02ed4c1a
git+https://github.com/google/googletest#commit=800f5422ac9d9e0ad59cd860a2ef3a679588acb4
# patches
- clang.patch
- xdg.patch
+ xdg.diff # https://github.com/cemu-project/Cemu/commit/963f9b38349c5d03b26ab2a50ead2ee4e743ca41.patch
)
sha256sums=(
SKIP
- 5cae7072042b3043e12d53d50ef404bbb76949dad1de368d7f993a15c8c05ecc
9f14c788aee15b777051e48f868c5d4d959bd679fc5050e3d2a29de80d8fd32e
262faed507149c89aab7572fd2c2a968f843ca2900043e30a9c339735ed08a8f
91528f60cca93d3bce042d2ac16a63169025ec25a34453b49803126ed19153ae
@@ -53,8 +50,7 @@ sha256sums=(
SKIP
SKIP
SKIP
- 893832f2e7dd7784e9df423020ff2acc63ffe8d9b75b7d92f371f7dd57313131
- c8b6cefa33256c84435313c02f03dfe55b651db573642c12b3db01e1a51a64da
+ 78aa9187fa6a1819da039c10f1d2681b962329c9fc6d4724eeff5936b3ec02ee
)
pkgver() {
@@ -81,23 +77,12 @@ prepare() {
done
popd
- # unbundled fmt
- sed -i '/fmt/c\add_subdirectory(dependencies/fmt)' CMakeLists.txt
- ln -srf "$srcdir/fmt-7.1.3" dependencies/fmt
-
# unbundled imgui
sed -i '/imgui/c\add_subdirectory(dependencies/imgui)' CMakeLists.txt
ln -srf "$srcdir/imgui-1.88" dependencies/imgui
ln -srf "$srcdir/imgui.cmake" dependencies/imgui/CMakeLists.txt
ln -srf "$srcdir/imgui.conf" dependencies/imgui/imgui-config.cmake.in
- # prefer clang (faster)
- which clang &> /dev/null && [[ -z $CC ]] && export CC=$(which clang)
- which clang++ &> /dev/null && [[ -z $CXX ]] && export CXX=$(which clang++)
-
- # clang workaround
- [[ $CXX == *clang* ]] && git apply "$srcdir/clang.patch"
-
# glm fix
sed -i 's/glm::glm/glm/' src/Common/CMakeLists.txt src/input/CMakeLists.txt
@@ -105,10 +90,14 @@ prepare() {
sed -i 's/GLSLANG_VERSION_LESS/GLSLANG_VERSION_GREATER/' src/Cafe/HW/Latte/Renderer/Vulkan/RendererShaderVk.cpp
# xdg base dir support (https://github.com/cemu-project/Cemu/pull/130)
- git apply "$srcdir/xdg.patch"
+ git apply "$srcdir/xdg.diff"
# gameProfiles improvement
sed -i 's|gameProfiles/default|gameProfiles|' src/Cafe/GameProfile/GameProfile.cpp
+
+ # prefer clang (faster)
+ which clang &> /dev/null && [[ -z $CC ]] && export CC=$(which clang)
+ which clang++ &> /dev/null && [[ -z $CXX ]] && export CXX=$(which clang++)
}
build() {
diff --git a/clang.patch b/clang.patch
deleted file mode 100644
index 23e768434fed..000000000000
--- a/clang.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src/Cemu/Logging/CemuLogging.h b/src/Cemu/Logging/CemuLogging.h
-index 4238b63..a9b1daa 100644
---- a/src/Cemu/Logging/CemuLogging.h
-+++ b/src/Cemu/Logging/CemuLogging.h
-@@ -58,9 +58,6 @@ bool cemuLog_log(LogType type, TFmt format, TArgs&&... args)
- if (!cemuLog_isLoggingEnabled(type))
- return false;
-
-- const auto format_view = fmt::to_string_view(format);
-- const auto text = fmt::vformat(format_view, fmt::make_args_checked<TArgs...>(format_view, args...));
-- cemuLog_log(type, std::basic_string_view(text.data(), text.size()));
- return true;
- }
-
diff --git a/xdg.patch b/xdg.diff
index e2937554ea53..04f2e665c29e 100644
--- a/xdg.patch
+++ b/xdg.diff
@@ -1,5 +1,5 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b001421..4868374 100644
+index e9f7458..9135c62 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,6 +58,13 @@ option(ENABLE_OPENGL "Enables the OpenGL backend" ON)
@@ -21,7 +21,7 @@ index b001421..4868374 100644
endif()
+if (ENABLE_XDG_DIRS)
-+ add_compile_definitions(XDG)
++ add_compile_definitions(XDG)
+endif()
+
add_subdirectory("dependencies/ih264d" EXCLUDE_FROM_ALL)
@@ -135,7 +135,7 @@ index 41e33a1..38e52bb 100644
{
if (!it->is_directory(ec))
diff --git a/src/Cafe/HW/Latte/Core/LatteShaderCache.cpp b/src/Cafe/HW/Latte/Core/LatteShaderCache.cpp
-index bcdaffa..aa8c296 100644
+index ebf425b..7ad99e4 100644
--- a/src/Cafe/HW/Latte/Core/LatteShaderCache.cpp
+++ b/src/Cafe/HW/Latte/Core/LatteShaderCache.cpp
@@ -197,17 +197,17 @@ void LatteShaderCache_load()
@@ -336,20 +336,33 @@ index f58e798..6d403de 100644
LogContext.file_stream.open(path, std::ios::out);
if (LogContext.file_stream.fail())
{
-diff --git a/src/Cemu/Logging/CemuLogging.h b/src/Cemu/Logging/CemuLogging.h
-index 4238b63..a9b1daa 100644
---- a/src/Cemu/Logging/CemuLogging.h
-+++ b/src/Cemu/Logging/CemuLogging.h
-@@ -58,9 +58,6 @@ bool cemuLog_log(LogType type, TFmt format, TArgs&&... args)
- if (!cemuLog_isLoggingEnabled(type))
- return false;
+diff --git a/src/Common/ExceptionHandler/ExceptionHandler_win32.cpp b/src/Common/ExceptionHandler/ExceptionHandler_win32.cpp
+index 25dca26..9f38cdd 100644
+--- a/src/Common/ExceptionHandler/ExceptionHandler_win32.cpp
++++ b/src/Common/ExceptionHandler/ExceptionHandler_win32.cpp
+@@ -61,7 +61,7 @@ bool CreateMiniDump(CrashDump dump, EXCEPTION_POINTERS* pep)
+ if (dump == CrashDump::Disabled)
+ return true;
-- const auto format_view = fmt::to_string_view(format);
-- const auto text = fmt::vformat(format_view, fmt::make_args_checked<TArgs...>(format_view, args...));
-- cemuLog_log(type, std::basic_string_view(text.data(), text.size()));
- return true;
- }
+- fs::path p = ActiveSettings::GetPath("crashdump");
++ fs::path p = ActiveSettings::GetDataPath("crashdump");
+
+ std::error_code ec;
+ fs::create_directories(p, ec);
+@@ -356,11 +356,11 @@ void createCrashlog(EXCEPTION_POINTERS* e, PCONTEXT context)
+ const auto temp_time = std::chrono::system_clock::to_time_t(now);
+ const auto& time = *std::gmtime(&temp_time);
+
+- fs::path p = ActiveSettings::GetPath("crashdump");
++ fs::path p = ActiveSettings::GetDataPath("crashdump");
+ p /= fmt::format("log_{:04d}{:02d}{:02d}_{:02d}{:02d}{:02d}.txt", 1900 + time.tm_year, time.tm_mon + 1, time.tm_mday, time.tm_year, time.tm_hour, time.tm_min, time.tm_sec);
+ std::error_code ec;
+- fs::copy_file(ActiveSettings::GetPath("log.txt"), p, ec);
++ fs::copy_file(ActiveSettings::GetDataPath("log.txt"), p, ec);
+ }
+
+ exit(0);
diff --git a/src/config/ActiveSettings.cpp b/src/config/ActiveSettings.cpp
index c7ff4fe..23bc364 100644
--- a/src/config/ActiveSettings.cpp
@@ -426,7 +439,7 @@ index c7ff4fe..23bc364 100644
+ return GetDataPath("mlc01");
+}
diff --git a/src/config/ActiveSettings.h b/src/config/ActiveSettings.h
-index 44b5f50..e5a35d4 100644
+index 95ceae1..c47ebeb 100644
--- a/src/config/ActiveSettings.h
+++ b/src/config/ActiveSettings.h
@@ -13,6 +13,11 @@ public:
@@ -442,63 +455,63 @@ index 44b5f50..e5a35d4 100644
[[nodiscard]] static fs::path GetPath(std::string_view p)
{
@@ -57,6 +62,62 @@ public:
- return GetMlcPath() / fmt::format(format, std::forward<TArgs>(args)...);
+ return GetMlcPath() / fmt::format(fmt::runtime(format), std::forward<TArgs>(args)...);
}
+ template <typename ...TArgs>
+ [[nodiscard]] static fs::path GetCachePath(std::string_view format, TArgs&&... args)
+ {
+ cemu_assert_debug(format.empty() || (format[0] != L'/' && format[0] != L'\\'));
-+ return GetCachePath() / fmt::format(format, std::forward<TArgs>(args)...);
++ return GetCachePath() / fmt::format(fmt::runtime(format), std::forward<TArgs>(args)...);
+ }
+
+ template <typename ...TArgs>
+ [[nodiscard]] static fs::path GetCachePath(std::wstring_view format, TArgs&&... args)
+ {
+ cemu_assert_debug(format.empty() || (format[0] != L'/' && format[0] != L'\\'));
-+ return GetCachePath() / fmt::format(format, std::forward<TArgs>(args)...);
++ return GetCachePath() / fmt::format(fmt::runtime(format), std::forward<TArgs>(args)...);
+ }
+
+ template <typename ...TArgs>
+ [[nodiscard]] static fs::path GetConfigPath(std::string_view format, TArgs&&... args)
+ {
+ cemu_assert_debug(format.empty() || (format[0] != L'/' && format[0] != L'\\'));
-+ return GetConfigPath() / fmt::format(format, std::forward<TArgs>(args)...);
++ return GetConfigPath() / fmt::format(fmt::runtime(format), std::forward<TArgs>(args)...);
+ }
+
+ template <typename ...TArgs>
+ [[nodiscard]] static fs::path GetConfigPath(std::wstring_view format, TArgs&&... args)
+ {
+ cemu_assert_debug(format.empty() || (format[0] != L'/' && format[0] != L'\\'));
-+ return GetConfigPath() / fmt::format(format, std::forward<TArgs>(args)...);
++ return GetConfigPath() / fmt::format(fmt::runtime(format), std::forward<TArgs>(args)...);
+ }
+
+ template <typename ...TArgs>
+ [[nodiscard]] static fs::path GetDataPath(std::string_view format, TArgs&&... args)
+ {
+ cemu_assert_debug(format.empty() || (format[0] != L'/' && format[0] != L'\\'));
-+ return GetDataPath() / fmt::format(format, std::forward<TArgs>(args)...);
++ return GetDataPath() / fmt::format(fmt::runtime(format), std::forward<TArgs>(args)...);
+ }
+
+ template <typename ...TArgs>
+ [[nodiscard]] static fs::path GetDataPath(std::wstring_view format, TArgs&&... args)
+ {
+ cemu_assert_debug(format.empty() || (format[0] != L'/' && format[0] != L'\\'));
-+ return GetDataPath() / fmt::format(format, std::forward<TArgs>(args)...);
++ return GetDataPath() / fmt::format(fmt::runtime(format), std::forward<TArgs>(args)...);
+ }
+
+ template<typename ...TArgs>
+ [[nodiscard]] static fs::path GetSystemDataPath(std::string_view format, TArgs&&... args)
+ {
+ cemu_assert_debug(format.empty() || (format[0] != L'/' && format[0] != L'\\'));
-+ return GetSystemDataPath() / fmt::format(format, std::forward<TArgs>(args)...);
++ return GetSystemDataPath() / fmt::format(fmt::runtime(format), std::forward<TArgs>(args)...);
+ }
+
+ template<typename ...TArgs>
+ [[nodiscard]] static fs::path GetSystemDataPath(std::wstring_view format, TArgs&&... args)
+ {
+ cemu_assert_debug(format.empty() || (format[0] != L'/' && format[0] != L'\\'));
-+ return GetSystemDataPath() / fmt::format(format, std::forward<TArgs>(args)...);
++ return GetSystemDataPath() / fmt::format(fmt::runtime(format), std::forward<TArgs>(args)...);
+ }
+
// get mlc path to default cemu root dir/mlc01
@@ -510,7 +523,7 @@ index 44b5f50..e5a35d4 100644
};
-
diff --git a/src/gui/CemuApp.cpp b/src/gui/CemuApp.cpp
-index 17e31f7..1d145d3 100644
+index e78b30b..b1a72b0 100644
--- a/src/gui/CemuApp.cpp
+++ b/src/gui/CemuApp.cpp
@@ -115,7 +115,7 @@ bool CemuApp::OnInit()
@@ -549,11 +562,10 @@ index 17e31f7..1d145d3 100644
if (!fs::exists(memorySearcherFolder))
fs::create_directories(memorySearcherFolder);
}
-@@ -398,5 +402,3 @@ void CemuApp::ActivateApp(wxActivateEvent& event)
- g_window_info.app_active = event.GetActive();
+@@ -399,4 +403,3 @@ void CemuApp::ActivateApp(wxActivateEvent& event)
event.Skip();
}
--
+
-
diff --git a/src/gui/ChecksumTool.cpp b/src/gui/ChecksumTool.cpp
index 74422c9..9787ffd 100644
@@ -636,7 +648,7 @@ index 28e5bf6..6811b99 100644
size_t sbNameLen = strlen(sb.name);
if(sbNameLen == 0)
diff --git a/src/gui/MainWindow.cpp b/src/gui/MainWindow.cpp
-index b23a5ca..032d0af 100644
+index 8f26f81..2fb052e 100644
--- a/src/gui/MainWindow.cpp
+++ b/src/gui/MainWindow.cpp
@@ -997,7 +997,7 @@ void MainWindow::OnDebugSetting(wxCommandEvent& event)