summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Luna2021-08-06 20:14:14 -0500
committerChristopher Luna2021-08-06 20:14:14 -0500
commit4b04056ddd451596367d9c17b6c9f281f75081bf (patch)
tree7f5986222afd64f00db60d0806c851b99f7dc39b
parent47a9f71fdbab46d8ca5f24f92fe5672647c64c45 (diff)
downloadaur-4b04056ddd451596367d9c17b6c9f281f75081bf.tar.gz
Updated to 1.25.1c and cemuhook 1251_0574
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD14
-rw-r--r--cemu.desktop2
-rw-r--r--cemu.sh9
4 files changed, 23 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59f1d62fee98..cbce5342b149 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cemu
pkgdesc = Wii U emulator (via wine). Includes the Cemuhook plugin
- pkgver = 1.25.0
+ pkgver = 1.25.1
pkgrel = 1
url = https://cemu.info/
install = cemu.install
@@ -8,19 +8,19 @@ pkgbase = cemu
license = custom
depends = wine
depends = winetricks
- noextract = cemuhook_1159_0573.zip
+ noextract = cemuhook_1251_0574.zip
options = !strip
source = cemu.sh
source = cemu.xpm
source = cemu.desktop
- source = https://cemu.info/releases/cemu_1.25.0.zip
- source = https://files.sshnuke.net/cemuhook_1159_0573.zip
+ source = https://cemu.info/releases/cemu_1.25.1.zip
+ source = https://files.sshnuke.net/cemuhook_1251_0574.zip
source = https://web.archive.org/web/20180907210517if_/https://files.sshnuke.net/sharedFonts.7z
- md5sums = cb1dbf192ad3237a087260aa16758e95
+ md5sums = 51e12b3721d16c13caba23cc0144936f
md5sums = 54d70005a8975812ab54fcfef53f7bde
- md5sums = f419f0ebf4e14b7689eea9011555b838
- md5sums = c05ae9b867453cfcc24137c71a48b7ce
- md5sums = f5f0de02b9df62d5b6018c7a82e6d43b
+ md5sums = b2fc346c4ae4e25856c9457e8d8c1eac
+ md5sums = 5f52dfd7fb0623b3b39c787a89305188
+ md5sums = 14ce1f8e2491609f81dd0e15d76310bb
md5sums = 336a0bc0e44eede4ddf613a0eebf3bb9
pkgname = cemu
diff --git a/PKGBUILD b/PKGBUILD
index cedc57f752d3..d8c667373800 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Contributor: chrisl echo archlinux@c2h0r1i2s4t5o6p7h8e9r-l3u4n1a.com|sed 's/[0-9]//g'
pkgname=cemu
-pkgver=1.25.0
+pkgver=1.25.1
pkgrel=1
pkgdesc="Wii U emulator (via wine). Includes the Cemuhook plugin"
arch=(x86_64)
url="https://cemu.info/"
license=('custom')
depends=('wine' 'winetricks')
-_cemuhookver=1159_0573
+_cemuhookver=1251_0574
source=(
cemu.sh
cemu.xpm
@@ -24,11 +24,11 @@ install=${pkgname}.install
# Sometimes, they update the zip file without changing its name, which causes the md5sum to fail.
# If you notice this, please mark this package as out-of-date in the aur website and I'll fix it.
-md5sums=('cb1dbf192ad3237a087260aa16758e95'
+md5sums=('51e12b3721d16c13caba23cc0144936f'
'54d70005a8975812ab54fcfef53f7bde'
- 'f419f0ebf4e14b7689eea9011555b838'
- 'c05ae9b867453cfcc24137c71a48b7ce'
- 'f5f0de02b9df62d5b6018c7a82e6d43b'
+ 'b2fc346c4ae4e25856c9457e8d8c1eac'
+ '5f52dfd7fb0623b3b39c787a89305188'
+ '14ce1f8e2491609f81dd0e15d76310bb'
'336a0bc0e44eede4ddf613a0eebf3bb9')
options=(!strip)
@@ -51,7 +51,7 @@ package() {
cp -R sharedFonts $pkgdir/usr/share/$pkgname
cd cemu_$pkgver
install -m644 Cemu.exe $pkgdir/usr/share/$pkgname
- install -m644 dbghelp.dll $pkgdir/usr/share/$pkgname
+ install -m644 cemuhook.dll $pkgdir/usr/share/$pkgname
install -m644 keystone.dll $pkgdir/usr/share/$pkgname
cp -R gameProfiles $pkgdir/usr/share/$pkgname
mkdir $pkgdir/usr/share/$pkgname/mlc01
diff --git a/cemu.desktop b/cemu.desktop
index d858d6839985..c2f6e926bf54 100644
--- a/cemu.desktop
+++ b/cemu.desktop
@@ -1,5 +1,5 @@
[Desktop Entry]
-Version=1.25.0b
+Version=1.25.1c
Type=Application
Name=Cemu
Comment=Wii U emulator
diff --git a/cemu.sh b/cemu.sh
index 957f335b883b..6aa156c491f2 100644
--- a/cemu.sh
+++ b/cemu.sh
@@ -1,6 +1,6 @@
#!/bin/bash
export WINEPREFIX="$HOME/.cemu/wine"
-export WINEDLLOVERRIDES="mscoree=;mshtml=;dbghelp.dll=n,b"
+export WINEDLLOVERRIDES="mscoree=;mshtml=;cemuhook.dll=n,b"
# Allows to play BotW with Polaris video cards
export R600_DEBUG="nohyperz"
@@ -8,7 +8,7 @@ export R600_DEBUG="nohyperz"
if [ ! -d "$HOME"/.cemu ] ; then
mkdir -p "$HOME"/.cemu/wine || exit 1
ln -s /usr/share/cemu/Cemu.exe "$HOME"/.cemu/Cemu.exe || exit 1
- ln -s /usr/share/cemu/dbghelp.dll "$HOME"/.cemu/dbghelp.dll || exit 1
+ ln -s /usr/share/cemu/cemuhook.dll "$HOME"/.cemu/cemuhook.dll || exit 1
ln -s /usr/share/cemu/keystone.dll "$HOME"/.cemu/keystone.dll || exit 1
ln -s /usr/share/cemu/sharedFonts "$HOME"/.cemu/sharedFonts || exit 1
cp -r /usr/share/cemu/gameProfiles "$HOME"/.cemu/ || exit 1
@@ -16,6 +16,11 @@ if [ ! -d "$HOME"/.cemu ] ; then
cp -r /usr/share/cemu/shaderCache "$HOME"/.cemu/ || exit 1
fi
+if [ -d "$HOME"/.cemu ] && [ -L "$HOME"/.cemu/dbghelp.dll ] ; then
+ rm "$HOME"/.cemu/dbghelp.dll
+ ln -s /usr/share/cemu/cemuhook.dll "$HOME"/.cemu/cemuhook.dll || exit 1
+fi
+
if [ ! -L "$HOME"/.cemu/sharedFonts ] && [ ! -d "$HOME"/.cemu/sharedFonts ] ; then
ln -s /usr/share/cemu/sharedFonts "$HOME"/.cemu/sharedFonts || exit 1
fi