summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuskuss2022-09-17 16:58:07 +0200
committerAnuskuss2022-09-17 16:58:07 +0200
commit5b1097d9d561511465a3190053a9a786eb531a0d (patch)
treeb7d0b90cab484fe95eb7bb43300b67f1d6698afb
parent263bdfec5db03d86485bb73c47a88373e5f7985d (diff)
downloadaur-5b1097d9d561511465a3190053a9a786eb531a0d.tar.gz
Updated to latest version
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD46
-rw-r--r--dark.diff253
-rw-r--r--gamelist.diff16
-rw-r--r--mic.diff6
-rw-r--r--xdg.diff10
6 files changed, 49 insertions, 306 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 934929f33859..a4b399e1bdba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cemu
pkgdesc = Software to emulate Wii U games and applications on PC (with cutting edge Linux patches)
- pkgver = 2.0.128
+ pkgver = 2.0.138
pkgrel = 1
url = https://cemu.info
install = cemu.install
@@ -10,8 +10,8 @@ pkgbase = cemu
makedepends = cmake>=3.21.1
makedepends = make
makedepends = rapidjson
- makedepends = boost>=1.79.0
- makedepends = glslang>=11.8.0
+ makedepends = boost>=1.79
+ makedepends = glslang>=11.8
makedepends = glm>=0.9.9.8
makedepends = fmt>=9.1
makedepends = nasm
@@ -21,19 +21,18 @@ pkgbase = cemu
depends = pugixml>=1.12.1
depends = libzip>=1.9.2
depends = libpng>=1.6.37
- depends = wxwidgets-gtk3>=3.2.0
+ depends = wxwidgets-gtk3>=3.2
optdepends = vulkan-driver: Vulkan graphics
- source = git+https://github.com/cemu-project/Cemu#commit=cebdccfdf5aec30aa2ab7c61c4720ec2191bdb8f
+ source = git+https://github.com/cemu-project/Cemu#commit=12b6830546e28e6a697c5dbcbc3aa24882ec7fb3
source = imgui-1.88.tar.gz::https://github.com/ocornut/imgui/archive/refs/tags/v1.88.tar.gz
- source = imgui.cmake::https://raw.githubusercontent.com/microsoft/vcpkg/1b0252ca70ca2244a711535462c7f981eb439e83/ports/imgui/CMakeLists.txt
- source = imgui.conf::https://raw.githubusercontent.com/microsoft/vcpkg/1b0252ca70ca2244a711535462c7f981eb439e83/ports/imgui/imgui-config.cmake.in
+ source = imgui.cmake::https://raw.githubusercontent.com/microsoft/vcpkg/1b0252c/ports/imgui/CMakeLists.txt
+ source = imgui.conf::https://raw.githubusercontent.com/microsoft/vcpkg/1b0252c/ports/imgui/imgui-config.cmake.in
source = git+https://github.com/mozilla/cubeb#commit=dc511c6b3597b6384d28949285b9289e009830ea
- source = git+https://github.com/Exzap/ZArchive#commit=48914a07df3c213333c580bb5e5bb3393442ca5b
+ source = git+https://github.com/Exzap/ZArchive#commit=d2c717730092c7bf8cbb033b12fd4001b7c4d932
source = git+https://github.com/arsenm/sanitizers-cmake#commit=aab6948fa863bc1cbe5d0850bc46b9ef02ed4c1a
source = git+https://github.com/google/googletest#commit=800f5422ac9d9e0ad59cd860a2ef3a679588acb4
source = xdg.diff
source = overlay.diff
- source = dark.diff
source = gamelist.diff
source = mic.diff
sha256sums = SKIP
@@ -44,10 +43,9 @@ pkgbase = cemu
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 8c108b92d641b404d753b72aecfd7ebfa7609f84e8fa4b1318227a5a33bbe240
+ sha256sums = 6c6f0d4f68e86aeb7d61cff7af12a6522761188d0f12f7fb92427de6e531eaec
sha256sums = f25d13fe76cc6a0b475f0131211a951288160ddae92cd7a815f5aea61d7cfc0f
- sha256sums = 3c5527c6aa07bca9425b2bad5cd84102d5a7ab5ce61dadff727ce977a005aeae
- sha256sums = 7f1b11b78de3f9f96d2af9569a980f066422bfc68f76e03bf8c253dc926c03f2
- sha256sums = 3a3b29fc2643433c94d5244eaa3c3ff689929563c74f540b7b29266329c5a494
+ sha256sums = 00a8b51434c45f595b54b3d317719cd36955ce36dcb246c796eabfd3d3967ed1
+ sha256sums = 182113fe927b9bc3dd0dd94e1caa9f725dbeffc70c137615c3145fa135b7d9da
pkgname = cemu
diff --git a/PKGBUILD b/PKGBUILD
index 811a126d8153..0e906623c624 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Anuskuss <anuskuss@googlemail.com>
pkgname=cemu
-pkgver=2.0.128
+pkgver=2.0.138
pkgrel=1
pkgdesc='Software to emulate Wii U games and applications on PC (with cutting edge Linux patches)'
arch=(x86_64)
@@ -8,13 +8,15 @@ url=https://cemu.info
license=(MPL2)
depends=(
# unbundled vcpkg
- 'sdl2>=2.0.22' 'pugixml>=1.12.1' 'libzip>=1.9.2' 'libpng>=1.6.37' 'wxwidgets-gtk3>=3.2.0'
+ 'sdl2>=2.0.22' 'pugixml>=1.12.1' 'libzip>=1.9.2' 'libpng>=1.6.37' 'wxwidgets-gtk3>=3.2'
)
makedepends=(
# pkgbuild
git 'cmake>=3.21.1' make
+ # clang
+ $([[ $CC+$CXX == *clang* ]] && echo 'clang>=12 llvm>=12')
# unbundled vcpkg
- rapidjson 'boost>=1.79.0' 'glslang>=11.8.0' 'glm>=0.9.9.8' 'fmt>=9.1'
+ rapidjson 'boost>=1.79' 'glslang>=11.8' 'glm>=0.9.9.8' 'fmt>=9.1'
# cemu
nasm 'vulkan-headers>=1.3.225'
# wxwidgets
@@ -25,23 +27,22 @@ optdepends=(
)
install=cemu.install
source=(
- git+https://github.com/cemu-project/Cemu#commit=cebdccfdf5aec30aa2ab7c61c4720ec2191bdb8f
+ git+https://github.com/cemu-project/Cemu#commit=12b6830546e28e6a697c5dbcbc3aa24882ec7fb3
# dependencies
imgui-1.88.tar.gz::https://github.com/ocornut/imgui/archive/refs/tags/v1.88.tar.gz
- imgui.cmake::https://raw.githubusercontent.com/microsoft/vcpkg/1b0252ca70ca2244a711535462c7f981eb439e83/ports/imgui/CMakeLists.txt
- imgui.conf::https://raw.githubusercontent.com/microsoft/vcpkg/1b0252ca70ca2244a711535462c7f981eb439e83/ports/imgui/imgui-config.cmake.in
+ imgui.cmake::https://raw.githubusercontent.com/microsoft/vcpkg/1b0252c/ports/imgui/CMakeLists.txt
+ imgui.conf::https://raw.githubusercontent.com/microsoft/vcpkg/1b0252c/ports/imgui/imgui-config.cmake.in
# submodules
git+https://github.com/mozilla/cubeb#commit=dc511c6b3597b6384d28949285b9289e009830ea
# git+https://github.com/microsoft/vcpkg#commit=1b0252ca70ca2244a711535462c7f981eb439e83
# git+https://github.com/KhronosGroup/Vulkan-Headers#commit=715673702f5b18ffb8e5832e67cf731468d32ac6
- git+https://github.com/Exzap/ZArchive#commit=48914a07df3c213333c580bb5e5bb3393442ca5b
+ git+https://github.com/Exzap/ZArchive#commit=d2c717730092c7bf8cbb033b12fd4001b7c4d932
# cubeb submodules
git+https://github.com/arsenm/sanitizers-cmake#commit=aab6948fa863bc1cbe5d0850bc46b9ef02ed4c1a
git+https://github.com/google/googletest#commit=800f5422ac9d9e0ad59cd860a2ef3a679588acb4
# patches
xdg.diff # 00dbe939f29c6fa6670a6f71946e52b520d51033
overlay.diff # edeb14d4c68ee8bf500b990b13079177e01c25f1
- dark.diff # dd8c91f7fa1af00a85dd54a7a24d10bc11c4ee4b
gamelist.diff # 182b40d38964a4c296127c5eb4497b5cccc01802
mic.diff # 5231a71527cb57ea79b1b2ab9e4d7247d9141dd1
)
@@ -54,36 +55,35 @@ sha256sums=(
SKIP
SKIP
SKIP
- 8c108b92d641b404d753b72aecfd7ebfa7609f84e8fa4b1318227a5a33bbe240
+ 6c6f0d4f68e86aeb7d61cff7af12a6522761188d0f12f7fb92427de6e531eaec
f25d13fe76cc6a0b475f0131211a951288160ddae92cd7a815f5aea61d7cfc0f
- 3c5527c6aa07bca9425b2bad5cd84102d5a7ab5ce61dadff727ce977a005aeae
- 7f1b11b78de3f9f96d2af9569a980f066422bfc68f76e03bf8c253dc926c03f2
- 3a3b29fc2643433c94d5244eaa3c3ff689929563c74f540b7b29266329c5a494
+ 00a8b51434c45f595b54b3d317719cd36955ce36dcb246c796eabfd3d3967ed1
+ 182113fe927b9bc3dd0dd94e1caa9f725dbeffc70c137615c3145fa135b7d9da
)
pkgver() {
cd Cemu
- MAJ=$(awk -F '\t' '/LEAD/ {print $NF;exit}' src/Common/version.h)
- MIN=$(awk -F '\t' '/MAJOR/ {print $NF;exit}' src/Common/version.h)
+ MAJ=$(awk -F'\t' '/LEAD/ {print $NF;exit}' src/Common/version.h)
+ MIN=$(awk -F'\t' '/MAJOR/ {print $NF;exit}' src/Common/version.h)
PAT=$(git rev-list --count HEAD)
echo "$MAJ.$MIN.$PAT"
}
prepare() {
cd Cemu
- echo "#define BUILD_VERSION_WITH_NAME_STRING \"Cemu $pkgver\"" >> src/Common/version.h
+ sed -i "s/ (experimental)/.${pkgver##*.}/" src/Common/version.h
# cemu submodules
for submodule in dependencies/{cubeb,ZArchive}; do
- git config submodule.$submodule.url "$srcdir/${submodule##*/}"
+ git config submodule.$submodule.url "file://$srcdir/${submodule##*/}"
git submodule update --init $submodule
done
- pushd dependencies/cubeb
+ pushd dependencies/cubeb > /dev/null
for submodule in {cmake/sanitizers-cmake,googletest}; do
- git config submodule.$submodule.url "$srcdir/${submodule##*/}"
+ git config submodule.$submodule.url "file://$srcdir/${submodule##*/}"
git submodule update --init $submodule
done
- popd
+ popd > /dev/null
# unbundled imgui
sed -i '/imgui/cadd_subdirectory(dependencies/imgui)' CMakeLists.txt
@@ -107,9 +107,7 @@ prepare() {
# experimental: linux overlay (https://github.com/cemu-project/Cemu/pull/142)
rm -rf src/util/SystemInfo
git apply "$srcdir/overlay.diff"
-
- # experimental: dark mode fix (https://github.com/cemu-project/Cemu/pull/241)
- git apply "$srcdir/dark.diff"
+ sed -i '/add_library/aSystemInfo/SystemInfo.cpp SystemInfo/SystemInfoLinux.cpp' src/util/CMakeLists.txt
# experimental: gamelist auto resize (https://github.com/cemu-project/Cemu/pull/214)
git apply "$srcdir/gamelist.diff"
@@ -123,8 +121,8 @@ build() {
# prefer clang (faster)
if [[ $(clang --version 2> /dev/null | sed -E '1!d;s/^clang version ([0-9]+)\.[0-9]+\.[0-9]+$/\1/') -ge 12 ]] &&
[[ $(llvm-config --version 2> /dev/null | sed -E 's/^([0-9]+)\.[0-9]+\.[0-9]+$/\1/') -ge 12 ]]; then
- export CC=$(which clang)
- export CXX=$(which clang++ 2> /dev/null || which clang)
+ [[ -z $CC ]] && export CC=$(which clang)
+ [[ -z $CXX ]] && export CXX=$(which clang++)
fi
cd Cemu
diff --git a/dark.diff b/dark.diff
deleted file mode 100644
index 2baab8088256..000000000000
--- a/dark.diff
+++ /dev/null
@@ -1,253 +0,0 @@
---- a/src/gui/components/wxGameList.cpp
-+++ b/src/gui/components/wxGameList.cpp
-@@ -71,8 +71,8 @@ wxGameList::wxGameList(wxWindow* parent, wxWindowID id)
- m_tooltip_window->SetBackgroundColour(wxSystemSettings::GetColour(wxSYS_COLOUR_INFOBK));
- m_tooltip_window->SetSizerAndFit(tooltip_sizer);
- m_tooltip_window->Hide();
--
-- m_tooltip_timer = new wxTimer(this);
-+
-+ m_tooltip_timer = new wxTimer(this);
-
- Bind(wxEVT_CLOSE_WINDOW, &wxGameList::OnClose, this);
- Bind(wxEVT_MOTION, &wxGameList::OnMouseMove, this);
-@@ -125,16 +125,16 @@ void wxGameList::LoadConfig()
- {
- wxArrayInt order;
- order.reserve(ColumnFavorite);
--
-+
- const auto order_string = std::string_view(config.game_list_column_order).substr(1);
--
-+
- const boost::char_separator<char> sep(",");
- boost::tokenizer tokens(order_string.begin(), order_string.end(), sep);
- for(const auto& token : tokens)
- {
- order.push_back(ConvertString<int>(token, 10));
- }
--
-+
- #ifdef wxHAS_LISTCTRL_COLUMN_ORDER
- if(order.GetCount() == ColumnFavorite)
- SetColumnsOrder(order);
-@@ -209,10 +209,10 @@ void wxGameList::SetStyle(Style style, bool save)
- return;
-
- wxWindowUpdateLocker updatelock(this);
--
-+
- m_style = style;
- SetWindowStyleFlag(GetStyleFlags(m_style));
--
-+
- uint64 selected_title_id = 0;
- auto selection = GetNextItem(wxNOT_FOUND, wxLIST_NEXT_ALL, wxLIST_STATE_SELECTED);
- if (selection != wxNOT_FOUND)
-@@ -230,7 +230,7 @@ void wxGameList::SetStyle(Style style, bool save)
- wxListCtrl::SetImageList(m_image_list_small, wxIMAGE_LIST_NORMAL);
- break;
- }
--
-+
- ReloadGameEntries();
- SortEntries();
- UpdateItemColors();
-@@ -269,16 +269,42 @@ long wxGameList::GetStyleFlags(Style style) const
-
- void wxGameList::UpdateItemColors(sint32 startIndex)
- {
-+
- wxWindowUpdateLocker lock(this);
-+
-+ // Get the background color so we can determine the theme in use
-+ const wxColour bgColour = GetBackgroundColour();
-+
- for (int i = startIndex; i < GetItemCount(); ++i)
- {
- const auto titleId = (uint64)GetItemData(i);
- if (GetConfig().IsGameListFavorite(titleId))//entry->favorite)
-+ {
- SetItemBackgroundColour(i, kFavoriteColor);
-+ SetItemTextColour(i, 0x000000UL);
-+ }
- else if ((i&1) != 0)
-- SetItemBackgroundColour(i, kSecondColor);
-+ {
-+ // Depending on the background RGB value:
-+ // Light theme row color will be 10% darker (90)
-+ // Dark theme row color will be 10% brighter (110)
-+ int alpha = bgColour.GetRGB() > 0x808080 ? 90 : 110;
-+ SetItemBackgroundColour(i, bgColour.ChangeLightness(alpha));
-+
-+ // Text can be changed to other values for alternating rows if needed
-+ SetItemTextColour(i, wxSystemSettings::GetColour(wxSYS_COLOUR_WINDOWTEXT));
-+ }
- else
-- SetItemBackgroundColour(i, 0xFFFFFFUL);
-+ {
-+ // Depending on the background RGB value:
-+ // Light theme row color will be 0% darker (100)
-+ // Dark theme row color will be 0% brighter (100)
-+ int alpha = bgColour.GetRGB() > 0x808080 ? 100 : 100;
-+ SetItemBackgroundColour(i, bgColour.ChangeLightness(alpha));
-+
-+ // Text color can be modified to other values for alternating rows if needed
-+ SetItemTextColour(i, wxSystemSettings::GetColour(wxSYS_COLOUR_WINDOWTEXT));
-+ }
- }
- }
-
-@@ -309,7 +335,7 @@ int wxGameList::SortFunction(wxIntPtr item1, wxIntPtr item2, wxIntPtr sortData)
- {
- const auto sort_data = (SortData*)sortData;
- const int dir = sort_data->dir;
--
-+
- return sort_data->thisptr->SortComparator((uint64)item1, (uint64)item2, sort_data);
- }
-
-@@ -331,7 +357,7 @@ void wxGameList::SortEntries(int column)
- s_direction = 1;
- }
- }
--
-+
- switch (column)
- {
- case ColumnName:
-@@ -349,7 +375,7 @@ void wxGameList::SortEntries(int column)
- void wxGameList::CreateListColumns()
- {
- DeleteAllColumns();
--
-+
- const auto& config = GetConfig();
- wxListItem col0;
- col0.SetId(ColumnHiddenName);
-@@ -392,7 +418,7 @@ void wxGameList::CreateListColumns()
- col6.SetText(_("Last played"));
- col6.SetWidth(config.column_width.game_started);
- InsertColumn(ColumnGameStarted, col6);
--
-+
- wxListItem col7;
- col7.SetId(ColumnRegion);
- col7.SetText(_("Region"));
-@@ -405,7 +431,7 @@ void wxGameList::OnKeyDown(wxListEvent& event)
- event.Skip();
- if (m_style != Style::kList)
- return;
--
-+
- const auto keycode = std::tolower(event.m_code);
- if (keycode == WXK_LEFT)
- {
-@@ -445,12 +471,12 @@ void wxGameList::OnKeyDown(wxListEvent& event)
- enum ContextMenuEntries
- {
- kContextMenuRefreshGames = wxID_HIGHEST + 1,
--
-+
- kContextMenuStart,
- kWikiPage,
- kContextMenuFavorite,
- kContextMenuEditName,
--
-+
- kContextMenuGameFolder,
- kContextMenuSaveFolder,
- kContextMenuUpdateFolder,
-@@ -465,10 +491,10 @@ enum ContextMenuEntries
- void wxGameList::OnContextMenu(wxContextMenuEvent& event)
- {
- auto& config = GetConfig();
--
-+
- wxMenu menu;
- menu.Bind(wxEVT_COMMAND_MENU_SELECTED, &wxGameList::OnContextMenuSelected, this);
--
-+
- const auto selection = GetNextItem(-1, wxLIST_NEXT_ALL, wxLIST_STATE_SELECTED);
- if (selection != wxNOT_FOUND)
- {
-@@ -486,18 +512,18 @@ void wxGameList::OnContextMenu(wxContextMenuEvent& event)
- menu.AppendSeparator();
- menu.AppendCheckItem(kContextMenuFavorite, _("&Favorite"))->Check(isFavorite);
- menu.Append(kContextMenuEditName, _("&Edit name"));
--
-+
- menu.AppendSeparator();
- menu.Append(kWikiPage, _("&Wiki page"));
- menu.Append(kContextMenuGameFolder, _("&Game directory"));
- menu.Append(kContextMenuSaveFolder, _("&Save directory"))->Enable(fs::is_directory(gameInfo.GetSaveFolder(), ec));
- menu.Append(kContextMenuUpdateFolder, _("&Update directory"))->Enable(gameInfo.HasUpdate());
- menu.Append(kContextMenuDLCFolder, _("&DLC directory"))->Enable(gameInfo.HasAOC());
--
-+
- menu.AppendSeparator();
- menu.Append(kContextMenuEditGraphicPacks, _("&Edit graphic packs"));
- menu.Append(kContextMenuEditGameProfile, _("&Edit game profile"));
--
-+
- menu.AppendSeparator();
- }
- }
-@@ -581,7 +607,7 @@ void wxGameList::OnContextMenuSelected(wxCommandEvent& event)
- }
- break;
- }
--
-+
- case kContextMenuSaveFolder:
- {
- wxLaunchDefaultBrowser(wxHelper::FromUtf8(fmt::format("file:{}", _pathToUtf8(gameInfo.GetSaveFolder()))));
-@@ -647,7 +673,7 @@ void wxGameList::OnColumnRightClick(wxListEvent& event)
- {
- ResetWidth = wxID_HIGHEST + 1,
- ResetOrder,
--
-+
- ShowName,
- ShowVersion,
- ShowDlc,
-@@ -658,10 +684,10 @@ void wxGameList::OnColumnRightClick(wxListEvent& event)
- const int column = event.GetColumn();
- wxMenu menu;
- menu.SetClientObject(new wxCustomData(column));
--
-+
- menu.Append(ResetWidth, _("Reset &width"));
- menu.Append(ResetOrder, _("Reset &order")) ;
--
-+
- menu.AppendSeparator();
- menu.AppendCheckItem(ShowName, _("Show &name"))->Check(GetColumnWidth(ColumnName) > 0);
- menu.AppendCheckItem(ShowVersion, _("Show &version"))->Check(GetColumnWidth(ColumnVersion) > 0);
-@@ -758,7 +784,7 @@ void wxGameList::ApplyGameListColumnWidths()
- else
- this->SetColumnWidth(id, width);
- };
--
-+
- const auto& config = GetConfig();
- wxWindowUpdateLocker lock(this);
- set_width(ColumnName, config.column_width.name);
-@@ -943,7 +969,7 @@ void wxGameList::OnItemActivated(wxListEvent& event)
- wxPostEvent(this, open_settings_event);
- return;
- }
--
-+
- TitleInfo titleInfo;
- if (!CafeTitleList::GetFirstByTitleId(item_data, titleInfo))
- return;
-@@ -974,7 +1000,7 @@ void wxGameList::OnTimer(wxTimerEvent& event)
- //}
- }
- }
--
-+
- }
-
- void wxGameList::OnMouseMove(wxMouseEvent& event)
diff --git a/gamelist.diff b/gamelist.diff
index e6a0d59b8ce9..24ac40b2e1ee 100644
--- a/gamelist.diff
+++ b/gamelist.diff
@@ -148,7 +148,7 @@
if (flush)
g_config.Save();
-@@ -372,61 +373,7 @@ void wxGameList::SortEntries(int column)
+@@ -366,61 +367,7 @@ void wxGameList::SortEntries(int column)
}
}
@@ -211,7 +211,7 @@
{
event.Skip();
if (m_style != Style::kList)
-@@ -659,6 +616,12 @@ void wxGameList::OnContextMenuSelected(wxCommandEvent& event)
+@@ -653,6 +610,12 @@ void wxGameList::OnContextMenuSelected(wxCommandEvent& event)
}
}
@@ -224,7 +224,7 @@
void wxGameList::OnColumnClick(wxListEvent& event)
{
const int column = event.GetColumn();
-@@ -686,17 +649,16 @@ void wxGameList::OnColumnRightClick(wxListEvent& event)
+@@ -680,17 +643,16 @@ void wxGameList::OnColumnRightClick(wxListEvent& event)
menu.SetClientObject(new wxCustomData(column));
menu.Append(ResetWidth, _("Reset &width"));
@@ -246,7 +246,7 @@
menu.Bind(wxEVT_COMMAND_MENU_SELECTED,
[this](wxCommandEvent& event) {
-@@ -709,44 +668,44 @@ void wxGameList::OnColumnRightClick(wxListEvent& event)
+@@ -703,44 +662,44 @@ void wxGameList::OnColumnRightClick(wxListEvent& event)
switch (event.GetId())
{
case ShowName:
@@ -304,7 +304,7 @@
break;
default:
return;
-@@ -757,11 +719,11 @@ void wxGameList::OnColumnRightClick(wxListEvent& event)
+@@ -751,11 +713,11 @@ void wxGameList::OnColumnRightClick(wxListEvent& event)
case ResetOrder:
{
config.game_list_column_order.clear();
@@ -319,7 +319,7 @@
Refresh();
return;
}
-@@ -775,31 +737,60 @@ void wxGameList::OnColumnRightClick(wxListEvent& event)
+@@ -769,31 +731,60 @@ void wxGameList::OnColumnRightClick(wxListEvent& event)
event.Skip();
}
@@ -395,7 +395,7 @@
event.Veto();
else
event.Skip();
-@@ -829,21 +820,18 @@ void wxGameList::OnColumnResize(wxListEvent& event)
+@@ -823,21 +814,18 @@ void wxGameList::OnColumnResize(wxListEvent& event)
case ColumnGameStarted:
config.column_width.game_started = width;
break;
@@ -422,7 +422,7 @@
void wxGameList::OnClose(wxCloseEvent& event)
{
event.Skip();
-@@ -854,8 +842,6 @@ int wxGameList::FindInsertPosition(TitleId titleId)
+@@ -848,8 +836,6 @@ int wxGameList::FindInsertPosition(TitleId titleId)
{
SortData data{ this, s_last_column, s_direction };
const auto itemCount = GetItemCount();
diff --git a/mic.diff b/mic.diff
index da2ec7e993e7..8606039dea46 100644
--- a/mic.diff
+++ b/mic.diff
@@ -175,7 +175,7 @@
namespace mic
--- a/src/audio/CMakeLists.txt
+++ b/src/audio/CMakeLists.txt
-@@ -3,6 +3,8 @@ project(CemuAudio)
+@@ -1,6 +1,8 @@ project(CemuAudio)
add_library(CemuAudio
IAudioAPI.cpp
IAudioAPI.h
@@ -184,7 +184,7 @@
)
set_property(TARGET CemuAudio PROPERTY MSVC_RUNTIME_LIBRARY "MultiThreaded$<$<CONFIG:Debug>:Debug>")
-@@ -28,6 +30,8 @@ if(ENABLE_CUBEB)
+@@ -26,6 +28,8 @@ if(ENABLE_CUBEB)
target_sources(CemuAudio PRIVATE
CubebAPI.cpp
CubebAPI.h
@@ -766,7 +766,7 @@
config.pad_volume = m_pad_volume->GetValue();
+ config.input_volume = m_input_volume->GetValue();
- config.tv_device = L"";
+ config.tv_device.clear();
const auto tv_device = m_tv_device->GetSelection();
@@ -861,6 +916,15 @@ void GeneralSettings2::StoreConfig()
config.pad_device = device_description->GetDescription()->GetIdentifier();
diff --git a/xdg.diff b/xdg.diff
index ab7416dfdf18..866f1986ff1d 100644
--- a/xdg.diff
+++ b/xdg.diff
@@ -262,7 +262,7 @@
if (fs::file_size(seeprom_file, ec) != 512)
--- a/src/Cafe/OS/RPL/rpl.cpp
+++ b/src/Cafe/OS/RPL/rpl.cpp
-@@ -2122,7 +2122,7 @@ void RPLLoader_LoadDependency(rplDependency_t* dependency)
+@@ -2116,7 +2116,7 @@ void RPLLoader_LoadDependency(rplDependency_t* dependency)
// attempt to load rpl from Cemu's /cafeLibs/ directory
if (ActiveSettings::LoadSharedLibrariesEnabled())
{
@@ -678,7 +678,7 @@
if(sbNameLen == 0)
--- a/src/gui/MainWindow.cpp
+++ b/src/gui/MainWindow.cpp
-@@ -999,7 +999,7 @@ void MainWindow::OnDebugSetting(wxCommandEvent& event)
+@@ -989,7 +989,7 @@ void MainWindow::OnDebugSetting(wxCommandEvent& event)
{
try
{
@@ -687,7 +687,7 @@
fs::create_directories(path);
}
catch (const std::exception& ex)
-@@ -1056,8 +1056,8 @@ void MainWindow::OnDebugDumpUsedTextures(wxCommandEvent& event)
+@@ -1046,8 +1046,8 @@ void MainWindow::OnDebugDumpUsedTextures(wxCommandEvent& event)
try
{
// create directory
@@ -698,7 +698,7 @@
}
catch (const std::exception& ex)
{
-@@ -1077,8 +1077,8 @@ void MainWindow::OnDebugDumpUsedShaders(wxCommandEvent& event)
+@@ -1067,8 +1067,8 @@ void MainWindow::OnDebugDumpUsedShaders(wxCommandEvent& event)
try
{
// create directory
@@ -751,7 +751,7 @@
void DebuggerWindow2::OnBreakpointHit(wxCommandEvent& event)
--- a/src/gui/input/InputSettings2.cpp
+++ b/src/gui/input/InputSettings2.cpp
-@@ -669,10 +669,10 @@ void InputSettings2::on_profile_delete(wxCommandEvent& event)
+@@ -667,10 +667,10 @@ void InputSettings2::on_profile_delete(wxCommandEvent& event)
}
try
{