summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuskuss2022-09-08 02:55:22 +0200
committerAnuskuss2022-09-08 02:55:22 +0200
commit5b9dfd1628e844fb078f7e6fe4113288a45cbb14 (patch)
treeaa934f31e6f6040e7a76552a8e3416da4fbd88bf
parent9736a7cf041004d956d42f5c689a0b765771b026 (diff)
downloadaur-5b9dfd1628e844fb078f7e6fe4113288a45cbb14.tar.gz
Added introduction, fixed exit crash and updated to latest version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--cemu.install16
3 files changed, 26 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8702038a7b15..6f99d718d9f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = cemu
pkgdesc = Software to emulate Wii U games and applications on PC (with cutting edge Linux patches)
- pkgver = 2.0.99
+ pkgver = 2.0.104
pkgrel = 1
url = https://cemu.info
+ install = cemu.install
arch = x86_64
license = MPL2
makedepends = git
@@ -22,7 +23,7 @@ pkgbase = cemu
depends = libpng
depends = wxwidgets-gtk3>=3.2
optdepends = vulkan-driver: Vulkan graphics
- source = git+https://github.com/cemu-project/Cemu#commit=e20bfd00ecfc4376e39048942c15a55463f065d0
+ source = git+https://github.com/cemu-project/Cemu#commit=6cdb6eed1730cde23ede99099a12092b9abe8aa3
source = imgui-1.88.tar.gz::https://github.com/ocornut/imgui/archive/refs/tags/v1.88.tar.gz
source = imgui.cmake::https://raw.githubusercontent.com/microsoft/vcpkg/master/ports/imgui/CMakeLists.txt
source = imgui.conf::https://raw.githubusercontent.com/microsoft/vcpkg/master/ports/imgui/imgui-config.cmake.in
diff --git a/PKGBUILD b/PKGBUILD
index b1ccdf984b21..18a3c77e30e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Anuskuss <anuskuss@googlemail.com>
pkgname=cemu
-pkgver=2.0.99
+pkgver=2.0.104
pkgrel=1
pkgdesc='Software to emulate Wii U games and applications on PC (with cutting edge Linux patches)'
arch=(x86_64)
@@ -23,8 +23,9 @@ makedepends=(
optdepends=(
'vulkan-driver: Vulkan graphics'
)
+install=cemu.install
source=(
- git+https://github.com/cemu-project/Cemu#commit=e20bfd00ecfc4376e39048942c15a55463f065d0
+ git+https://github.com/cemu-project/Cemu#commit=6cdb6eed1730cde23ede99099a12092b9abe8aa3
# dependencies
imgui-1.88.tar.gz::https://github.com/ocornut/imgui/archive/refs/tags/v1.88.tar.gz
imgui.cmake::https://raw.githubusercontent.com/microsoft/vcpkg/master/ports/imgui/CMakeLists.txt
@@ -40,7 +41,6 @@ source=(
# patches
xdg.diff # 963f9b38349c5d03b26ab2a50ead2ee4e743ca41
overlay.diff # edeb14d4c68ee8bf500b990b13079177e01c25f1
-
)
sha256sums=(
SKIP
@@ -93,15 +93,16 @@ prepare() {
# glslang fix
sed -i 's/GLSLANG_VERSION_LESS/GLSLANG_VERSION_GREATER/' src/Cafe/HW/Latte/Renderer/Vulkan/RendererShaderVk.cpp
+ # exit crash fix
+ sed -i 's/exit(0)/_exit(0)/g' src/gui/CemuApp.cpp
+
# experimental: xdg base dir (https://github.com/cemu-project/Cemu/pull/130)
git apply "$srcdir/xdg.diff"
+ sed -i 's|gameProfiles/default|gameProfiles|' src/Cafe/GameProfile/GameProfile.cpp
# experimental: linux overlay (https://github.com/cemu-project/Cemu/pull/142)
rm -rf src/util/SystemInfo
git apply "$srcdir/overlay.diff"
-
- # gameProfiles improvement
- sed -i 's|gameProfiles/default|gameProfiles|' src/Cafe/GameProfile/GameProfile.cpp
}
build() {
diff --git a/cemu.install b/cemu.install
new file mode 100644
index 000000000000..b871eca1c1e7
--- /dev/null
+++ b/cemu.install
@@ -0,0 +1,16 @@
+post_install() {
+cat << 'EOF'
++------------------------------------------------------------------------------+
+| This software is still experimental! Many features are missing (e.g. Online) |
+| and current performance is worse than running through Wine (AUR: cemu-wine) |
+| and much worse than Windows. |
+| |
+| This package follows the XDG Base Directory Specification: |
+| Put your keys in your "$XDG_CONFIG_HOME" (default: ~/.config/cemu/keys.txt) |
+| Put your mlc01 in your "$XDG_DATA_HOME" (default: ~/.local/share/cemu/mlc01) |
+| |
+| Linux specific issues: https://github.com/cemu-project/Cemu/issues |
+| Arch specific issues: https://aur.archlinux.org/packages/cemu |
++------------------------------------------------------------------------------+
+EOF
+}