summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Luna2022-02-11 19:02:00 -0600
committerChristopher Luna2022-02-11 19:02:00 -0600
commit71987ba6b55fcf535bdefac9be0e920dfa24bdf8 (patch)
tree1522a5daf98c7290a0a6701f80a641d843164531
parent950a152a9eced9e28b76f77f517b751f6c515d3a (diff)
downloadaur-71987ba6b55fcf535bdefac9be0e920dfa24bdf8.tar.gz
Updated to 1.26.2. Removed cemuhook
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--cemu.desktop2
-rw-r--r--cemu.sh8
4 files changed, 17 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ee53dc1294a..e1a11b5ce30e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cemu
- pkgdesc = Wii U emulator (via wine). Includes the Cemuhook plugin
- pkgver = 1.26.1
+ pkgdesc = Wii U emulator (via wine).
+ pkgver = 1.26.2
pkgrel = 1
url = https://cemu.info/
install = cemu.install
@@ -9,19 +9,16 @@ pkgbase = cemu
depends = wine
depends = winetricks
optdepends = wine-ge-custom: Vulkan support
- noextract = cemuhook_1251c_0575.zip
options = !strip
source = cemu.sh
source = cemu.xpm
source = cemu.desktop
- source = cemu_1.26.1-1.zip::https://cemu.info/releases/cemu_1.26.1.zip
- source = https://files.sshnuke.net/cemuhook_1251c_0575.zip
+ source = cemu_1.26.2-1.zip::https://cemu.info/releases/cemu_1.26.2.zip
source = https://web.archive.org/web/20180907210517if_/https://files.sshnuke.net/sharedFonts.7z
- md5sums = 4a5add39abfee819f76e4eceef4971b7
+ md5sums = 0e2f22844f73513d91d0b42474bb8ff2
md5sums = 54d70005a8975812ab54fcfef53f7bde
- md5sums = dd3bfdd9ab2c8b1d21bb83166017c102
- md5sums = 60c4d7a0a513d18661c470924a6df2b4
- md5sums = 266d9f45c6c75a1a7d5d80da0e97857e
+ md5sums = 3325fba5405408c3bbf650ecfd679692
+ md5sums = 726dc9328e42e4db934ea24aba511ec7
md5sums = 336a0bc0e44eede4ddf613a0eebf3bb9
pkgname = cemu
diff --git a/PKGBUILD b/PKGBUILD
index 9eb30302ddf6..5f691ce61644 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,36 @@
# Contributor: chrisl echo archlinux@c2h0r1i2s4t5o6p7h8e9r-l3u4n1a.com|sed 's/[0-9]//g'
pkgname=cemu
-pkgver=1.26.1
+pkgver=1.26.2
pkgrel=1
-pkgdesc="Wii U emulator (via wine). Includes the Cemuhook plugin"
+pkgdesc="Wii U emulator (via wine)."
arch=(x86_64)
url="https://cemu.info/"
license=('custom')
depends=('wine' 'winetricks')
-_cemuhookver=1251c_0575
source=(
cemu.sh
cemu.xpm
cemu.desktop
cemu_${pkgver}-${pkgrel}.zip::https://cemu.info/releases/cemu_${pkgver}.zip
- https://files.sshnuke.net/cemuhook_${_cemuhookver}.zip
https://web.archive.org/web/20180907210517if_/https://files.sshnuke.net/sharedFonts.7z
)
# The link for the sharedFonts comes from here: https://github.com/decaf-emu/decaf-emu/issues/29#issuecomment-315511347
-noextract=("cemuhook_${_cemuhookver}.zip")
install=${pkgname}.install
optdepends=('wine-ge-custom: Vulkan support')
# Sometimes, they update the zip file without changing its name, which causes the md5sum to fail.
# If you notice this, please mark this package as out-of-date in the aur website and I'll fix it.
-md5sums=('4a5add39abfee819f76e4eceef4971b7'
+md5sums=('0e2f22844f73513d91d0b42474bb8ff2'
'54d70005a8975812ab54fcfef53f7bde'
- 'dd3bfdd9ab2c8b1d21bb83166017c102'
- '60c4d7a0a513d18661c470924a6df2b4'
- '266d9f45c6c75a1a7d5d80da0e97857e'
+ '3325fba5405408c3bbf650ecfd679692'
+ '726dc9328e42e4db934ea24aba511ec7'
'336a0bc0e44eede4ddf613a0eebf3bb9')
options=(!strip)
-build() {
- cd $srcdir/
- cd cemu_$pkgver
- bsdtar -x -f $srcdir/cemuhook_${_cemuhookver}.zip
-}
package() {
cd $srcdir
install -d -m755 $pkgdir/usr/share/
@@ -53,7 +44,6 @@ package() {
cp -R sharedFonts $pkgdir/usr/share/$pkgname
cd cemu_$pkgver
install -m644 Cemu.exe $pkgdir/usr/share/$pkgname
- install -m644 cemuhook.dll $pkgdir/usr/share/$pkgname
install -m644 keystone.dll $pkgdir/usr/share/$pkgname
cp -R gameProfiles $pkgdir/usr/share/$pkgname
mkdir $pkgdir/usr/share/$pkgname/mlc01
diff --git a/cemu.desktop b/cemu.desktop
index d1f2720c6408..3989c7ab1a0b 100644
--- a/cemu.desktop
+++ b/cemu.desktop
@@ -1,5 +1,5 @@
[Desktop Entry]
-Version=1.26.1
+Version=1.26.2
Type=Application
Name=Cemu
Comment=Wii U emulator
diff --git a/cemu.sh b/cemu.sh
index 49a4553bbeb4..da0c779fa172 100644
--- a/cemu.sh
+++ b/cemu.sh
@@ -1,6 +1,6 @@
#!/bin/bash
export WINEPREFIX="$HOME/.cemu/wine"
-export WINEDLLOVERRIDES="mscoree=;mshtml=;cemuhook.dll=n,b"
+export WINEDLLOVERRIDES="mscoree=;mshtml="
# Allows to play BotW with Polaris video cards
export R600_DEBUG="nohyperz"
@@ -8,7 +8,6 @@ export R600_DEBUG="nohyperz"
if [ ! -d "$HOME"/.cemu ] ; then
mkdir -p "$HOME"/.cemu/wine || exit 1
ln -s /usr/share/cemu/Cemu.exe "$HOME"/.cemu/Cemu.exe || exit 1
- ln -s /usr/share/cemu/cemuhook.dll "$HOME"/.cemu/cemuhook.dll || exit 1
ln -s /usr/share/cemu/keystone.dll "$HOME"/.cemu/keystone.dll || exit 1
ln -s /usr/share/cemu/sharedFonts "$HOME"/.cemu/sharedFonts || exit 1
cp -r /usr/share/cemu/gameProfiles "$HOME"/.cemu/ || exit 1
@@ -18,7 +17,10 @@ fi
if [ -d "$HOME"/.cemu ] && [ -L "$HOME"/.cemu/dbghelp.dll ] ; then
rm "$HOME"/.cemu/dbghelp.dll
- ln -s /usr/share/cemu/cemuhook.dll "$HOME"/.cemu/cemuhook.dll || exit 1
+fi
+
+if [ -d "$HOME"/.cemu ] && [ -L "$HOME"/.cemu/cemuhook.dll ] ; then
+ rm "$HOME"/.cemu/cemuhook.dll
fi
if [ ! -L "$HOME"/.cemu/sharedFonts ] && [ ! -d "$HOME"/.cemu/sharedFonts ] ; then