summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Kescher2023-04-17 09:20:43 +0200
committerJeremy Kescher2023-04-17 09:38:52 +0200
commit9e6032ceae3e69f5a9ce98da8b4363a4a25646b7 (patch)
tree1d4e34bc341bccba8a0612a9d57158a9e65d9e1d
parente8ea97915687b5f98eb7b6c89a5b846558bf0b7d (diff)
downloadaur-9e6032ceae3e69f5a9ce98da8b4363a4a25646b7.tar.gz
v2.0-33
Also removed the pseudo-boxing around post-install/-upgrade messages and added a check for the previous version in the message that outputs the new keys location
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--cemu.install44
3 files changed, 25 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c967ff5b8408..cd7bbd9f7bb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cemu
pkgdesc = Software to emulate Wii U games and applications on PC
- pkgver = 2.0.328
+ pkgver = 2.0.339
pkgrel = 1
url = https://cemu.info
install = cemu.install
@@ -31,7 +31,7 @@ pkgbase = cemu
optdepends = alsa-lib: Audio output
optdepends = vulkan-driver: Vulkan graphics
options = !strip
- source = git+https://github.com/cemu-project/Cemu#tag=v2.0-32
+ source = git+https://github.com/cemu-project/Cemu#tag=v2.0-33
source = git+https://github.com/mozilla/cubeb#commit=dc511c6b3597b6384d28949285b9289e009830ea
source = git+https://github.com/ocornut/imgui#commit=8a44c31c95c8e0217f6e1fc814cbbbcca4981f14
source = git+https://github.com/Exzap/ZArchive#commit=d2c717730092c7bf8cbb033b12fd4001b7c4d932
diff --git a/PKGBUILD b/PKGBUILD
index 11ed71e24f28..bddf5062339b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jeremy Kescher <jeremy@kescher.at>
pkgname=cemu
-pkgver=2.0.328
+pkgver=2.0.339
pkgrel=1
pkgdesc='Software to emulate Wii U games and applications on PC'
arch=(x86_64)
@@ -31,7 +31,7 @@ optdepends=(
)
install=cemu.install
source=(
- git+https://github.com/cemu-project/Cemu#tag=v2.0-32
+ git+https://github.com/cemu-project/Cemu#tag=v2.0-33
# submodules
git+https://github.com/mozilla/cubeb#commit=dc511c6b3597b6384d28949285b9289e009830ea
git+https://github.com/ocornut/imgui#commit=8a44c31c95c8e0217f6e1fc814cbbbcca4981f14
diff --git a/cemu.install b/cemu.install
index b7bd9ffb98cb..a91501c21c21 100644
--- a/cemu.install
+++ b/cemu.install
@@ -1,30 +1,28 @@
post_install() {
- cat << 'EOF'
-+-Cemu-------------------------------------------------------------------------+
-| This software is still experimental! Some features are missing (e.g. Online) |
-| but performance is already great. If you rely on a specific feature you can |
-| still run the Windows version through Wine (AUR: cemu-wine) although doing |
-| that is no longer recommended. |
-| |
-| This package follows the XDG Base Directory Specification: |
-| - Config files (e.g. settings.txt) are found in $XDG_CONFIG_HOME. |
-| Default: ~/.config/cemu |
-| - Data files (e.g. mlc01, keys.txt, log.txt) are found in $XDG_DATA_HOME. |
-| Default: ~/.local/share/cemu |
-| - Cache files (e.g. shaderCache) are found in $XDG_CACHE_HOME. |
-| Default: ~/.cache/cemu |
-| |
-| Report Linux issues here: https://github.com/cemu-project/Cemu/issues |
-| Report Arch issues here: https://aur.archlinux.org/packages/cemu |
-+------------------------------------------------------------------------------+
+ cat << EOF
+This software is still experimental! Some features are missing (e.g. Online)
+but performance is already great. If you rely on a specific feature you can
+still run the Windows version through Wine (AUR: cemu-wine) although doing
+that is no longer recommended.
+
+This package follows the XDG Base Directory Specification:
+- Config files (e.g. settings.txt) are found in "$XDG_CONFIG_HOME/cemu".
+ Default: ~/.config/cemu
+- Data files (e.g. mlc01, keys.txt, log.txt) are found in "$XDG_DATA_HOME/cemu".
+ Default: ~/.local/share/cemu
+- Cache files (e.g. shaderCache) are found in "$XDG_CACHE_HOME/cemu".
+ Default: ~/.cache/cemu
+
+Report Linux issues here: https://github.com/cemu-project/Cemu/issues
+Report Arch issues here: https://aur.archlinux.org/packages/cemu
EOF
}
post_upgrade() {
- cat << 'EOF'
-+-Cemu-------------------------------------------------------------------------+
-| The location of the keys file recently changed from $XDG_CONFIG_HOME to |
-| $XDG_DATA_HOME (defaults to ~/.local/share/cemu/keys.txt). |
-+------------------------------------------------------------------------------+
+ if [ $(vercmp $2 2.0.182-1) -lt 0 ]; then cat << EOF
+The location of the keys file recently changed from
+$XDG_CONFIG_HOME (defaults to ~/.config/cemu/keys.txt) to
+$XDG_DATA_HOME (defaults to ~/.local/share/cemu/keys.txt).
EOF
+fi
}