summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Kescher2024-05-09 11:43:39 +0200
committerJeremy Kescher2024-05-09 11:43:39 +0200
commite13613b9ae0d98e089b87aff73b9ebdb15f2ad88 (patch)
tree0fde6d75cb79cd42f358f72c9d59cb6bb3259d19
parent42dd27014db1b89c0c9c4509cf15d1c91fa92c50 (diff)
downloadaur-e13613b9ae0d98e089b87aff73b9ebdb15f2ad88.tar.gz
Fix submodule handling
As was pointed out by HurricanePootis and FabioLolix, submodules were not handled correctly, being cloned twice. This is now handled properly. Co-authored-by: HurricanePootis <hurricanepootis@protonmail.com>
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
2 files changed, 36 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cae63127d25..2e8838be8aa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -33,16 +33,16 @@ pkgbase = cemu
optdepends = vulkan-driver: Vulkan graphics
options = !strip
source = git+https://github.com/cemu-project/Cemu#tag=v2.0-82
- source = git+https://github.com/mozilla/cubeb#commit=dc511c6b3597b6384d28949285b9289e009830ea
- source = git+https://github.com/ocornut/imgui#commit=8a44c31c95c8e0217f6e1fc814cbbbcca4981f14
- source = git+https://github.com/Exzap/ZArchive#commit=d2c717730092c7bf8cbb033b12fd4001b7c4d932
- source = git+https://github.com/arsenm/sanitizers-cmake#commit=aab6948fa863bc1cbe5d0850bc46b9ef02ed4c1a
- source = git+https://github.com/google/googletest#commit=800f5422ac9d9e0ad59cd860a2ef3a679588acb4
- sha256sums = 8302fb4de0bbba1e9f79da2c8badeb6e1f3b146fca35d40f7bbe306d910c3f22
- sha256sums = ad74dba4d6bd055e7862ef6916654e7572cb3601a7882715b0617207b159fc94
- sha256sums = b2f59d28eca6c4d702c845ad82818b5378e9edafff12394f9321bb69e9f80642
- sha256sums = 778720b0b08b122af1a958faf5bb1340d44fa33057124373c81822f1e1918e19
- sha256sums = a24b426203153fe25c9678a0ed2335293eec40e4a922a81d61fe0b60987573bc
- sha256sums = 2353b7e1877666d242fd45083ae730667fbcdbb418dfaa43b39d33a828ce6e08
+ source = git+https://github.com/mozilla/cubeb.git#commit=dc511c6b3597b6384d28949285b9289e009830ea
+ source = git+https://github.com/ocornut/imgui.git#commit=8a44c31c95c8e0217f6e1fc814cbbbcca4981f14
+ source = git+https://github.com/Exzap/ZArchive.git#commit=d2c717730092c7bf8cbb033b12fd4001b7c4d932
+ source = git+https://github.com/arsenm/sanitizers-cmake.git#commit=aab6948fa863bc1cbe5d0850bc46b9ef02ed4c1a
+ source = git+https://github.com/google/googletest.git#commit=800f5422ac9d9e0ad59cd860a2ef3a679588acb4
+ sha512sums = 103532d1841a3beebf9bf0006bac85ee903b101989e5bd243657a24d7acd9d72bd61b1bdb4215037654f647488ac2281f5c9e023de8233d6ec1db989da0fdf87
+ sha512sums = 770a67624181e4c7f05c88c3f1a10dc14012d4967d5bf95f48af1a5bd7a90dd5d8242a868dbe74d8beb043365eababd0d62768b74ccc9867c0c4fd1883849828
+ sha512sums = 0c3d10999772aa92e97aa3082f10e6ebba93f2a738e402f9833f350eb525b71afca178bf834db3bbe965eb0073f249f68b5c8124176add0af997f1c897282803
+ sha512sums = 6ac14841ef983fe5202b23ea5c647959a04b9815bb187c0a0141fb14fb3e2edf8ce14b0c43474774d5ff779284f365981e6d45cc011612e5cd8fb429b3accf5e
+ sha512sums = 587d4d3dea948ce2aac33d3250cab0fe322ae892dc4f7261a56ad467c42a3d782d67113dc09ca7e5aff6d92dc9f0879c16dacb6531a4f3c5e5c62a3d6bfe6ab6
+ sha512sums = 8b65394aaf76a693a95cc493c57df3db61a7ac3474ec36596de5c36dd15b11a051ea46e74058bad184e521712dac570aa3b623c1028305f89ebbdde45457ded8
pkgname = cemu
diff --git a/PKGBUILD b/PKGBUILD
index 0cce902f2104..510c86d5d39c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,8 @@
pkgname=cemu
pkgver=2.0.572
+cemu_experimental_version=82
+cemu_tag=v2.0-$cemu_experimental_version
pkgrel=1
pkgdesc='Software to emulate Wii U games and applications on PC'
arch=(x86_64)
@@ -31,27 +33,31 @@ optdepends=(
)
install=cemu.install
source=(
- git+https://github.com/cemu-project/Cemu#tag=v2.0-82
+ "git+https://github.com/cemu-project/Cemu#tag=${cemu_tag}"
# submodules
- git+https://github.com/mozilla/cubeb#commit=dc511c6b3597b6384d28949285b9289e009830ea
- git+https://github.com/ocornut/imgui#commit=8a44c31c95c8e0217f6e1fc814cbbbcca4981f14
- git+https://github.com/Exzap/ZArchive#commit=d2c717730092c7bf8cbb033b12fd4001b7c4d932
+ git+https://github.com/mozilla/cubeb.git#commit=dc511c6b3597b6384d28949285b9289e009830ea
+ git+https://github.com/ocornut/imgui.git#commit=8a44c31c95c8e0217f6e1fc814cbbbcca4981f14
+ git+https://github.com/Exzap/ZArchive.git#commit=d2c717730092c7bf8cbb033b12fd4001b7c4d932
# cubeb submodules
- git+https://github.com/arsenm/sanitizers-cmake#commit=aab6948fa863bc1cbe5d0850bc46b9ef02ed4c1a
- git+https://github.com/google/googletest#commit=800f5422ac9d9e0ad59cd860a2ef3a679588acb4
+ git+https://github.com/arsenm/sanitizers-cmake.git#commit=aab6948fa863bc1cbe5d0850bc46b9ef02ed4c1a
+ git+https://github.com/google/googletest.git#commit=800f5422ac9d9e0ad59cd860a2ef3a679588acb4
)
-sha256sums=('8302fb4de0bbba1e9f79da2c8badeb6e1f3b146fca35d40f7bbe306d910c3f22'
- 'ad74dba4d6bd055e7862ef6916654e7572cb3601a7882715b0617207b159fc94'
- 'b2f59d28eca6c4d702c845ad82818b5378e9edafff12394f9321bb69e9f80642'
- '778720b0b08b122af1a958faf5bb1340d44fa33057124373c81822f1e1918e19'
- 'a24b426203153fe25c9678a0ed2335293eec40e4a922a81d61fe0b60987573bc'
- '2353b7e1877666d242fd45083ae730667fbcdbb418dfaa43b39d33a828ce6e08')
+sha512sums=('103532d1841a3beebf9bf0006bac85ee903b101989e5bd243657a24d7acd9d72bd61b1bdb4215037654f647488ac2281f5c9e023de8233d6ec1db989da0fdf87'
+ '770a67624181e4c7f05c88c3f1a10dc14012d4967d5bf95f48af1a5bd7a90dd5d8242a868dbe74d8beb043365eababd0d62768b74ccc9867c0c4fd1883849828'
+ '0c3d10999772aa92e97aa3082f10e6ebba93f2a738e402f9833f350eb525b71afca178bf834db3bbe965eb0073f249f68b5c8124176add0af997f1c897282803'
+ '6ac14841ef983fe5202b23ea5c647959a04b9815bb187c0a0141fb14fb3e2edf8ce14b0c43474774d5ff779284f365981e6d45cc011612e5cd8fb429b3accf5e'
+ '587d4d3dea948ce2aac33d3250cab0fe322ae892dc4f7261a56ad467c42a3d782d67113dc09ca7e5aff6d92dc9f0879c16dacb6531a4f3c5e5c62a3d6bfe6ab6'
+ '8b65394aaf76a693a95cc493c57df3db61a7ac3474ec36596de5c36dd15b11a051ea46e74058bad184e521712dac570aa3b623c1028305f89ebbdde45457ded8')
pkgver() {
cd Cemu
MAJ=$(awk -F'\t' '/LEAD/ {print $NF; exit}' src/Common/version.h)
MIN=$(awk -F'\t' '/MAJOR/ {print $NF; exit}' src/Common/version.h)
+ # TODO: Apply this with the next Cemu release
+ # PAT=$cemu_experimental_version
PAT=$(git rev-list --count HEAD)
+ # TODO: Apply this with the next Cemu release
+ # sed -i "/#define EMULATOR_VERSION_MINOR/s/[0-9]\+/$PAT/" src/Common/version.h
sed -i "/#define EMULATOR_VERSION_MINOR/s/[0-9]\+/$PAT/;s/-/./" src/Common/version.h
echo "$MAJ.$MIN.$PAT"
}
@@ -60,15 +66,15 @@ prepare() {
cd Cemu
# cemu submodules
- for submodule in dependencies/{cubeb,imgui,ZArchive}; do
- git config submodule.$submodule.url "file://$srcdir/${submodule##*/}"
- git submodule--helper update --init $submodule
+ git rm --ignore-unmatch dependencies/{Vulkan-Headers,vcpkg}
+ for submodule in {cubeb,imgui,ZArchive}; do
+ git config --file=.gitmodules submodule.dependencies/"${submodule}".url "$srcdir/$submodule"
done
+ git -c protocol.file.allow=always submodule update --init
pushd dependencies/cubeb > /dev/null
- for submodule in {cmake/sanitizers-cmake,googletest}; do
- git config submodule.$submodule.url "file://$srcdir/${submodule##*/}"
- git submodule--helper update --init $submodule
- done
+ git config --file=.gitmodules submodule.googletest.url "$srcdir/googletest"
+ git config --file=.gitmodules submodule.cmake/sanitizers-cmake.url "$srcdir/sanitizers-cmake"
+ git -c protocol.file.allow=always submodule update --init
popd > /dev/null
# unbundled fmt