summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonn2022-11-11 06:14:38 +0200
committerDonn2022-11-11 06:23:47 +0200
commite2f1f9c855b4e3c2fdfe4e31f71c2bc884dea812 (patch)
tree8db9e4c1969eecf22cef122c0fb4c8103563c1c8
downloadaur-e2f1f9c855b4e3c2fdfe4e31f71c2bc884dea812.tar.gz
Initial
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD66
-rw-r--r--info.cemu.Cemu.desktop26
-rw-r--r--info.cemu.Cemu.metainfo.xml84
-rw-r--r--info.cemu.Cemu.pngbin0 -> 11984 bytes
6 files changed, 211 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e53c54c3695d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = cemu-bin
+ pkgdesc = Nintendo Wii U Emulator
+ pkgver = 2.0r14
+ pkgrel = 1
+ url = https://cemu.info
+ arch = x86_64
+ license = MPL-2.0
+ depends = pugixml
+ depends = pulseaudio
+ depends = opengl-driver
+ depends = vulkan-driver
+ depends = cairo
+ depends = icu
+ depends = graphite
+ provides = cemu
+ conflicts = cemu
+ conflicts = cemu-git
+ options = !strip
+ options = !docs
+ options = libtool
+ options = emptydirs
+ source = https://github.com/cemu-project/Cemu/releases/download/v2.0-14/cemu-2.0-14-ubuntu-20.04-x64.zip
+ source = info.cemu.Cemu.desktop
+ source = info.cemu.Cemu.metainfo.xml
+ source = info.cemu.Cemu.png
+ sha256sums = 92760341c85e7566464bc7847d76ac1b2bf8afb3bf9895514a717cc564a96470
+ sha256sums = c9f711d46917ac112c497e8600c6e99d68bb3d16b862e9232dc7578314b95978
+ sha256sums = 054fc7d9050a545bb9d4a0320720f4cee8b994a47c3daf029edbda1e996d3447
+ sha256sums = 6458a99b8bd54e44857efa0f82bfd6035e7e072e7e080e3330e4e2cfe89cbd33
+
+pkgname = cemu-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..74a473da0dad
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.zst
+*.zip \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2156eecf7445
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Donn <me@donn.website>
+pkgname=cemu-bin
+_pkgver_raw=2.0
+_buildno=14
+pkgver=${_pkgver_raw}r${_buildno}
+pkgrel=1
+pkgdesc="Nintendo Wii U Emulator"
+arch=('x86_64')
+url="https://cemu.info"
+license=('MPL-2.0')
+groups=()
+depends=(
+ 'pugixml'
+ 'pulseaudio'
+ 'opengl-driver'
+ 'vulkan-driver'
+ 'icu'
+ 'gtk3'
+ 'graphite'
+ 'pcre'
+ 'systemd'
+ 'libffi'
+)
+provides=('cemu')
+conflicts=('cemu' 'cemu-git')
+options=(!strip !docs libtool emptydirs)
+install=
+changelog=
+source=(
+ "https://github.com/cemu-project/Cemu/releases/download/v${_pkgver_raw}-${_buildno}/cemu-${_pkgver_raw}-${_buildno}-ubuntu-20.04-x64.zip"
+ "info.cemu.Cemu.desktop"
+ "info.cemu.Cemu.metainfo.xml"
+ "info.cemu.Cemu.png"
+)
+noextract=()
+sha256sums=(
+ '92760341c85e7566464bc7847d76ac1b2bf8afb3bf9895514a717cc564a96470'
+ 'c9f711d46917ac112c497e8600c6e99d68bb3d16b862e9232dc7578314b95978'
+ '054fc7d9050a545bb9d4a0320720f4cee8b994a47c3daf029edbda1e996d3447'
+ '6458a99b8bd54e44857efa0f82bfd6035e7e072e7e080e3330e4e2cfe89cbd33'
+)
+
+package() {
+ CEMU_BIN_PATH="$srcdir/Cemu_${_pkgver_raw}-${_buildno}/Cemu"
+
+ # Patch
+ patchelf --replace-needed libpcre.so.3 libpcre.so $CEMU_BIN_PATH
+ patchelf --replace-needed libffi.so.7 libffi.so $CEMU_BIN_PATH
+
+ patchelf --replace-needed libicuuc.so.71 libicuuc.so $CEMU_BIN_PATH
+ patchelf --replace-needed libicui18n.so.71 libicui18n.so $CEMU_BIN_PATH
+ patchelf --replace-needed libicudata.so.71 libicudata.so $CEMU_BIN_PATH
+
+ patchelf --remove-needed libsepol.so.1 $CEMU_BIN_PATH
+ patchelf --remove-needed libselinux.so.1 $CEMU_BIN_PATH
+
+ # Chmod
+ chmod +x $CEMU_BIN_PATH
+
+ mkdir -p "$pkgdir/usr/share/cemu"
+ cp -r "$srcdir/Cemu_${_pkgver_raw}-${_buildno}"/* "$pkgdir/usr/share/cemu"
+
+ install -Dm644 -t "$pkgdir"/usr/share/applications info.cemu.Cemu.desktop
+ install -Dm644 -t "$pkgdir"/usr/share/metainfo info.cemu.Cemu.metainfo.xml
+ install -Dm644 -t "$pkgdir"/usr/share/icons/hicolor/128x128/apps info.cemu.Cemu.png
+} \ No newline at end of file
diff --git a/info.cemu.Cemu.desktop b/info.cemu.Cemu.desktop
new file mode 100644
index 000000000000..8d022e4f5eb7
--- /dev/null
+++ b/info.cemu.Cemu.desktop
@@ -0,0 +1,26 @@
+[Desktop Entry]
+Name=Cemu
+Type=Application
+Terminal=false
+Icon=info.cemu.Cemu
+Exec=/usr/share/cemu/Cemu
+GenericName=Wii U Emulator
+GenericName[fi]=Wii U -emulaattori
+GenericName[el]=Πρόγραμμα προσομοίωσης Wii U
+GenericName[es]=Emulador de Wii U
+GenericName[pt_BR]=Emulador de Wii U
+GenericName[fr]=Émulateur de Wii U
+GenericName[it]=Emulatore Wii U
+Comment=Software to emulate Wii U games and applications on PC
+Comment[fi]=Ohjelmisto Wii U -pelien ja sovellusten emulointiin PC:lla
+Comment[de]=Software zum emulieren von Wii U Spielen und Anwendungen auf dem PC
+Comment[ru]=Программа для эмуляции игр и приложений Wii U на PC
+Comment[fr]=Application pour émuler des jeux et des applications Wii U sur PC
+Comment[nl]=Applicatie om Wii U spellen en applicaties te emuleren op PC
+Comment[el]=Πρόγραμμα προσομοίωσης παιχνιδιών και εφαρμογών Wii U στον υπολογιστή
+Comment[es]=Software para emular juegos y aplicaciones de Wii U en PC
+Comment[pt_BR]=Software para emular jogos e aplicativos de Wii U no PC
+Comment[it]=Software per emulare giochi e applicazioni per Wii U su PC
+Categories=Game;Emulator;
+Keywords=Nintendo;
+MimeType=application/x-wii-u-rom; \ No newline at end of file
diff --git a/info.cemu.Cemu.metainfo.xml b/info.cemu.Cemu.metainfo.xml
new file mode 100644
index 000000000000..c2cdef7e0f29
--- /dev/null
+++ b/info.cemu.Cemu.metainfo.xml
@@ -0,0 +1,84 @@
+<?xml version='1.0' encoding='utf-8'?>
+<component type="desktop">
+ <!--Created with jdAppdataEdit 4.2-->
+ <id>info.cemu.Cemu</id>
+ <name>Cemu</name>
+ <summary>Software to emulate Wii U games and applications on PC</summary>
+ <summary xml:lang="de">Software zum emulieren von Wii U Spielen und Anwendungen auf dem PC</summary>
+ <summary xml:lang="fr">Application pour émuler des jeux et applications Wii U sur PC</summary>
+ <summary xml:lang="nl">Applicatie om Wii U spellen en applicaties te emuleren op PC</summary>
+ <summary xml:lang="el">Πρόγραμμα προσομοίωσης παιχνιδιών και εφαρμογών Wii U στον υπολογιστή</summary>
+ <summary xml:lang="es">Software para emular juegos y aplicaciones de Wii U en PC</summary>
+ <summary xml:lang="pt_BR">Software para emular jogos e aplicativos de Wii U no PC</summary>
+ <summary xml:lang="it">Software per emulare giochi e applicazioni per Wii U su PC</summary>
+ <summary xml:lang="fi">Ojelmisto Wii U -pelien ja -sovellusten emulointiin PC:llä</summary>
+ <developer_name>Cemu Project</developer_name>
+ <launchable type="desktop-id">info.cemu.Cemu.desktop</launchable>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>MPL-2.0</project_license>
+ <description>
+ <p>Cemu is a Nintendo Wii U emulator that is able to run most Wii U games and homebrew in a playable state. Created by Exzap, and written in C/C++.</p>
+ <p xml:lang="de">Cemu ist ein Nintendo Wii U-Emulator, der die meisten Wii U Spiele und Homebrew in einem spielbaren Zustand ausführen kann. Erstellt von Exzap, und geschrieben in C/C++.</p>
+ <p xml:lang="fr">Cemu est un émulateur de Wii U capable de lancer la plupart des jeux Wii U et des homebrews en interface de jeu. Crée par Exzap, et développé en C/C++.</p>
+ <p xml:lang="nl">Cemu is een Nintendo Wii U emulator die de meeste Wii U en Homebrew games speelbaar kan runnen. Het project is begonnen door Exzap, en het is geschreven in C/C++.</p>
+ <p xml:lang="el">Το Cemu είναι ένας προσομοιωτής της κονσόλας Nintendo Wii U που προσομοιώνει επίσημα παιχνίδια, καθώς και μη επίσημα προγράμματα ("homebrew") του Wii U. Δημιουργήθηκε από τον Exzap σε C/C++.</p>
+ <p xml:lang="es">Cemu es un emulador de Nintendo Wii U que es capaz de ejecutar la mayoría de los juegos de Wii U y homebrew en un estado jugable. Creado por Exzap, y escrito en C y C++.</p>
+ <p xml:lang="pt_BR">Cemu é um emulador de Nintendo Wii U que é capaz de executar a maioría dos jogos de Wii U e homebrew em um estado jogavel. Criado por Exzap, e escrito em C e C++.</p>
+ <p xml:lang="it">Cemu è un emulatore del Nintendo Wii U in grado di eseguire in stato giocabile la maggior parte dei giochi e homebrew per Wii U. Creato da Exzap, e scritto in C/C++.</p>
+ <p xml:lang="fi">Cemu on Wii U -emulaattori, joka pystyy toistamaan useimpia Wii U -pelejä ja homebrew'ta pelikelvollisesti. Luonut Exzap, kirjoitettu C:llä/C++:lla.</p>
+ <p>This emulator aims at providing both high-accuracy and performance, and is actively being developed with new features and fixes to increase compatibility, convenience and usability.</p>
+ <p xml:lang="de">Dieser Emulator zielt darauf ab, sowohl hohe Genauigkeit als auch Leistung zu bieten, und wird aktiv mit neuen Funktionen und Korrekturen weiterentwickelt, um Kompatibilität, Komfort und Benutzerfreundlichkeit zu verbessern.</p>
+ <p xml:lang="fr">Cet émulateur vise à la fois à offrir fidélité et performance, il est activement développé avec des nouvelles fonctionnalités et des correctifs pour augmenter la compatibilité, la commodité et la facilité d'utilisation.</p>
+ <p xml:lang="nl">De emulator richt zich op integriteit en snelheid, en wordt continu verder ontwikkeld met nieuwe toevoegingen en fixes om de compatibiliteit, het gemak en de gebruiksvriendelijkheid te verbeteren.</p>
+ <p xml:lang="el">Ο προσομοιωτής αυτός στοχεύει τόσο στην ακρίβεια, όσο και στην ταχύτητα, και βελτιώνεται συνεχώς με νέες δυνατότητες και διορθώσεις που τον καθιστούν πιο βολικό, εύκολο στην χρήση και συμβατό με περισσότερα παιχνίδια.</p>
+ <p xml:lang="es">Este emulador tiene como objetivo proporcionar tanto alta precisión como rendimiento y se desarrolla activamente con nuevas características y correcciones para mejorar la compatibilidad, la comodidad y la usabilidad.</p>
+ <p xml:lang="pt_BR">Esse emulador visa proporcionar tanto alta precisão como rendimento e está sendo ativamente desenvolvido com novas características e correções para melhorar a compatibilidade, a comodidade e a usabilidade.</p>
+ <p xml:lang="it">Questo emulatore ha l'obiettivo di fornire sia alta precisione che alte prestazioni, ed è in continuo sviluppo con nuove funzionalità e correzioni per aumentare la compatibilità, la comodità e l'usabilità.</p>
+ <p xml:lang="fi">Tämä emulaattori pyrkii tarjoamaan korkeaa tarkkuutta sekä suorituskykyä, ja sitä kehitetään aktiivisesti uusilla ominaisuuksilla ja korjauksilla, jotka parantavat yhteensopivuutta, mukavuutta ja käytettävyyttä..</p>
+ <p>It was written from scratch and development on the project began roughly early 2015.</p>
+ <p xml:lang="de">Er wird seit Anfang 2015 entwickelt.</p>
+ <p xml:lang="fr">Il a été écrit à partir de zéro et son développement a débuté vers le début de l'année 2015.</p>
+ <p xml:lang="nl">Ontwikkeling van Cemu begon ongeveer in het voorjaar van 2015.</p>
+ <p xml:lang="el">Αρχισε απο το τίποτα και βρίσκεται υπό ανάπτυξη από το 2015.</p>
+ <p xml:lang="es">Fue escrito desde cero y el desarrollo del proyecto comenzó aproximadamente a principios de 2015.</p>
+ <p xml:lang="pt_BR">Foi escrito do zero e o desenvolvimento do projeto começou aproximadamente a princípio de 2015.</p>
+ <p xml:lang="it">È stato scritto da zero e lo sviluppo del progetto è cominciato intorno all'inizio del 2015.</p>
+ <p xml:lang="fi">Se kirjoitettiin tyhjästä ja sen kehitys alkoi suunnilleen vuoden 2015 alussa.</p>
+
+ </description>
+ <screenshots>
+ <screenshot type="default">
+ <image type="source">https://upload.wikimedia.org/wikipedia/commons/5/58/Cemu_Screenshot.png</image>
+ </screenshot>
+ </screenshots>
+ <releases>
+ <release version="v2.0" date="2022-08-22" type="stable">
+ <url>https://github.com/cemu-project/Cemu/releases/tag/v2.0</url>
+ </release>
+ </releases>
+ <url type="homepage">https://cemu.info</url>
+ <url type="bugtracker">https://github.com/cemu-project/Cemu/issues</url>
+ <url type="faq">https://cemu.info/faq.html</url>
+ <url type="help">https://wiki.cemu.info</url>
+ <!-- <url type="vcs-browser">https://github.com/cemu-project/Cemu</url> -->
+ <categories>
+ <category>Game</category>
+ <category>Emulator</category>
+ </categories>
+ <recommends>
+ <memory>8192</memory>
+ </recommends>
+ <supports>
+ <control>pointing</control>
+ <control>keyboard</control>
+ <control>gamepad</control>
+ </supports>
+ <content_rating type="oars-1.1" />
+ <provides>
+ <binary>cemu</binary>
+ <mediatype>application/x-wii-u-rom</mediatype>
+ </provides>
+ <keywords>
+ <keyword>nintendo</keyword>
+ </keywords>
+</component> \ No newline at end of file
diff --git a/info.cemu.Cemu.png b/info.cemu.Cemu.png
new file mode 100644
index 000000000000..6f6550724816
--- /dev/null
+++ b/info.cemu.Cemu.png
Binary files differ