summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2022-10-11 09:56:10 +0200
committerAlexandre Bouvier2022-10-11 09:56:10 +0200
commitaeeb5794e2ad23d69b0fdedc292e328043415e41 (patch)
treed9de7b09b20c39df1555ae06e2f822154665ba6c
parent938832343e53111a229abee38e18f3549608b113 (diff)
downloadaur-aeeb5794e2ad23d69b0fdedc292e328043415e41.tar.gz
update to 2.0.4.r23.g2b9edce
* use imgui submodule
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2110d0e72c41..5a61010885aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cemu-git
pkgdesc = Nintendo Wii U emulator
- pkgver = 2.0.4.r0.g101ff77
+ pkgver = 2.0.4.r23.g2b9edce
pkgrel = 1
url = https://cemu.info/
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = cemu-git
makedepends = glm
makedepends = glslang
makedepends = glu
- makedepends = libglvnd
+ makedepends = libgl
makedepends = libpng
makedepends = libzip
makedepends = nasm
@@ -26,19 +26,19 @@ pkgbase = cemu-git
makedepends = zlib
makedepends = zstd
depends = discord-rpc
- depends = imgui
depends = pugixml
depends = wxwidgets-gtk3>=3.2
provides = cemu
conflicts = cemu
source = cemu::git+https://github.com/cemu-project/Cemu.git
+ source = imgui::git+https://github.com/ocornut/imgui.git
source = cemu.bash
b2sums = SKIP
+ b2sums = SKIP
b2sums = 431a90ba59c911b5e822bf826a79228512ae1bc4221350cb0cf262f8f01c05d7c75effff59c0fc52a0f27b94ebd70d2d72c94432fcfef3920a3ae5ab179fdcd5
pkgname = cemu-git
depends = discord-rpc
- depends = imgui
depends = pugixml
depends = wxwidgets-gtk3>=3.2
depends = libboost_filesystem.so
diff --git a/PKGBUILD b/PKGBUILD
index 8137d2478c9c..009ca01319df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
_pkgname=cemu
pkgname=$_pkgname-git
-pkgver=2.0.4.r0.g101ff77
+pkgver=2.0.4.r23.g2b9edce
pkgrel=1
pkgdesc="Nintendo Wii U emulator"
arch=('x86_64')
@@ -9,7 +9,6 @@ url="https://cemu.info/"
license=('MPL2')
depends=(
'discord-rpc'
- 'imgui'
'pugixml'
'wxwidgets-gtk3>=3.2'
)
@@ -23,7 +22,7 @@ makedepends=(
'glm'
'glslang'
'glu'
- 'libglvnd'
+ 'libgl'
'libpng'
'libzip'
'nasm'
@@ -39,10 +38,12 @@ provides=("$_pkgname")
conflicts=("$_pkgname")
source=(
"$_pkgname::git+https://github.com/cemu-project/Cemu.git"
+ 'imgui::git+https://github.com/ocornut/imgui.git'
"$_pkgname.bash"
)
b2sums=(
'SKIP'
+ 'SKIP'
'431a90ba59c911b5e822bf826a79228512ae1bc4221350cb0cf262f8f01c05d7c75effff59c0fc52a0f27b94ebd70d2d72c94432fcfef3920a3ae5ab179fdcd5'
)
@@ -53,11 +54,12 @@ pkgver() {
prepare() {
cd $_pkgname
+ git config submodule.dependencies/imgui.url ../imgui
+ git submodule update
sed -i '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt
sed -i '/discord-rpc/d' CMakeLists.txt
sed -i '/FMT_HEADER_ONLY/d' src/Common/precompiled.h
sed -i 's/glm::glm/glm/' src/{Common,input}/CMakeLists.txt
- sed -i 's/GLSLANG_VERSION_LESS_OR_EQUAL_TO/GLSLANG_VERSION_GREATER_OR_EQUAL_TO/' src/Cafe/HW/Latte/Renderer/Vulkan/RendererShaderVk.cpp
sed -i '/target_precompile_headers/c target_compile_options(CemuCommon PUBLIC -include Common/precompiled.h)' src/Common/CMakeLists.txt
}