summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:24:30 -0400
committerKyle Keen2015-06-13 00:24:30 -0400
commitb64ada8409ae4eaecb0bbe8ebaffa2a90c87c790 (patch)
tree127ff82ed8420445f2b885d2b6af450fb9385490
downloadaur-b64ada8409ae4eaecb0bbe8ebaffa2a90c87c790.tar.gz
Initial import
-rw-r--r--.AURINFO20
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD67
-rw-r--r--gcc47.patch7
4 files changed, 118 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..d7857eeb5e81
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,20 @@
+pkgbase = cenon
+ pkgdesc = GNUstep vector editor for EPS, DXF, Gerber, HPGL. Includes docs and examples.
+ pkgver = 4.0.2
+ pkgrel = 1
+ url = http://www.cenon.info
+ arch = i686
+ arch = x86_64
+ license = custom:vhfPL
+ makedepends = gnustep-make
+ makedepends = gcc-objc
+ depends = gnustep-base
+ depends = gnustep-gui
+ source = http://www.cenon.zone/download/source/Cenon-4.0.2.tar.bz2
+ source = http://www.cenon.zone/download/source/CenonLibrary-4.0.0-1.tar.bz2
+ source = http://www.cenon.zone/download/doc/Cenon-4.0_gb.pdf
+ source = gcc47.patch
+ options = !strip
+
+pkgname = cenon
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7981b1f17ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = cenon
+ pkgdesc = GNUstep vector editor for EPS, DXF, Gerber, HPGL. Includes docs and examples.
+ pkgver = 4.0.2
+ pkgrel = 1
+ url = http://www.cenon.info
+ arch = i686
+ arch = x86_64
+ license = custom:vhfPL
+ makedepends = gnustep-make
+ makedepends = gcc-objc
+ depends = gnustep-base
+ depends = gnustep-gui
+ options = !strip
+ source = http://www.cenon.zone/download/source/Cenon-4.0.2.tar.bz2
+ source = http://www.cenon.zone/download/source/CenonLibrary-4.0.0-1.tar.bz2
+ source = http://www.cenon.zone/download/doc/Cenon-4.0_gb.pdf
+ source = gcc47.patch
+ md5sums = ba6519d09106a250cbec72b28f970bbc
+ md5sums = 5d7542f054b4ac3eb630c360d3752aa8
+ md5sums = SKIP
+ md5sums = 015e2c1538788eb42c1320353a2da6e5
+
+pkgname = cenon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da39d8f8ae96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+pkgname=cenon
+pkgver=4.0.2
+_libver=4.0.0
+pkgrel=1
+pkgdesc="GNUstep vector editor for EPS, DXF, Gerber, HPGL. Includes docs and examples."
+arch=('i686' 'x86_64')
+url="http://www.cenon.info"
+license=('custom:vhfPL')
+depends=('gnustep-base' 'gnustep-gui')
+makedepends=('gnustep-make' 'gcc-objc')
+options=('!strip')
+#source=(http://www.vhf-group.com/vhf-interservice/download/source/Cenon-$pkgver.tar.bz2
+# http://www.vhf-group.com/vhf-interservice/download/source/CenonLibrary-$_libver-1.tar.bz2
+# http://www.vhf-group.com/vhf-interservice/download/doc/Cenon-4.0_gb.pdf
+source=("http://www.cenon.zone/download/source/Cenon-$pkgver.tar.bz2"
+ "http://www.cenon.zone/download/source/CenonLibrary-$_libver-1.tar.bz2"
+ "http://www.cenon.zone/download/doc/Cenon-4.0_gb.pdf"
+ gcc47.patch)
+md5sums=('ba6519d09106a250cbec72b28f970bbc'
+ '5d7542f054b4ac3eb630c360d3752aa8'
+ 'SKIP'
+ '015e2c1538788eb42c1320353a2da6e5')
+
+build() {
+ cd "$srcdir/Cenon"
+
+ patch -p1 VHFShared/vhfCompatibility.h "$srcdir/gcc47.patch"
+ export CFLAGS="$CFLAGS -g"
+ export CXXFLAGS="$CXXFLAGS -g"
+
+ make GNUSTEP_MAKEFILES="/usr/share/GNUstep/Makefiles/" \
+ GNUSTEP_LOCAL_LIBRARY="/usr/lib/GNUstep/Libraries/" \
+ GNUSTEP_LOCAL_APPS="/usr/share/"
+}
+
+package() {
+ cd "$srcdir/Cenon"
+ install -d "$pkgdir/usr/lib/GNUstep/Libraries/"
+ install -d "$pkgdir/usr/share/"
+ sed -i 's/chmod/#&/' GNUmakefile.postamble
+ sed -i 's/cp/#&/' GNUmakefile.postamble
+ make DESTDIR="$pkgdir" \
+ GNUSTEP_MAKEFILES="/usr/share/GNUstep/Makefiles/" \
+ GNUSTEP_LOCAL_LIBRARY="$pkgdir/usr/lib/GNUstep/Libraries/" \
+ GNUSTEP_LOCAL_APPS="/usr/share/" \
+ install
+
+ chmod -R ugo+rX "$pkgdir"/usr/share/Cenon.*
+
+ install -d "$pkgdir/usr/share/doc/cenon/"
+ # yeah, yeah. use install
+ cp -R Devices/ "$pkgdir/usr/share/doc/cenon/"
+ cp -R Documentation/ "$pkgdir/usr/share/doc/cenon/"
+ cp -R Examples/ "$pkgdir/usr/share/doc/cenon/"
+ cp -R Projects/ "$pkgdir/usr/share/doc/cenon/"
+ cp ../../Cenon-4.0_gb.pdf "$pkgdir/usr/share/doc/cenon/Documentation/"
+
+ # figure out how to fix the library path for real
+ #touch "$pkgdir/usr/bin/cenon"
+ #chmod +x "$pkgdir/usr/bin/cenon"
+ #echo "#!/bin/sh" >> "$pkgdir/usr/bin/cenon"
+ #echo "LD_LIBRARY_PATH=\"/usr/lib/GNUstep/Libraries\" Cenon" >> "$pkgdir/usr/bin/cenon"
+}
+
+
+
diff --git a/gcc47.patch b/gcc47.patch
new file mode 100644
index 000000000000..ff155480125c
--- /dev/null
+++ b/gcc47.patch
@@ -0,0 +1,7 @@
+41a42,47
+> /* GCC 4.7
+> */
+> #if __GNU_LIBOBJC__ >= 20100911
+> # define sel_eq(__A__,__B__) sel_isEqual(__A__,__B__)
+> #endif
+>