summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBazaah2023-11-06 19:39:51 +0000
committerBazaah2023-11-06 19:39:51 +0000
commit1ea1d504490db509e0134a351ef92472a64e24d6 (patch)
treeb03245001b1df8f4f692a024af859d635c9e705a
parent110161fbc44ff08a23790d92ace0898258508f81 (diff)
downloadaur-1ea1d504490db509e0134a351ef92472a64e24d6.tar.gz
pkgbuild: tidy up check()
pkill is not required by checkdepends anymore rendering this loop useless, and I haven't seen orphan processes so far. Can always add it back later if needed.
-rw-r--r--PKGBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ca2c225abd5..351223bc355d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -239,12 +239,8 @@ check() {
export CTEST_PARALLEL_LEVEL=7
export CTEST_OUTPUT_ON_FAILURE=1
- VERBOSE=1 make -C build check || true
- # sometimes processes are not properly terminated...
- for process in ceph-mon ceph-mgr ceph-osd; do
- pkill -9 "${process}" || true
- done
+ VERBOSE=1 make -C build check || true
}
_package() {