summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBazaah2024-03-18 14:30:49 +0000
committerBazaah2024-03-23 10:35:26 +0000
commit246af22b29342b3a85fe989f2904f2721e8a2b12 (patch)
tree1a966c4855d9c6b67d2e85d9bb1342c9a1a835f0
parentfcde70e9a17986f8c3619b1ca9f8df2dcedb2fd5 (diff)
downloadaur-246af22b29342b3a85fe989f2904f2721e8a2b12.tar.gz
pkgbuild: restrict prepare() patch machinery to ceph-*
So that we can introduce non ceph patches in future commits
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0289d52f6bcd..5989cbaa82ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -153,7 +153,8 @@ prepare() {
# apply patches from the source array
local filename
for filename in "${source[@]%%::*}"; do
- if [[ "${filename}" =~ \.patch$ ]]; then
+ if [[ "${filename}" =~ \.patch$ ]] \
+ && [[ "${filename}" =~ ^ceph-.* ]]; then
echo "Applying patch ${filename##*/}"
patch -p1 -N -i "${srcdir}/${filename##*/}"
fi