summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBazaah2023-08-27 14:09:34 +0000
committerBazaah2023-09-09 17:10:46 +0000
commit3ddb7038f95be4805d6e8c66c25e7b58df49c036 (patch)
tree1519eaede9c49f68c88e68db46c7d23f2fd8506c
parent9ca7efd18c4e772b6e41a759b78c6bd7c4d4e68c (diff)
downloadaur-3ddb7038f95be4805d6e8c66c25e7b58df49c036.tar.gz
justfile: remove watch, logs
These never worked correctly anyway
-rw-r--r--justfile19
1 files changed, 0 insertions, 19 deletions
diff --git a/justfile b/justfile
index 4123fe6551cb..aaa98750e22a 100644
--- a/justfile
+++ b/justfile
@@ -22,16 +22,6 @@ chroot: (_update_chroot ChrootBase)
# Initialize the base chroot for building packages
mkchroot: (_mkchroot ChrootBase)
-# Watch build log streams, optionally filtering them with the given regex and options
-watch $filter=None $opts="-iP": _mkloglist
- @$Say Watching build {{BuildTriple}} logs ${filter:+"(filter: $filter $opts)"}
- tail -F -n +1 --silent $(cat {{LogFileList}} | xargs) 2>/dev/null {{ if filter == None { None } else { '| rg ' + opts + ' "' + filter + '"' } }}
-
-# Print build logs, optionally filtering them with the given regex and options
-logs $filter=None $opts="-iP": _mkloglist
- @$Say Printing {{BuildTriple}} logs ${filter:+"(filter: $filter $opts)"}
- cat *.log 2>/dev/null {{ if filter == None { None } else { '| rg ' + opts + ' "' + filter + '"' } }}
-
# Install required dependencies
deps:
pacman -S base-devel sudo devtools ripgrep --needed --noconfirm
@@ -75,14 +65,6 @@ upload pkg="ceph,ceph-libs,ceph-mgr": (_upload pkg)
$Say Updating chroot packages @$cbase
arch-nspawn $cbase pacman -Syu
-@_mkloglist:
- mkdir -p $(dirname {{LogFileList}})
- echo \
- ceph-{{BuildTriple}}-{build,prepare,check,package_ceph{,-libs,-mgr}}.log \
- ceph-{,mgr-,libs-}{{BuildTriple}}.pkg.tar.zst-namcap.log \
- PKGBUILD-namcap.log \
- > {{LogFileList}}
-
# Script to upload a comma separated list of packages to the active Github release
_upload $pkgstring:
#!/usr/bin/env bash
@@ -137,7 +119,6 @@ GitCommitish := if `git tag --points-at HEAD` != None {
}
BuildId := "[" + C_YELLOW + PkgBase + C_RESET + "/" + C_GREEN + PkgVer + ":" + PkgRel + C_RESET + "@" + C_CYAN + GitCommitish + C_RESET + "]"
BuildTriple := PkgVer + "-" + PkgRel + "-" + "x86_64"
-LogFileList := env_var_or_default("TEMP", "/tmp") / PkgBase + ".temp" / "logfiles"
GithubRepo := "bazaah/aur-ceph"
# ~~~ Color Codes ~~~