summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBazaah2022-11-30 14:39:01 +0000
committerBazaah2023-09-09 17:10:42 +0000
commita60c26a5d6eaf10a2b44edfaf40a273e712c9be7 (patch)
tree93ad127da6e3e67623a45e19806218e1df196d22
parent1531a6ad8ada6ad1db039a60d278a4c209276a44 (diff)
downloadaur-a60c26a5d6eaf10a2b44edfaf40a273e712c9be7.tar.gz
pkgbuild: rm -DFMT_DEPRECATED_OSTREAM
There seems to just be a large amount of effort across the entire project for this one. Not surprising, given my investigations but it does make it difficult to provide a singular upstream reference for this change. Instead I'll just link directly to all the commits involved since v17.2.0... - ceph/ceph@d8d93b0fe3b crimson/osd: correct the fmt::formatter<WatchTimeoutRequest> - ceph/ceph@71b9344f299 crimson/os: specialize fmt::formatter<> for StagedIterator - ceph/ceph@32e207da3f3 crimson/os: include fmt/os.h for printing std::error_code - ceph/ceph@85830863fa4 crimson: specialize fmt::formatter<> for formatting using {fmt} - ceph/ceph@76e4c5d83c2 test/librados/aio_cxx: use fmt formatting - ceph/ceph@2e7aea7b0fd crimson/os: print pointer using fmt::ptr() - ceph/ceph@c9569f8eb02 crimson: specialize fmt::formatter<> - ceph/ceph@01f6bef6e52 *: specialize fmt::formatter<> for formatting using {fmt} - ceph/ceph@3f67d67ede1 crimson: specialize fmt::formatter<> to print using {fmt} - ceph/ceph@42dc970392e crimson/net: print shared_ptr using fmt::ptr() - ceph/ceph@fe1e6b6c4eb neorados: compile with fmt v9 - ceph/ceph@b2c61113ffb crimson/net: define fmt::formatter for write_state_t - ceph/ceph@1f1398bc515 mon: Fix snprintf truncation warning by switching to fmtlib - ceph/ceph@93dfb7e88b9 common: improving fmtlib handling of ceph::utime_t - ceph/ceph@3d7a895d197 include/object_fmt: mark fmt::formatter<>::format() const - ceph/ceph@2901943618f common/LogEntry: specialize fmt::formatter<LogEntry> - ceph/ceph@6e223a68021 common/Journald: include msg/msg_fmt.h - ceph/ceph@c0a3d460297 mon: use fmt::format for stderr cluster logging - ceph/ceph@cef04bc4ed0 common: use fmt::format for stderr logging - ceph/ceph@31aa539f266 osd: use fmt/ranges.h for printing ranges - ceph/ceph@b7b7ff4cce3 include/types_fmt: use fmt::join() to format containers - ceph/ceph@b287fadde3e fmt: pickup v8.1.1 - ceph/ceph@3c46dd64bbc cmake: bump up required fmt version - ceph/ceph@01f9dc84826 msg/msg_type: use fmt::format to print entity_addr - ceph/ceph@ac114ad172b crimson/os: use fmt::format() instead of sstream - ceph/ceph@bb9d099ede8 crimson: specialize fmt::formatter<>() for crimson types - ceph/ceph@3fd91d7e6d9 crimson/os/seastore: drop compile-time fmt validation
-rw-r--r--PKGBUILD6
1 files changed, 0 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3762efb6fd0f..72324e5c53d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -169,12 +169,6 @@ prepare() {
build() {
cd "${srcdir}/${pkgbase}-${pkgver}"
- # 2022-09-27 fmt>9 has deprecated an API that is used extensively throughout
- # the code base. See:
- # Upstream: https://tracker.ceph.com/issues/56610
- # Debian: https://salsa.debian.org/ceph-team/ceph/-/merge_requests/9
- CPPFLAGS+=' -DFMT_DEPRECATED_OSTREAM'
-
export CFLAGS+=" ${CPPFLAGS}"
export CXXFLAGS+=" ${CPPFLAGS}"
export CMAKE_BUILD_TYPE='RelWithDebInfo'