summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIdo Rosen2013-11-17 15:41:41 -0500
committerIdo Rosen2013-11-17 15:41:41 -0500
commit771071c71019e0775b51a2cda823cfef7019f409 (patch)
treeaf5e63f9b5d0614a8e17e3dc71d5efd3d9ed9ef3
downloadaur-771071c71019e0775b51a2cda823cfef7019f409.tar.gz
Added ceph-git.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD61
2 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8479ea5744df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = ceph-git
+ pkgdesc = Massively distributed fault-tolerant file system. Git development version.
+ pkgver = 20110528
+ pkgrel = 1
+ url = http://ceph.newdream.net/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = boost
+ depends = libedit
+ depends = libsigc++
+ depends = gtkmm
+ depends = btrfs-progs-unstable
+ depends = crypto++
+ depends = gperftools
+ depends = python2
+ depends = fuse
+ depends = keyutils
+ depends = libatomic_ops
+ depends = linux>=2.6.37
+ optdepends = fcgi: radosgw - Amazon S3 compatibility
+ optdepends = expat: radosgw - Amazon S3 compatibility
+ provides = ceph
+ conflicts = ceph
+
+pkgname = ceph-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bac7bf8534b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+pkgname=ceph-git
+pkgver=20110528
+pkgrel=1
+pkgdesc="Massively distributed fault-tolerant file system. Git development version."
+arch=('x86_64' 'i686')
+url="http://ceph.newdream.net/"
+license=('GPL')
+depends=('libedit' 'libsigc++' 'gtkmm' 'btrfs-progs-unstable' 'crypto++' 'gperftools' 'python2' 'fuse' 'keyutils' 'libatomic_ops' 'linux>=2.6.37')
+makedepends=('boost')
+optdepends=('fcgi: radosgw - Amazon S3 compatibility'
+ 'expat: radosgw - Amazon S3 compatibility')
+provides=('ceph')
+conflicts=('ceph')
+_gitroot="git://ceph.newdream.net/git/ceph.git"
+_gitname="ceph"
+
+build() {
+ cd "$srcdir"
+
+ msg "Connecting to the ceph git repository..."
+ if [ -d "$srcdir/$_gitname" ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+ msg "GIT checkout done or server timeout"
+
+ cd "$srcdir"
+ rm -rf "$_gitname-build"
+ git clone "$_gitname" "$_gitname-build"
+ cd "$_gitname-build"
+
+ msg2 "Configuring..."
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make clean
+ msg2 "Compiling..."
+ make
+ msg2 "Patching python scripts..."
+ sed -i 's:thon:thon2:' src/obsync/boto_tool
+ sed -i 's:thon:thon2:' src/obsync/obsync
+}
+
+package() {
+ cd "$_gitname-build"
+ msg2 "Packaging..."
+ make DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir/var/run/ceph" "$pkgdir/var/log/ceph" \
+ "$pkgdir/etc/rc.d" "$pkgdir/etc/ceph"
+ install -Dm755 "src/init-ceph" "$pkgdir/etc/rc.d/ceph"
+ # Move /usr/sbin to /sbin, which is expected by the mount command
+ mv "$pkgdir/usr/sbin" "$pkgdir/"
+ install -Dm644 "$pkgdir/usr/share/doc/ceph/sample.ceph.conf" \
+ "$pkgdir/etc/ceph/ceph.conf.sample"
+ install -Dm644 COPYING \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: