summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimofey Titovets2017-11-22 03:28:55 +0300
committerTimofey Titovets2017-11-22 03:28:55 +0300
commit45801cf80e24b3473b4477608b3d18ceaf8b8852 (patch)
tree06816ac2eb1b647c8a74be5ab2b405af0c782931
downloadaur-45801cf80e24b3473b4477608b3d18ceaf8b8852.tar.gz
Init
Signed-off-by: Timofey Titovets <nefelim4ag@gmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD17
3 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e89b697bf53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Wed Nov 22 00:28:48 UTC 2017
+pkgbase = ceph-iscsi-cli
+ pkgdesc = Configshell based cli for managing ceph/iscsi gateways built using LIO
+ pkgver = 2.5
+ pkgrel = 1
+ url = https://github.com/ceph/ceph-iscsi-cli
+ arch = any
+ license = GPL3
+ source = ceph-iscsi-cli::git://github.com/ceph/ceph-iscsi-cli.git#tag=2.5
+ md5sums = SKIP
+
+pkgname = ceph-iscsi-cli
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..63bbd0625c6f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+ceph-iscsi-cli
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f211d195ba3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Timofey Titovets <nefelim4ag@gmail.com>
+
+pkgname=ceph-iscsi-cli
+pkgver=2.5
+pkgrel=1
+pkgdesc="Configshell based cli for managing ceph/iscsi gateways built using LIO"
+arch=('any')
+url="https://github.com/ceph/ceph-iscsi-cli"
+license=('GPL3')
+depends=('')
+source=("$pkgname"::"git://github.com/ceph/ceph-iscsi-cli.git#tag=${pkgver}")
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/${pkgname}/"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}