summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2020-05-22 01:25:25 +0200
committerRicardo (XenGi) Band2020-05-22 01:25:25 +0200
commit162ce66ddf8dfc44c9c7276c1945f18eb8de3081 (patch)
treee47b0462a7775db6a06f38c6a41486913e81042e
downloadaur-162ce66ddf8dfc44c9c7276c1945f18eb8de3081.tar.gz
initial dump
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore21
-rw-r--r--PKGBUILD24
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..044156b24f7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cephadm
+ pkgdesc = Cephadm deploys and manages a Ceph cluster by connection to hosts from the manager daemon via SSH to add, remove, or update Ceph daemon containers
+ pkgver = 15.2.2
+ pkgrel = 1
+ url = https://ceph.com/
+ arch = any
+ license = GPL2
+ license = LGPL2.1
+ license = LGPL3
+ depends = lvm2
+ optdepends = podman: container backend
+ optdepends = docker: container backend
+ optdepends = chrony: time sync service
+ optdepends = ntp: time sync service
+ provides = cephadm
+ conflicts = cephadm-git
+ source = cephadm-15.2.2::https://github.com/ceph/ceph/raw/v15.2.2/src/cephadm/cephadm
+ sha256sums = b690fa4b6bd1a2f4336473e2d526e828fc6345289b7cc7c3556a9ea300d55005
+
+pkgname = cephadm
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4cde54694c62
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,21 @@
+cephadm-*
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f84b4a258fbf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# maintainer: Ricardo Band <email@ricardo.band>
+
+pkgname=cephadm
+pkgver=15.2.2
+pkgrel=1
+pkgdesc='Cephadm deploys and manages a Ceph cluster by connection to hosts from the manager daemon via SSH to add, remove, or update Ceph daemon containers'
+arch=('any')
+url="https://ceph.com/"
+license=('GPL2' 'LGPL2.1' 'LGPL3')
+depends=('lvm2')
+optdepends=('podman: container backend'
+ 'docker: container backend'
+ 'chrony: time sync service'
+ 'ntp: time sync service')
+provides=('cephadm')
+conflicts=('cephadm-git')
+source=("cephadm-$pkgver::https://github.com/ceph/ceph/raw/v$pkgver/src/cephadm/cephadm")
+sha256sums=('b690fa4b6bd1a2f4336473e2d526e828fc6345289b7cc7c3556a9ea300d55005')
+
+package() {
+ cd $srcdir
+ install -Dm0755 cephadm-$pkgver $pkgdir/usr/bin/cephadm
+}
+