summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlessandro Gario2016-05-16 21:03:59 +0200
committerAlessandro Gario2016-05-16 21:08:42 +0200
commit94e3992b45f81e30ebfb9544171fe59d32b80cb0 (patch)
tree12be5b2569e5cf64a77bee9455ce0aa0e2785865
parent8b665dbbcaf288beb9d3d1b1f38e636cf17503e8 (diff)
downloadaur-94e3992b45f81e30ebfb9544171fe59d32b80cb0.tar.gz
Added a .gitignore file, more comments and a missing dependency.
-rw-r--r--.SRCINFO1
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD19
3 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9d9a5780cc7..8e54a82eb050 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,7 @@ pkgbase = cerbero-profiler
depends = findutils
depends = coreutils
depends = binutils
+ depends = openssl
provides = cerbero-profiler
noextract = libpython3.4_3.4.3-1ubuntu1~14.04.3_amd64.deb
noextract = libpng12-0_1.2.50-1ubuntu2.14.04.2_amd64.deb
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef102cb1602b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.tar.xz
+*.tar.gz
+*.deb
+
+/pkg
+/src
+
diff --git a/PKGBUILD b/PKGBUILD
index 05d5823a4cc8..4fe9ccb64b71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgdesc="Cerbero Profiler is a tool designed primarily for malware and forensic
arch=('x86_64')
url="http://cerbero.io/profiler"
license=('custom')
-depends=('curl' 'tar' 'findutils' 'coreutils' 'binutils')
+depends=('curl' 'tar' 'findutils' 'coreutils' 'binutils' 'openssl')
provides=('cerbero-profiler')
# release tarball and external dependencies...
@@ -37,21 +37,24 @@ prepare() {
}
build() {
- # copy the external dependencies we have downloaded
+ # keep in mind that his is not an official package! ubuntu is the only
+ # officially supported linux distribution!
+
+ # copy the external dependencies we have downloaded from the ubuntu repository
cp "${srcdir}/usr/lib/x86_64-linux-gnu/libpython3.4m.so.1.0" "profiler_${pkgver}"
cp "${srcdir}/lib/x86_64-linux-gnu/libpng12.so.0.50.0" "profiler_${pkgver}/libpng12.so.0"
- # hardcode dirname to our installation directory
+ # hardcode the 'dirname' variable in the launcher to our installation directory
sed -i 's+dirname=`dirname $0`+dirname=/opt/Cerbero/Profiler+g' "profiler_${pkgver}/cerpro.sh"
# generate a .desktop file for the menu
- printf '[Desktop Entry]\nComment=Malware and forensic analysis tool.\nExec=/opt/Profiler/cerpro.sh %%U\nIcon=/opt/Cerbero/Profiler/icons/app_256x256.png\nName=Cerbero Profiler\nTerminal=false\nType=Application\nCategories=Development;\n' > "${srcdir}/Cerbero Profiler.desktop"
+ printf '[Desktop Entry]\nComment=Malware and forensic analysis tool.\nExec=/opt/Cerbero/Profiler/cerpro.sh %%U\nIcon=/opt/Cerbero/Profiler/icons/app_256x256.png\nName=Cerbero Profiler\nTerminal=false\nType=Application\nCategories=Development;\n' > "${srcdir}/Cerbero Profiler.desktop"
}
package() {
local menu_folder="${pkgdir}/usr/share/applications"
- # menu item
+ # install the menu item
mkdir -p "$menu_folder"
mv "${srcdir}/Cerbero Profiler.desktop" "$menu_folder"
@@ -61,12 +64,12 @@ package() {
mkdir -p "$application_folder"
mv "profiler_${pkgver}" "${application_folder}/Profiler"
- # symlink
+ # symlink the main executable to /usr/local/bin so that we can start the program by running the 'cerpro' command
local local_bin_folder="${pkgdir}/usr/local/bin"
mkdir -p "$local_bin_folder"
ln -s "/opt/Cerbero/Profiler/cerpro.sh" "${local_bin_folder}/cerpro"
- # permissions
+ # fix the permissions
chown -R root:root "$application_folder"
find "$application_folder" -type d -exec chmod 755 {} \;
find "$application_folder" -type f -exec chmod 644 {} \;
@@ -75,6 +78,6 @@ package() {
chmod 755 "${application_folder}/Profiler/cerpro" "${application_folder}/Profiler/file" "${application_folder}/Profiler/jsdbg" "${application_folder}/Profiler/yara" "${application_folder}/Profiler/hdrmgr"
- # license file
+ # install the license file
install -D -m644 "${pkgdir}/opt/Cerbero/Profiler/credits.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}