summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlessandro Gario2016-11-04 16:16:00 +0100
committerAlessandro Gario2016-11-04 16:16:00 +0100
commitd007b8fe9e4960bcd5495f985dddc8437be974e7 (patch)
treea7db52cee3aa7c416f4f12f9b86a9ae723613550
parentaff64fb7f9495bb4a87a605df1d23e2e63552058 (diff)
downloadaur-d007b8fe9e4960bcd5495f985dddc8437be974e7.tar.gz
Package release changed to 2; added a small description to the beginning of the PKGFILE.
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f6096e062c4..8a1afa1f3c1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,13 @@
-# Maintainer: Alessandro Gario <alessandro@icerbero.com>
+#
+# Maintainer: Alessandro Gario
+#
+# keep in mind that his is not an official package! ubuntu is the only
+# officially supported linux distribution!
+#
+
pkgname=cerbero-profiler
pkgver=2.6.2
-pkgrel=1
+pkgrel=2
pkgdesc="Cerbero Profiler is a tool designed primarily for malware and forensic analysis. It supports a huge number of file formats on which it performs analysis and lets the user inspect their internal layout."
arch=('x86_64')
url="http://cerbero.io/profiler"
@@ -9,11 +15,8 @@ license=('custom')
depends=('curl' 'tar' 'findutils' 'coreutils' 'binutils' 'openssl')
provides=('cerbero-profiler')
-# release tarball and external dependencies...
-source=("https://store.cerbero.io/static/downloads/profiler/profiler_${pkgver}.tar.gz" 'http://security.ubuntu.com/ubuntu/pool/main/p/python3.4/libpython3.4_3.4.0-2ubuntu1.1_amd64.deb' 'http://mirrors.kernel.org/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.50-1ubuntu2.14.04.2_amd64.deb')
-noextract=('libpython3.4_3.4.3-1ubuntu1~14.04.3_amd64.deb' 'libpng12-0_1.2.50-1ubuntu2.14.04.2_amd64.deb')
-
#
+# release tarball and external dependencies
# this is where the sha1 hashes were obtained:
#
# 1. http://packages.ubuntu.com/uk/trusty-updates/amd64/libpng12-0/download
@@ -21,6 +24,8 @@ noextract=('libpython3.4_3.4.3-1ubuntu1~14.04.3_amd64.deb' 'libpng12-0_1.2.50-1u
# 3. https://store.cerbero.io/profiler/download
#
+source=("https://store.cerbero.io/static/downloads/profiler/profiler_${pkgver}.tar.gz" 'http://security.ubuntu.com/ubuntu/pool/main/p/python3.4/libpython3.4_3.4.0-2ubuntu1.1_amd64.deb' 'http://mirrors.kernel.org/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.50-1ubuntu2.14.04.2_amd64.deb')
+noextract=('libpython3.4_3.4.3-1ubuntu1~14.04.3_amd64.deb' 'libpng12-0_1.2.50-1ubuntu2.14.04.2_amd64.deb')
sha1sums=('c4517aac16d56aeca6a64e9bff06bf5496875ef3' 'f3feb9e69cc02a0f4c7502e45db0f1f9c4e7c863' '0fd57a753a5e46659492187f804d6981158d8a00')
prepare() {
@@ -37,9 +42,6 @@ prepare() {
}
build() {
- # keep in mind that his is not an official package! ubuntu is the only
- # officially supported linux distribution!
-
# copy the external dependencies we have downloaded from the ubuntu repository
cp "${srcdir}/usr/lib/x86_64-linux-gnu/libpython3.4m.so.1.0" "profiler_${pkgver}"
cp "${srcdir}/lib/x86_64-linux-gnu/libpng12.so.0.50.0" "profiler_${pkgver}/libpng12.so.0"
@@ -71,6 +73,7 @@ package() {
# fix the permissions
chown -R root:root "$application_folder"
+
find "$application_folder" -type d -exec chmod 755 {} \;
find "$application_folder" -type f -exec chmod 644 {} \;
find "$application_folder" -type f -iname '*.so*' -exec chmod 755 {} \;