summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsvalo2019-08-07 11:42:05 +0200
committersvalo2019-08-07 11:42:05 +0200
commit4d23dd10ab1137ea338ce75645661d3e3c1ae30d (patch)
tree1cde1d54d2813d5dcc836aa0a579e4f6f192e588
downloadaur-4d23dd10ab1137ea338ce75645661d3e3c1ae30d.tar.gz
Creates certbot-dns-gandi-git package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
-rw-r--r--gandi.ini3
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3b7adff6083
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = certbot-dns-gandi-git
+ pkgdesc = gandi DNS authenticator plugin for certbot - GIT version
+ pkgver = 20190716.9bc7d07
+ pkgrel = 1
+ url = https://github.com/obynio/certbot-plugin-gandi.git
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = certbot
+ provides = certbot-dns-gandi
+ backup = etc/letsencrypt/gandi.ini
+ source = certbot-dns-gandi::git://github.com/obynio/certbot-plugin-gandi.git
+ source = gandi.ini
+ sha256sums = SKIP
+ sha256sums = 2a55fa5f82814eb95d9748737be182302d3a8cb2217e0365737062a8f57a677c
+
+pkgname = certbot-dns-gandi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f023e8e0b94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: svalo <code@valo.space>
+pkgname="certbot-dns-gandi-git"
+pkgdesc="gandi DNS authenticator plugin for certbot - GIT version"
+pkgver=20190716.9bc7d07
+pkgrel=1
+arch=("any")
+url="https://github.com/obynio/certbot-plugin-gandi.git"
+license=("MIT")
+depends=("certbot")
+makedepends=("python-setuptools")
+provides=("certbot-dns-gandi")
+backup=(
+ "etc/letsencrypt/gandi.ini"
+)
+source=(
+ "certbot-dns-gandi::git://github.com/obynio/certbot-plugin-gandi.git"
+ "gandi.ini"
+)
+sha256sums=('SKIP'
+ '2a55fa5f82814eb95d9748737be182302d3a8cb2217e0365737062a8f57a677c')
+
+pkgver() {
+ cd "${srcdir}/certbot-dns-gandi"
+ git log -1 --date=short --format="%cd.%h" | tr -d '-'
+}
+
+package() {
+ cd "${srcdir}/certbot-dns-gandi"
+ python setup.py install --root="${pkgdir}"
+ mkdir -p "${pkgdir}/etc/letsencrypt"
+ install -m 0600 "${srcdir}/gandi.ini" "${pkgdir}/etc/letsencrypt/gandi.ini"
+}
diff --git a/gandi.ini b/gandi.ini
new file mode 100644
index 000000000000..a41aa4045a14
--- /dev/null
+++ b/gandi.ini
@@ -0,0 +1,3 @@
+# Uncomment following line adding your APIKEY obtained from Gandi
+
+#certbot_plugin_gandi:dns_api_key=APIKEY