summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2019-05-10 18:48:41 +0200
committerDaniel Peukert2019-05-10 18:48:41 +0200
commitbcc3a29957530003f9576296d63effec14551a08 (patch)
tree58167023acffe0873c4ca05c47b0bc4e1b336849
downloadaur-bcc3a29957530003f9576296d63effec14551a08.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD20
4 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c4fc5ed364c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = certbot-dns-vultr
+ pkgdesc = Cerbot hooks for Vultr DNS
+ pkgver = 20190506
+ pkgrel = 1
+ url = https://github.com/oefd/certbot-dns-vultr
+ arch = any
+ license = MIT
+ depends = python-certifi
+ depends = python-chardet
+ depends = python-idna
+ depends = python-requests
+ depends = python-urllib3
+ depends = certbot
+ source = https://raw.githubusercontent.com/oefd/certbot-dns-vultr/5acb7e2b6d66f21decb3a37ed0d7ec808eefe844/vultr-hook.py
+ md5sums = 4b367f267dce06fb6ec9801f6e2b3b24
+
+pkgname = certbot-dns-vultr
+
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b669a9b7602c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c11627ac8d2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+pkgname='certbot-dns-vultr'
+pkgver='20190506'
+_commit='5acb7e2b6d66f21decb3a37ed0d7ec808eefe844'
+pkgrel='1'
+pkgdesc='Cerbot hooks for Vultr DNS'
+arch=('any')
+url="https://github.com/oefd/$pkgname"
+license=('MIT')
+depends=('python-certifi' 'python-chardet' 'python-idna' 'python-requests' 'python-urllib3' 'certbot')
+source=("https://raw.githubusercontent.com/oefd/$pkgname/$_commit/vultr-hook.py")
+md5sums=('4b367f267dce06fb6ec9801f6e2b3b24')
+
+package() {
+ cd "$_gitname"
+ install -dm755 "$pkgdir/usr/bin"
+ install -dm755 "$pkgdir/usr/share/$pkgname"
+ install -m755 "$srcdir/vultr-hook.py" "$pkgdir/usr/share/$pkgname/vultr-hook.py"
+ ln -sf "/usr/share/$pkgname/vultr-hook.py" "$pkgdir/usr/bin/$pkgname"
+}