summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-08-22 01:02:07 +0200
committerPellegrino Prevete2023-08-22 01:02:07 +0200
commitb2736f9257be14a291013ebfac8ced5afa57d57a (patch)
tree2ef81bc3b55c195aa7d8eeccfa9affc6a8222c3a
downloadaur-b2736f9257be14a291013ebfac8ced5afa57d57a.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD48
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f328b3a7a066
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = certbot-extra-formats-git
+ pkgdesc = Combine and write 'Let's encrypt' certificates compatible with a given application.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/tallero/certbot-extra-formats
+ arch = any
+ license = AGPLv3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = certbot
+ source = certbot-extra-formats::git+https://github.com/tallero/certbot-extra-formats.git
+ sha512sums = SKIP
+
+pkgname = certbot-extra-formats-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b930880eadf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+
+_py="python"
+_pkg=certbot-extra-formats
+pkgname="${_pkg}-git"
+pkgver=0.1
+pkgrel=1
+_pkgdesc=(
+ "Combine and write 'Let's encrypt'"
+ "certificates compatible with a given application.")
+pkgdesc="${_pkgdesc[*]}"
+_ns="tallero"
+url="https://github.com/${_ns}/${_pkg}"
+license=(
+ 'AGPLv3'
+)
+arch=(
+ 'any'
+)
+depends=(
+ "certbot"
+)
+makedepends=(
+ 'git'
+ "${_py}-setuptools"
+)
+source=(
+ "${_pkg}::git+${url}.git"
+)
+sha512sums=(
+ 'SKIP'
+)
+
+pkgver() {
+ cd "${_pkg}"
+ git describe --tags | \
+ sed 's/-/+/g'
+}
+
+package() {
+ cd "${_pkg}"
+ python3 setup.py \
+ install \
+ --root="${pkgdir}" \
+ --optimize=1
+}
+
+# vim:set sw=2 sts=-1 et: