summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2016-04-18 19:54:23 +0200
committerGordian Edenhofer2016-04-18 19:54:23 +0200
commit1c02421f5e2bb2188bd3491142304a984484cc77 (patch)
treeb4aba4a5b9831db2a253cd97b2d26f301e5e9d49
parentee4f72e625d51c19455160ac3ba9252a138ec32b (diff)
downloadaur-1c02421f5e2bb2188bd3491142304a984484cc77.tar.gz
Upgpkg: 0.5.0.r57.g86e09d5-1
Mention pkgver in provides field for better dependency handling.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba6e598ddcf2..015f0462cd1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,8 +25,10 @@ pkgbase = certbot-git
depends = python2-zope-interface
optdepends = certbot-apache: Apache plugin for Let’s Encrypt client
optdepends = certbot-nginx: Nginx plugin for Let’s Encrypt client
- provides = certbot
+ provides = certbot=0.5.0.r57.g86e09d5
+ provides = letsencrypt=0.5.0.r57.g86e09d5
conflicts = certbot
+ conflicts = letsencrypt
source = letsencrypt::git+https://github.com/letsencrypt/letsencrypt
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a64861e02afc..b29c265caadb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,8 @@ depends=('ca-certificates' "python2-acme=$pkgver" 'python2-configargparse' 'pyth
optdepends=("certbot-apache: Apache plugin for Let’s Encrypt client"
"certbot-nginx: Nginx plugin for Let’s Encrypt client")
makedepends=('git')
-provides=("certbot")
-conflicts=("certbot")
+provides=("certbot=${pkgver}" "letsencrypt=${pkgver}")
+conflicts=("certbot" "letsencrypt")
source=("${_reponame}"::"git+https://github.com/letsencrypt/letsencrypt")
md5sums=('SKIP')
@@ -49,7 +49,7 @@ package() {
python2 setup.py install --root="${pkgdir}" --optimize=1
# Create configuration, log and lib directories
- install -d -m700 "${pkgdir}"/etc
+ install -d "${pkgdir}"/etc/letsencrypt # TODO: someday this will probably change
install -d -m700 "${pkgdir}"/var/log/letsencrypt # TODO: someday this will probably change
- install -d -m700 "${pkgdir}"/var/lib/letsencrypt # TODO: someday this will probably change
+ install -d "${pkgdir}"/var/lib/letsencrypt # TODO: someday this will probably change
}