summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2016-05-19 22:22:08 +0200
committerGordian Edenhofer2016-05-19 22:22:08 +0200
commit2259b057a3d6b0c5c7cf7e9796633dfa54010646 (patch)
tree15d7a1096cfb9c0bfebf1faacc318e52bbad0320
parent70bb10dd2a729500bf31f7394986627b1af3cf33 (diff)
downloadaur-2259b057a3d6b0c5c7cf7e9796633dfa54010646.tar.gz
upgpkg: *(acme|certbot)* 0.6.0.r64.ge385274-1
Cerbot does require the same version of acme being installed. However simply state that the git version is needed. Despite the fact that the dependency does not need to be a git package itself, a versioned dep is often not properly resolved by an AUR helper. This ensures that both are updated at fairly the same time. upgpkg: certbot-git 0.6.0.r64.ge385274-1 upgpkg: certbot-plugins-git 0.6.0.r64.ge385274-1 upgpkg: letshelp-certbot-git 0.6.0.r64.ge385274-1 upgpkg: python-acme-git 0.6.0.r64.ge385274-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD9
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07a9fb1d1c67..5f3fc328c99f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = certbot-git
pkgdesc = A tool to automatically receive and install X.509 certificates to enable TLS on servers. The client will interoperate with the Let’s Encrypt CA which will be issuing browser-trusted certificates for free.
- pkgver = 0.5.0.r153.g41f347d
+ pkgver = 0.6.0.r64.ge385274
pkgrel = 1
url = https://letsencrypt.org/
arch = any
license = Apache
makedepends = git
depends = ca-certificates
- depends = python2-acme
+ depends = python2-acme-git
depends = python2-configargparse
depends = python2-configobj
depends = python2-cryptography
@@ -23,10 +23,11 @@ pkgbase = certbot-git
depends = python2-six
depends = python2-zope-component
depends = python2-zope-interface
- optdepends = certbot-apache: Apache plugin for Let’s Encrypt client
- optdepends = certbot-nginx: Nginx plugin for Let’s Encrypt client
- provides = certbot=0.5.0.r153.g41f347d
- provides = letsencrypt=0.5.0.r153.g41f347d
+ optdepends = certbot-apache-git: Apache plugin for Let’s Encrypt client
+ optdepends = certbot-nginx-git: Nginx plugin for Let’s Encrypt client
+ optdepends = letshelp-certbot-git: Let's help Certbot client
+ provides = certbot=0.6.0.r64.ge385274
+ provides = letsencrypt=0.6.0.r64.ge385274
conflicts = certbot
conflicts = letsencrypt
replaces = letsencrypt-git
diff --git a/PKGBUILD b/PKGBUILD
index ce0c03eb9b48..1854827519bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,21 @@
pkgname=certbot-git
_reponame="certbot"
-pkgver=0.5.0.r153.g41f347d
+pkgver=0.6.0.r64.ge385274
pkgrel=1
pkgdesc="A tool to automatically receive and install X.509 certificates to enable TLS on servers. The client will interoperate with the Let’s Encrypt CA which will be issuing browser-trusted certificates for free."
arch=('any')
license=('Apache')
url="https://letsencrypt.org/"
# Most AUR helpers unfortunately do not support versioned deps in the AUR ("python2-acme=${pkgver}")
-depends=('ca-certificates' 'python2-acme' 'python2-configargparse' 'python2-configobj'
+depends=('ca-certificates' 'python2-acme-git' 'python2-configargparse' 'python2-configobj'
'python2-cryptography' 'python2-pyopenssl' 'python2-mock' 'python2-parsedatetime'
'python2-psutil' 'python2-pyrfc3339' 'python2-pythondialog' 'python2-pytz'
'python2-requests' 'python2-setuptools' 'python2-six' 'python2-zope-component'
'python2-zope-interface')
-optdepends=("certbot-apache: Apache plugin for Let’s Encrypt client"
- "certbot-nginx: Nginx plugin for Let’s Encrypt client")
+optdepends=("certbot-apache-git: Apache plugin for Let’s Encrypt client"
+ "certbot-nginx-git: Nginx plugin for Let’s Encrypt client"
+ "letshelp-certbot-git: Let's help Certbot client")
makedepends=('git')
provides=("certbot=${pkgver}" "letsencrypt=${pkgver}")
conflicts=("certbot" "letsencrypt")