summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2017-06-09 20:09:32 +0200
committerGordian Edenhofer2017-06-09 20:09:32 +0200
commit9b5d76fd938ae2142959ed499aff32f4d86ec127 (patch)
tree6c9ce3c8cbc156a3fc891e82e46a15992f1efc7d
parent40d376ef3130f14aac9bd1f79b6079e71bfb400e (diff)
downloadaur-9b5d76fd938ae2142959ed499aff32f4d86ec127.tar.gz
upgpkg: certbot-git 0.15.0.r8.gcd34c427-1
Switch from python2 to python (version 3). upgpkg: certbot-plugins-git 0.15.0.r8.gcd34c427-1 upgpkg: letshelp-certbot-git 0.15.0.r8.gcd34c427-1 upgpkg: python-acme-git 0.15.0.r8.gcd34c427-1
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD22
2 files changed, 30 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88cb7979272d..6061d9318f1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,33 @@
pkgbase = certbot-git
pkgdesc = A tool to automatically receive and install X.509 certificates to enable TLS on servers. The client will interoperate with the Let’s Encrypt CA which will be issuing browser-trusted certificates for free.
- pkgver = 0.14.0.r6.gc6fcb017
+ pkgver = 0.15.0.r8.gcd34c427
pkgrel = 1
url = https://certbot.eff.org/
arch = any
license = Apache
makedepends = git
depends = ca-certificates
- depends = python2-acme-git
- depends = python2-configargparse
- depends = python2-configobj
- depends = python2-cryptography
- depends = python2-pyopenssl
- depends = python2-mock
- depends = python2-parsedatetime
- depends = python2-psutil
- depends = python2-pyrfc3339
- depends = python2-pythondialog
- depends = python2-pytz
- depends = python2-requests
- depends = python2-setuptools
- depends = python2-six
- depends = python2-zope-component
- depends = python2-zope-interface
+ depends = python-acme-git
+ depends = python-configargparse
+ depends = python-configobj
+ depends = python-cryptography
+ depends = python-pyopenssl
+ depends = python-mock
+ depends = python-parsedatetime
+ depends = python-psutil
+ depends = python-pyrfc3339
+ depends = python-pythondialog
+ depends = python-pytz
+ depends = python-requests
+ depends = python-setuptools
+ depends = python-six
+ depends = python-zope-component
+ depends = python-zope-interface
optdepends = certbot-apache-git: Apache plugin for Let’s Encrypt client
optdepends = certbot-nginx-git: Nginx plugin for Let’s Encrypt client
optdepends = letshelp-certbot-git: Let's help Certbot client
- provides = certbot=0.14.0.r6.gc6fcb017
- provides = letsencrypt=0.14.0.r6.gc6fcb017
+ provides = certbot=0.15.0.r8.gcd34c427
+ provides = letsencrypt=0.15.0.r8.gcd34c427
conflicts = certbot
conflicts = letsencrypt
replaces = letsencrypt-git
diff --git a/PKGBUILD b/PKGBUILD
index 9748d4124a5a..0d9b14a26322 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
pkgname=certbot-git
_reponame="certbot"
-pkgver=0.14.0.r6.gc6fcb017
+pkgver=0.15.0.r8.gcd34c427
pkgrel=1
pkgdesc="A tool to automatically receive and install X.509 certificates to enable TLS on servers. The client will interoperate with the Let’s Encrypt CA which will be issuing browser-trusted certificates for free."
arch=('any')
license=('Apache')
url="https://certbot.eff.org/"
-# Most AUR helpers unfortunately do not support versioned deps in the AUR ("python2-acme=${pkgver}")
-depends=('ca-certificates' 'python2-acme-git' 'python2-configargparse' 'python2-configobj'
- 'python2-cryptography' 'python2-pyopenssl' 'python2-mock' 'python2-parsedatetime'
- 'python2-psutil' 'python2-pyrfc3339' 'python2-pythondialog' 'python2-pytz'
- 'python2-requests' 'python2-setuptools' 'python2-six' 'python2-zope-component'
- 'python2-zope-interface')
+# Most AUR helpers unfortunately do not support versioned deps in the AUR ("python-acme=${pkgver}")
+depends=('ca-certificates' 'python-acme-git' 'python-configargparse' 'python-configobj'
+ 'python-cryptography' 'python-pyopenssl' 'python-mock' 'python-parsedatetime'
+ 'python-psutil' 'python-pyrfc3339' 'python-pythondialog' 'python-pytz'
+ 'python-requests' 'python-setuptools' 'python-six' 'python-zope-component'
+ 'python-zope-interface')
optdepends=("certbot-apache-git: Apache plugin for Let’s Encrypt client"
"certbot-nginx-git: Nginx plugin for Let’s Encrypt client"
"letshelp-certbot-git: Let's help Certbot client")
@@ -37,11 +37,11 @@ build() {
cd "${srcdir}/${_reponame}"
# Clean up build environment
- python2 setup.py clean
+ python setup.py clean
rm -rf build dist
- # Build the package using python2
- python2 setup.py build
+ # Build the package using python
+ python setup.py build
}
package() {
@@ -49,7 +49,7 @@ package() {
cd "${srcdir}/${_reponame}"
# Install files
- python2 setup.py install --root="${pkgdir}" --optimize=1
+ python setup.py install --root="${pkgdir}" --optimize=1
# Create configuration, log and lib directories
install -d "${pkgdir}"/etc/letsencrypt # TODO: someday this will probably change