summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-15 15:47:19 +0800
committerzxp198210052024-03-15 15:47:19 +0800
commit44cb51217dc489bf876bc35397885c0ac3d4641f (patch)
tree5680075078e437253e02130ef100beec162a81c8
parenta7e277ad4ad2c41afb83e377ebfb06e612e36207 (diff)
downloadaur-44cb51217dc489bf876bc35397885c0ac3d4641f.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--certbox.sh8
3 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cfc3d97ee341..2dc8a979c9c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = certbox-bin
pkgdesc = A X.509 certificate toolbox on your desktop or in your browser. It allows you to easily generate entire certificate chains, issue certificates from existing roots, clone certificates, and more.
pkgver = 1.8.0
- pkgrel = 2
+ pkgrel = 3
url = https://certbox.io/
arch = aarch64
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = certbox-bin
source = LICENSE-1.8.0::https://raw.githubusercontent.com/tls-inspector/certbox/1.8.0/LICENSE
source = certbox.sh
sha256sums = 6b2fa2b36ced9533ff04ff21bd9c7d22b4fd1747bcdc8a840f009943a51b628e
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
source_aarch64 = certbox-1.8.0-aarch64.deb::https://github.com/tls-inspector/certbox/releases/download/1.8.0/certbox_1.8.0_arm64.deb
sha256sums_aarch64 = 4eb01791f546c9af026054bde32249e16d35ab04110f50583f3e1696eeeaf673
source_x86_64 = certbox-1.8.0-x86_64.deb::https://github.com/tls-inspector/certbox/releases/download/1.8.0/certbox_1.8.0_x64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 8128a9cc0457..048e301f5162 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=certbox-bin
pkgver=1.8.0
_electronversion=28
-pkgrel=2
+pkgrel=3
pkgdesc="A X.509 certificate toolbox on your desktop or in your browser. It allows you to easily generate entire certificate chains, issue certificates from existing roots, clone certificates, and more."
arch=(
'aarch64'
@@ -23,13 +23,14 @@ source=(
"LICENSE-${pkgver}::https://raw.githubusercontent.com/tls-inspector/certbox/${pkgver}/LICENSE"
"${pkgname%-bin}.sh")
sha256sums=('6b2fa2b36ced9533ff04ff21bd9c7d22b4fd1747bcdc8a840f009943a51b628e'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
sha256sums_aarch64=('4eb01791f546c9af026054bde32249e16d35ab04110f50583f3e1696eeeaf673')
sha256sums_x86_64=('ce828045145481408d8af880c85698bf0000a81a1311f3154df1f812f1bb7530')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
}
diff --git a/certbox.sh b/certbox.sh
index f9ced1432cfc..7ddcaab8d734 100644
--- a/certbox.sh
+++ b/certbox.sh
@@ -1,14 +1,16 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file