summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-26 17:28:49 +0800
committerzxp198210052024-02-26 17:28:49 +0800
commita7e277ad4ad2c41afb83e377ebfb06e612e36207 (patch)
treef4f74b39510a3ba67d6095013624e1e337a6600c
parent69673a89b56a00043ab9bcb84be3ca7c1c5fda50 (diff)
downloadaur-a7e277ad4ad2c41afb83e377ebfb06e612e36207.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--certbox.sh9
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 703a918796e1..cfc3d97ee341 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = certbox-bin
pkgdesc = A X.509 certificate toolbox on your desktop or in your browser. It allows you to easily generate entire certificate chains, issue certificates from existing roots, clone certificates, and more.
pkgver = 1.8.0
- pkgrel = 1
+ pkgrel = 2
url = https://certbox.io/
arch = aarch64
arch = x86_64
license = MIT
depends = electron28
+ depends = nodejs
provides = certbox=1.8.0
conflicts = certbox
source = LICENSE-1.8.0::https://raw.githubusercontent.com/tls-inspector/certbox/1.8.0/LICENSE
source = certbox.sh
sha256sums = 6b2fa2b36ced9533ff04ff21bd9c7d22b4fd1747bcdc8a840f009943a51b628e
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
source_aarch64 = certbox-1.8.0-aarch64.deb::https://github.com/tls-inspector/certbox/releases/download/1.8.0/certbox_1.8.0_arm64.deb
sha256sums_aarch64 = 4eb01791f546c9af026054bde32249e16d35ab04110f50583f3e1696eeeaf673
source_x86_64 = certbox-1.8.0-x86_64.deb::https://github.com/tls-inspector/certbox/releases/download/1.8.0/certbox_1.8.0_x64.deb
diff --git a/PKGBUILD b/PKGBUILD
index a5fc5a7d694e..8128a9cc0457 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=certbox-bin
pkgver=1.8.0
_electronversion=28
-pkgrel=1
+pkgrel=2
pkgdesc="A X.509 certificate toolbox on your desktop or in your browser. It allows you to easily generate entire certificate chains, issue certificates from existing roots, clone certificates, and more."
arch=(
'aarch64'
@@ -15,6 +15,7 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
+ 'nodejs'
)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}_arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}_x64.deb")
@@ -22,15 +23,15 @@ source=(
"LICENSE-${pkgver}::https://raw.githubusercontent.com/tls-inspector/certbox/${pkgver}/LICENSE"
"${pkgname%-bin}.sh")
sha256sums=('6b2fa2b36ced9533ff04ff21bd9c7d22b4fd1747bcdc8a840f009943a51b628e'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
sha256sums_aarch64=('4eb01791f546c9af026054bde32249e16d35ab04110f50583f3e1696eeeaf673')
sha256sums_x86_64=('ce828045145481408d8af880c85698bf0000a81a1311f3154df1f812f1bb7530')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app|g" \
+ -e "s|@runname@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.zst"
+ bsdtar -xf "${srcdir}/data."*
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/certbox.sh b/certbox.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/certbox.sh
+++ b/certbox.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file