summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-19 11:16:37 +0800
committerzxp198210052023-10-19 11:16:37 +0800
commitd5466fe251b9cb4f9a79e66ce4b423e449286959 (patch)
tree5a275ee42ead3601025282f05de88fe5fdda1ae6
downloadaur-d5466fe251b9cb4f9a79e66ce4b423e449286959.tar.gz
update to 1.7.1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
-rw-r--r--certbox.sh8
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69ac42b07334
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = certbox-bin
+ pkgdesc = A X.509 certificate toolbox on your desktop or in your browser. It allows you to easily generate entire certificate chains, issue certificates from existing roots, clone certificates, and more.
+ pkgver = 1.7.1
+ pkgrel = 1
+ url = https://certbox.io/
+ arch = aarch64
+ arch = x86_64
+ license = MIT
+ depends = bash
+ depends = electron26
+ provides = certbox=1.7.1
+ conflicts = certbox
+ source = LICENSE::https://raw.githubusercontent.com/tls-inspector/certbox/1.7.1/LICENSE
+ source = certbox.sh
+ sha256sums = 86a899de0d14686c5fc2a444067323ed7162e88718b9d0b045653383b6059719
+ sha256sums = fe975d5b63ec9006d5baa93605607e8a71db2a19d30d43517724f987efd52373
+ source_aarch64 = certbox-1.7.1-aarch64.deb::https://github.com/tls-inspector/certbox/releases/download/1.7.1/certbox_1.7.1_arm64.deb
+ sha256sums_aarch64 = af4a20bc9e0a6fd2d0add893a93486a36800219f94b35c68e2ebd2b1250cece5
+ source_x86_64 = certbox-1.7.1-x86_64.deb::https://github.com/tls-inspector/certbox/releases/download/1.7.1/certbox_1.7.1_x64.deb
+ sha256sums_x86_64 = 73d5bf6548364bc7a8a67b7fba39085a1fff3619ec321372b400c4d01ece9ae6
+
+pkgname = certbox-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0e569ebe371
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=certbox-bin
+pkgver=1.7.1
+pkgrel=1
+pkgdesc="A X.509 certificate toolbox on your desktop or in your browser. It allows you to easily generate entire certificate chains, issue certificates from existing roots, clone certificates, and more."
+arch=('aarch64' 'x86_64')
+url="https://certbox.io/"
+_githuburl="https://github.com/tls-inspector/certbox"
+license=('MIT')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=('bash' 'electron26')
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_githuburl}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}_arm64.deb")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_githuburl}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}_x64.deb")
+source=("LICENSE::https://raw.githubusercontent.com/tls-inspector/certbox/${pkgver}/LICENSE"
+ "${pkgname%-bin}.sh")
+sha256sums=('86a899de0d14686c5fc2a444067323ed7162e88718b9d0b045653383b6059719'
+ 'fe975d5b63ec9006d5baa93605607e8a71db2a19d30d43517724f987efd52373')
+sha256sums_aarch64=('af4a20bc9e0a6fd2d0add893a93486a36800219f94b35c68e2ebd2b1250cece5')
+sha256sums_x86_64=('73d5bf6548364bc7a8a67b7fba39085a1fff3619ec321372b400c4d01ece9ae6')
+build() {
+ bsdtar -xf "${srcdir}/data.tar.zst"
+ sed "s| %U||g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 -d "${pkgdir}/opt/${pkgname%-bin}/resources"
+ cp -r "${srcdir}/usr/lib/${pkgname%-bin}/resources/app" "${pkgdir}/opt/${pkgname%-bin}/resources"
+ install -Dm644 "${srcdir}/usr/share/pixmaps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file
diff --git a/certbox.sh b/certbox.sh
new file mode 100644
index 000000000000..fbfe9a1e60c1
--- /dev/null
+++ b/certbox.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron26
+_APPDIR="/opt/certbox/resources/app/"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_APPDIR} "$@"
+else
+ exec ${_ELECTRON} ${_APPDIR} --no-sandbox "$@"
+fi \ No newline at end of file