summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Candau2022-09-01 13:25:05 +0200
committerRobin Candau2022-09-01 13:25:05 +0200
commite1004a34688eb4f9c333db636e42a8887baf68ee (patch)
tree1ac2eef6e4aac4edae5133aba3be468ace2b3358
downloadaur-e1004a34688eb4f9c333db636e42a8887baf68ee.tar.gz
Initial release of certificate-ripper on the AUR
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..135555ed25e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = certificate-ripper-bin
+ pkgdesc = A CLI tool to extract server certificates
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Hakky54/certificate-ripper
+ arch = x86_64
+ license = Apache
+ provides = certificate-ripper
+ conflicts = certificate-ripper
+ source = crip-1.0.0.tar.gz::https://github.com/Hakky54/certificate-ripper/releases/download/1.0.0/crip-linux-amd64.tar.gz
+ sha256sums = 83ab8bf2d68b54967a3c1525d25dc6a8210ebadb30cbd6592ef61001731a288a
+
+pkgname = certificate-ripper-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34684b665794
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Robin Candau <robincandau[at]protonmail[dot]com>
+
+pkgname=certificate-ripper-bin
+_pkgname="${pkgname%-bin}"
+_shortname=crip
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A CLI tool to extract server certificates"
+arch=('x86_64')
+url="https://github.com/Hakky54/certificate-ripper"
+license=('Apache')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_shortname}-${pkgver}.tar.gz::${url}/releases/download/${pkgver}/${_shortname}-linux-amd64.tar.gz")
+sha256sums=(83ab8bf2d68b54967a3c1525d25dc6a8210ebadb30cbd6592ef61001731a288a)
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm 755 "${_shortname}" "${pkgdir}/usr/bin/${_shortname}"
+}