summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-18 08:26:27 +0800
committerzxp198210052024-01-18 08:26:27 +0800
commit206b8514c8374f2c8913ea67f1547129026deb54 (patch)
tree8c78a8b83e4c8c79f4085ca061df3791ece859c7
parent35be2e722452220c679a9515631ad53ff300f7c1 (diff)
downloadaur-206b8514c8374f2c8913ea67f1547129026deb54.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--certmanager.sh4
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ced90752a9e..a034f2ddb22d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = certmanager-bin
pkgdesc = A simple and efficient local certificate management tool that provides functions such as certificate installation, certificate management, and certificate verification.一款简单高效的本地证书管理工具,提供证书安装、证书管理、证书验证等功能,支持国密证书.
pkgver = 1.0.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.bitnum.com/
arch = x86_64
license = custom:unknown
@@ -10,6 +10,6 @@ pkgbase = certmanager-bin
source = certmanager-1.0.0.deb::https://com-store-packages.uniontech.com/pool/appstore/c/cn.bitnum.certmanager/cn.bitnum.certmanager_1.0.0_amd64.deb
source = certmanager.sh
sha256sums = e5e15c046381827d6558e4cd351b73934c3812546fc85204259ea2a20e2febd9
- sha256sums = 0532bec6588d7b9d6cba26c488fc638b28d35b1c21e1ed16510c0a8f8df54450
+ sha256sums = a9783526d93e6c72c7e1551cc5cc513fd6056dcc4593abe8fac815721d32dd5a
pkgname = certmanager-bin
diff --git a/PKGBUILD b/PKGBUILD
index dc1a06b63d2d..f4e57e75737e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=certmanager-bin
_pkgname=CertManager
_uosname="cn.bitnum.${pkgname%-bin}"
pkgver=1.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="A simple and efficient local certificate management tool that provides functions such as certificate installation, certificate management, and certificate verification.一款简单高效的本地证书管理工具,提供证书安装、证书管理、证书验证等功能,支持国密证书."
arch=('x86_64')
url="http://www.bitnum.com/"
@@ -17,14 +17,14 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('e5e15c046381827d6558e4cd351b73934c3812546fc85204259ea2a20e2febd9'
- '0532bec6588d7b9d6cba26c488fc638b28d35b1c21e1ed16510c0a8f8df54450')
+ 'a9783526d93e6c72c7e1551cc5cc513fd6056dcc4593abe8fac815721d32dd5a')
build() {
sed -e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@runappname@|${_pkgname}|g" \
+ -e "s|@runname@|${_pkgname}|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
rm -rf "${srcdir}/opt/apps/${_uosname}/files/证书管理器"
- sed -e "s|/opt/apps/${_uosname}/files/${_pkgname}|${pkgname%-bin}|g" \
+ sed -e "s|/opt/apps/${_uosname}/files/${_pkgname}|${pkgname%-bin} %U|g" \
-e "s|/opt/apps/${_uosname}/entries/icons/icon.png|${pkgname%-bin}|g" \
-i "${srcdir}/opt/apps/${_uosname}/entries/applications/${_uosname}.desktop"
}
diff --git a/certmanager.sh b/certmanager.sh
index a9016ba6c5a8..8c3bc7d4fc8a 100644
--- a/certmanager.sh
+++ b/certmanager.sh
@@ -1,7 +1,7 @@
#!/bin/sh
set -e
_APPDIR=/opt/@appname@
-_APPNAME=@runappname@
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
cd "${_APPDIR}"
-exec "${_APPDIR}/${_APPNAME}" \ No newline at end of file
+exec "${_RUNNAME}" "$@" || exit $? \ No newline at end of file