summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-10-04 20:42:04 +0200
committerDaniel Peukert2023-10-04 20:42:04 +0200
commitd23f2ba3c8e6cd63829cc80a940827c75bc8df4f (patch)
treeff6f470c9b0c23b6cda2a00ad49bb2490bdc0893
parentb9653d7a0b6f1a2231fd6750755fbc14be59250a (diff)
downloadaur-d23f2ba3c8e6cd63829cc80a940827c75bc8df4f.tar.gz
Update go architectures and build vars
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1202fb0f042..a5d31fc255c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,13 +5,14 @@ pkgbase = certspotter
url = https://github.com/SSLMate/certspotter
install = certspotter.install
arch = x86_64
+ arch = i686
arch = pentium4
arch = armv7h
arch = aarch64
license = MPL2
makedepends = go>=1.19
makedepends = lowdown
- source = certspotter-0.16.0-1.tar.gz::https://github.com/SSLMate/certspotter/archive/v0.16.0.tar.gz
+ source = certspotter-0.16.0.tar.gz::https://github.com/SSLMate/certspotter/archive/v0.16.0.tar.gz
sha512sums = 418647a317b240bf7bf6589b7596045e2ef18001a97badc1f2eedd962f841696292792c005e6c3b75198e8457679e78f3f95380805b335f28038eb25f929052b
pkgname = certspotter
diff --git a/PKGBUILD b/PKGBUILD
index 18b1b61ca004..42e6c111750f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@ pkgname='certspotter'
pkgver='0.16.0'
pkgrel='1'
pkgdesc='Certificate Transparency Log Monitor'
-arch=('x86_64' 'pentium4' 'armv7h' 'aarch64')
+arch=('x86_64' 'i686' 'pentium4' 'armv7h' 'aarch64')
url="https://github.com/SSLMate/$pkgname"
license=('MPL2')
makedepends=('go>=1.19' 'lowdown')
install="$pkgname.install"
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha512sums=('418647a317b240bf7bf6589b7596045e2ef18001a97badc1f2eedd962f841696292792c005e6c3b75198e8457679e78f3f95380805b335f28038eb25f929052b')
_sourcedirectory="$pkgname-$pkgver"
-_bindir="$pkgname-$pkgver-$pkgrel-bin"
-_gopath="$pkgname-$pkgver-$pkgrel-gopath"
+_bindir="$pkgname-$pkgver-bin"
+_gopath="$pkgname-$pkgver-gopath"
prepare() {
mkdir -p "$srcdir/$_bindir/"
@@ -27,7 +27,7 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw -ldflags=-X=main.Version=v$pkgver"
+ export GOFLAGS="-buildmode=pie -trimpath '-ldflags=-X=main.Version=v$pkgver -linkmode=external' -mod=readonly -modcacherw"
go build -v -o "$srcdir/$_bindir/" './...'
# Build man pages
@@ -37,12 +37,6 @@ build() {
check() {
cd "$srcdir/$_sourcedirectory/"
- export GOPATH="$srcdir/$_gopath"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw -ldflags=-X=main.Version=v$pkgver"
go test -v './...'
}