summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-02-09 12:36:44 +0100
committerDaniel Peukert2023-02-09 12:36:44 +0100
commit0c348456379c4a57b0602732c104e21cf1dbfe94 (patch)
tree33a5e08ba6bb05159912ee5127426e3141e9b557
parent875b257690be6c67c3c67e5c9c5cdb4c1927e7fb (diff)
downloadaur-0c348456379c4a57b0602732c104e21cf1dbfe94.tar.gz
Update certspotter to 0.15.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
-rw-r--r--certspotter.install6
3 files changed, 34 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08e7df2d6dd6..ea95fb732be1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = certspotter-git
pkgdesc = Certificate Transparency Log Monitor - git version
- pkgver = 0.14.0.r0.g3d1bdb2
+ pkgver = 0.15.0.r0.gce81f90
pkgrel = 1
url = https://github.com/SSLMate/certspotter
+ install = certspotter.install
arch = x86_64
arch = i686
arch = arm
@@ -11,10 +12,13 @@ pkgbase = certspotter-git
arch = aarch64
license = MPL2
makedepends = git
- makedepends = go>=1.17
+ makedepends = go>=1.19
+ makedepends = lowdown
provides = certspotter
conflicts = certspotter
source = certspotter-git::git+https://github.com/SSLMate/certspotter
+ source = certspotter-git-0.15.0.r0.gce81f90-1-fix-errorf.diff::https://github.com/SSLMate/certspotter/pull/67.diff
sha512sums = SKIP
+ sha512sums = 9a27893c2ddbb7634e4316b63f7b6ba4686a44d27b9d128f627514fface7251f154d4dbb1300ba39d1290149a3c0879d232f523681cf577ddcc9e8b519fae0eb
pkgname = certspotter-git
diff --git a/PKGBUILD b/PKGBUILD
index dae8aa9a0f1c..5861d0044701 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
_pkgname='certspotter'
pkgname="$_pkgname-git"
-pkgver='0.14.0.r0.g3d1bdb2'
+pkgver='0.15.0.r0.gce81f90'
pkgrel='1'
pkgdesc='Certificate Transparency Log Monitor - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/SSLMate/$_pkgname"
license=('MPL2')
-makedepends=('git' 'go>=1.17')
+makedepends=('git' 'go>=1.19' 'lowdown')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$pkgname::git+$url")
-sha512sums=('SKIP')
+install="$_pkgname.install"
+source=(
+ "$pkgname::git+$url"
+ "$pkgname-$pkgver-$pkgrel-fix-errorf.diff::$url/pull/67.diff"
+)
+sha512sums=('SKIP'
+ '9a27893c2ddbb7634e4316b63f7b6ba4686a44d27b9d128f627514fface7251f154d4dbb1300ba39d1290149a3c0879d232f523681cf577ddcc9e8b519fae0eb')
_sourcedirectory="$pkgname"
_bindir="$pkgname-bin"
@@ -20,6 +25,10 @@ _gopath="$pkgname-gopath"
prepare() {
mkdir -p "$srcdir/$_bindir/"
mkdir -p "$srcdir/$_gopath/"
+
+ # Apply errorf patch
+ cd "$srcdir/$_sourcedirectory/"
+ patch --forward -p1 < "$srcdir/$pkgname-$pkgver-$pkgrel-fix-errorf.diff"
}
pkgver() {
@@ -36,6 +45,10 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
go build -v -o "$srcdir/$_bindir/" './...'
+
+ # Build man pages
+ cd "$srcdir/$_sourcedirectory/man/"
+ make all
}
check() {
@@ -51,7 +64,9 @@ check() {
package() {
cd "$srcdir/"
- for _binary in "$_pkgname" 'ctparsewatch' 'submitct'; do
- install -Dm755 "$_bindir/$_binary" "$pkgdir/usr/bin/$_binary"
- done
+ install -dm755 "$pkgdir/usr/bin/"
+ install -Dm755 "$_bindir/"* "$pkgdir/usr/bin/"
+
+ install -dm755 "$pkgdir/usr/share/man/man8/"
+ install -Dm644 "$_sourcedirectory/man/"*'.8' "$pkgdir/usr/share/man/man8/"
}
diff --git a/certspotter.install b/certspotter.install
new file mode 100644
index 000000000000..6912c694fa43
--- /dev/null
+++ b/certspotter.install
@@ -0,0 +1,6 @@
+post_upgrade() {
+ if [ "$(vercmp $2 0.15.0)" -lt 0 ]; then
+ echo 'certspotter is now a daemon, read the changelog for more details:'
+ echo 'https://github.com/SSLMate/certspotter/blob/master/CHANGELOG.md'
+ fi
+}