summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-02-09 21:27:56 +0100
committerDaniel Peukert2023-02-09 21:27:56 +0100
commit0f8e837ed7325019841a4150c6836bf1749d22a2 (patch)
treeb99dfe938ab067d25b18548db556fd5320f2b87c
parent0c348456379c4a57b0602732c104e21cf1dbfe94 (diff)
downloadaur-0f8e837ed7325019841a4150c6836bf1749d22a2.tar.gz
Update certspotter to 0.15.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 6 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea95fb732be1..2f731fdd1282 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = certspotter-git
pkgdesc = Certificate Transparency Log Monitor - git version
- pkgver = 0.15.0.r0.gce81f90
+ pkgver = 0.15.1.r0.g223bf93
pkgrel = 1
url = https://github.com/SSLMate/certspotter
install = certspotter.install
@@ -17,8 +17,6 @@ pkgbase = certspotter-git
provides = certspotter
conflicts = certspotter
source = certspotter-git::git+https://github.com/SSLMate/certspotter
- source = certspotter-git-0.15.0.r0.gce81f90-1-fix-errorf.diff::https://github.com/SSLMate/certspotter/pull/67.diff
sha512sums = SKIP
- sha512sums = 9a27893c2ddbb7634e4316b63f7b6ba4686a44d27b9d128f627514fface7251f154d4dbb1300ba39d1290149a3c0879d232f523681cf577ddcc9e8b519fae0eb
pkgname = certspotter-git
diff --git a/PKGBUILD b/PKGBUILD
index 5861d0044701..8f0bcc2db33d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
_pkgname='certspotter'
pkgname="$_pkgname-git"
-pkgver='0.15.0.r0.gce81f90'
+pkgver='0.15.1.r0.g223bf93'
pkgrel='1'
pkgdesc='Certificate Transparency Log Monitor - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -11,12 +11,8 @@ makedepends=('git' 'go>=1.19' 'lowdown')
provides=("$_pkgname")
conflicts=("$_pkgname")
install="$_pkgname.install"
-source=(
- "$pkgname::git+$url"
- "$pkgname-$pkgver-$pkgrel-fix-errorf.diff::$url/pull/67.diff"
-)
-sha512sums=('SKIP'
- '9a27893c2ddbb7634e4316b63f7b6ba4686a44d27b9d128f627514fface7251f154d4dbb1300ba39d1290149a3c0879d232f523681cf577ddcc9e8b519fae0eb')
+source=("$pkgname::git+$url")
+sha512sums=('SKIP')
_sourcedirectory="$pkgname"
_bindir="$pkgname-bin"
@@ -25,10 +21,6 @@ _gopath="$pkgname-gopath"
prepare() {
mkdir -p "$srcdir/$_bindir/"
mkdir -p "$srcdir/$_gopath/"
-
- # Apply errorf patch
- cd "$srcdir/$_sourcedirectory/"
- patch --forward -p1 < "$srcdir/$pkgname-$pkgver-$pkgrel-fix-errorf.diff"
}
pkgver() {
@@ -43,7 +35,7 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw -ldflags=-X=main.Version=$(git rev-parse HEAD)"
go build -v -o "$srcdir/$_bindir/" './...'
# Build man pages
@@ -58,7 +50,7 @@ check() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw -ldflags=-X=main.Version=$(git rev-parse HEAD)"
go test -v './...'
}