summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2022-06-08 08:37:27 +0200
committerDaniel Peukert2022-06-08 08:37:27 +0200
commitbf3bfc1f8eea273665c3542e264001cd078525b9 (patch)
tree5b2294570ef4dadf12eeb7aedf2cb1cc7bf46015
parentc4fc2a63c5b3679993c0a3296d79141967493000 (diff)
downloadaur-bf3bfc1f8eea273665c3542e264001cd078525b9.tar.gz
Update certspotter to 0.12
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4eb66ef52c3a..faa3de546f92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = certspotter-git
pkgdesc = Certificate Transparency Log Monitor - git version
- pkgver = 0.10.r1.g6d5e239
- pkgrel = 2
+ pkgver = 0.12.r0.g270cdab
+ pkgrel = 1
url = https://github.com/SSLMate/certspotter
arch = x86_64
arch = i686
@@ -15,6 +15,6 @@ pkgbase = certspotter-git
provides = certspotter
conflicts = certspotter
source = certspotter-git::git+https://github.com/SSLMate/certspotter
- sha256sums = SKIP
+ sha512sums = SKIP
pkgname = certspotter-git
diff --git a/PKGBUILD b/PKGBUILD
index 011a472848b9..cc9bf98b9e8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Maintainer: Daniel Peukert <daniel@peukert.cc>
_pkgname='certspotter'
pkgname="$_pkgname-git"
-pkgver='0.10.r1.g6d5e239'
-pkgrel='2'
+pkgver='0.12.r0.g270cdab'
+pkgrel='1'
pkgdesc='Certificate Transparency Log Monitor - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/SSLMate/$_pkgname"
@@ -11,7 +11,7 @@ makedepends=('git' 'go>=1.5')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$pkgname::git+$url")
-sha256sums=('SKIP')
+sha512sums=('SKIP')
_sourcedirectory="$pkgname"
_bindir="$pkgname-bin"
@@ -24,7 +24,7 @@ prepare() {
pkgver() {
cd "$srcdir/$_sourcedirectory/"
- git describe --long --tags | sed -e 's/-\([^-]*-g[^-]*\)$/-r\1/' -e 's/-/./g'
+ git describe --long --tags | sed -e 's/^v//' -e 's/-\([^-]*-g[^-]*\)$/-r\1/' -e 's/-/./g'
}
build() {
@@ -34,10 +34,7 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -modcacherw"
- go mod init "software.sslmate.com/src/$_pkgname"
- go mod tidy
- export GOFLAGS="$GOFLAGS -mod=readonly"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
go build -v -o "$srcdir/$_bindir/" './...'
}