summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Conzelmann2015-06-16 22:26:34 +0200
committerManuel Conzelmann2015-06-16 22:26:34 +0200
commit6870f9cd385c3471186942cc6ca5c127565e2c72 (patch)
tree1b75d5f317414dc927252f92c6d00da3fa638749
downloadaur-6870f9cd385c3471186942cc6ca5c127565e2c72.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD50
-rw-r--r--cewe-fotobuch.desktop8
-rw-r--r--cewe-fotobuch.install18
5 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c439378a259
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by makepkg 4.2.1
+# Tue Jun 16 20:07:36 UTC 2015
+pkgbase = cewe-fotobuch
+ pkgdesc = an offline client for creating photobooks, uploading and ordering them at cewe.de
+ pkgver = 6.0.4
+ pkgrel = 1
+ url = http://www.cewe.de/
+ install = cewe-fotobuch.install
+ arch = i686
+ arch = x86_64
+ license = custom:eula
+ makedepends = unzip
+ depends = libx11
+ depends = libjpeg
+ depends = curl
+ depends = wget
+ source = http://dls.photoprintit.de/download/Data/16523/hps/setup_Mein_CEWE_FOTOBUCH.tgz
+ source = cewe-fotobuch.desktop
+ md5sums = 9f66120c74bd43701d1b6e639a10dac1
+ md5sums = 481ac82e95881d2878da3973d29095f6
+
+pkgname = cewe-fotobuch
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1e2a59b8b6ea
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+pkgbuild_old
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f6c16dafe61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: Jozef Riha <jose1711 at gmail dot com>
+# Updated by Manuel Conzelmann, changed to non-branded software
+
+pkgname=cewe-fotobuch
+pkgver=6.0.4
+pkgrel=1
+pkgdesc="an offline client for creating photobooks, uploading and ordering them at cewe.de"
+url="http://www.cewe.de/"
+license=("custom:eula")
+depends=('libx11' 'libjpeg' 'curl' 'wget')
+makedepends=('unzip')
+arch=('i686' 'x86_64')
+source=("http://dls.photoprintit.de/download/Data/16523/hps/setup_Mein_CEWE_FOTOBUCH.tgz"
+"cewe-fotobuch.desktop")
+install=cewe-fotobuch.install
+md5sums=('9f66120c74bd43701d1b6e639a10dac1'
+ '481ac82e95881d2878da3973d29095f6')
+
+_KEYACCID=16523
+_CLIENTID=18
+
+
+build() {
+ cd $srcdir
+# # download list of links
+# wget -O url_list.txt "http://dls.photoprintit.de/download/Data/${_KEYACCID}/hps/${_CLIENTID}-index-$pkgver.txt" || return 1
+# echo "Downloading and extracting files.."
+# for url in $(awk -F\; '{print $1}' url_list.txt|egrep -v "dll|cewe|setup_Mueller|setup_Fotostar|setup_Meine_CeWe_Fotowelt_de|setup_Moj_CeWe"); do
+# wget "http://dls.photoprintit.de/$url" || return 1
+# unzip -o -d $srcdir $(basename $url) || return 1
+# done
+}
+package() {
+ mkdir -p $pkgdir/usr/{share/$pkgname,bin}
+ cd $srcdir
+ ./install.pl --installDir=$pkgdir/usr/share/cewe-fotobuch --workingDir=$srcdir -k -v
+# # copy EULA
+# install -D -m644 $srcdir/EULA.txt $pkgdir/usr/share/$pkgname/EULA.txt || return 1
+ # create startup script
+ (echo "#!/bin/bash
+ cd /usr/share/$pkgname
+ ./cewe-fotobuch \"\$@\"") > $pkgdir/usr/bin/cewe-fotobuch
+ chmod 755 $pkgdir/usr/bin/cewe-fotobuch
+ # utf-8 and space in executable filenames is generally a bad idea
+ cd $pkgdir/usr/share/$pkgname
+ mv "Mein CEWE FOTOBUCH" "cewe-fotobuch"
+ # create desktop shortcut
+ install -D -m644 $pkgdir/usr/share/$pkgname/Resources/keyaccount/32.xpm $pkgdir/usr/share/pixmaps/cewe-fotobuch.xpm && \
+ install -D -m644 $srcdir/cewe-fotobuch.desktop $pkgdir/usr/share/applications/cewe-fotobuch.desktop || return 1
+}
diff --git a/cewe-fotobuch.desktop b/cewe-fotobuch.desktop
new file mode 100644
index 000000000000..0f295bf4f854
--- /dev/null
+++ b/cewe-fotobuch.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=CeWe Fotobuch
+Comment=Offline client for cewe.de service
+Exec=cewe-fotobuch
+Icon=cewe-fotobuch
+StartupNotify=true
+Categories=Graphics;Photography;
diff --git a/cewe-fotobuch.install b/cewe-fotobuch.install
new file mode 100644
index 000000000000..963d713a2127
--- /dev/null
+++ b/cewe-fotobuch.install
@@ -0,0 +1,18 @@
+post_install() {
+ echo '--------------------------------------------------'
+ echo 'You *MUST* read and agree to the license stored in'
+ echo '/usr/share/cewe-fotobuch/EULA.txt before'
+ echo 'you start using it'
+ echo '--------------------------------------------------'
+
+ chmod 775 /usr/share/cewe-fotobuch
+ /bin/true
+}
+
+post_upgrade() {
+/bin/true
+}
+
+pre_remove() {
+/bin/true
+} \ No newline at end of file