summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Crompton2016-03-08 21:57:13 +0100
committerJames Crompton2016-03-08 21:57:13 +0100
commit699d745e8c558a0738b301ebb83668318ff42c13 (patch)
tree516341132aec46e70e666751562b7ee0f9238ea4
parente1bf08373c00df2367029547f19ac983df70677b (diff)
downloadaur-699d745e8c558a0738b301ebb83668318ff42c13.tar.gz
Signal upgrade to avoid requests for confirmation
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5491e276dd3a..a9c098792693 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,9 +47,9 @@ package() {
# don't show EULA/ask for confirmation if package is already installed
which $pkgname &>/dev/null && update='--update'
# keep packages unless updating from within application
- [[ -z "$_UPDATING" ]] && keepPackages='-k'
+ [[ -z "$_UPDATING" ]] && update='-k --upgrade'
- ./install.pl $update $keepPackages --installDir=$_installDir -v
+ ./install.pl $update --installDir=$_installDir -v
install -m644 -b updater.pl $_installDir/updater.pl
install -D -m644 $srcdir/EULA.txt $pkgdir/usr/share/licenses/$pkgname/EULA.txt
# pixmap for legacy customised mimetypes